Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 373347

Summary: net-dialup/radiusclient fails to crosscompile
Product: Gentoo Linux Reporter: Bertrand Jacquin <bertrand>
Component: Current packagesAssignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it <maintainer-needed>
Status: RESOLVED WONTFIX    
Severity: normal CC: alexander, bertrand, net-dialup, reviewers+disabled, treecleaner
Priority: Normal Keywords: PATCH, PMASKED
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://freshmeat.net/projects/radiusclient/tickets/2c46a43c4ab
See Also: https://github.com/gentoo/gentoo/issues/175
Whiteboard: Pending removal: 2016-09-20
Package list:
Runtime testing required: ---
Attachments: files/radiusclient-0.3.2-BJA-cross.diff

Description Bertrand Jacquin 2011-06-28 14:23:47 UTC
adiusclient configure failed when cross compiling as no fallback method to handling this :

checking for stricmp... no 
checking for random... yes 
checking for rand... yes 
checking for snprintf... yes 
checking for vsnprintf... yes 
checking for field domainname in struct utsname... configure: error: in `/usr/i586-geode-linux-gnu/tmp/portage/net-dialup/radiusclient-0.3.2/work/radiusclient-0.3.2': 
configure: error: cannot run test program while cross compiling 
See `config.log' for more details

Here is a patch to let user define utsname status by defining ac_cv_struct_utsname

There is another fix for /dev/urandom that is tested on build host. But this file can don't exist on target host. So let user define ac_cv_file__dev_urandom

Reproducible: Always

Steps to Reproduce:
1. i586-geode-linux-gnu-emerge -vat radiusclient
2.
3.
Comment 1 Bertrand Jacquin 2011-06-28 14:24:24 UTC
Created attachment 278503 [details, diff]
files/radiusclient-0.3.2-BJA-cross.diff
Comment 2 Bertrand Jacquin 2013-06-11 20:55:53 UTC
Any news on this bug team net-dialup ?
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-10-10 07:56:01 UTC
https://github.com/gentoo/gentoo/pull/175

Please let us know if it's ok to merge.
Comment 4 Sergey Popov gentoo-dev 2015-10-17 10:05:05 UTC
The only one consumer in tree is mail-mta/exim and it still uses old radiusclient API, thus neither net-dialup/freeradius-client nor net-dialup/radiusclient-ng are suitable for it

I thought that i can fix this, but i have failed :-(
Comment 5 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-10-17 11:16:20 UTC
Is it ok to merge this then?
Comment 6 Alexander Tsoy 2015-10-17 15:16:10 UTC
(In reply to Sergey Popov from comment #4)
Have you tried "RADIUS_LIB_TYPE=RADIUSCLIENTNEW" instead of "RADIUS_LIB_TYPE=RADIUSCLIENT"?
Comment 7 Alexander Tsoy 2015-10-17 16:39:32 UTC
OK. With a little patch I managed to build exim with freeradius-client and radiusclient-ng. However supporting both of them is painful since header names and config file paths are different. Also I didn't performed any runtime test.
Comment 8 Alexander Tsoy 2015-10-17 22:00:03 UTC
exim + freeradius-client works perfectly. I opened bug 563356
Comment 9 Pacho Ramos gentoo-dev 2016-08-18 17:44:19 UTC
CCing treecleaners as nothing needs this anymore
Comment 10 Brian De Wolf 2016-09-30 21:13:08 UTC
Please don't remove this package just yet as libradiusclient.so.0 is used by net-analyzer/nagios-plugins.  In older versions (1.4.16-r2), the dependency was controlled by a USE flag so it was visible.  It was changed to rely on "automagic dependencies", thus the dependency is no longer explicitly defined.
Comment 11 Pacho Ramos gentoo-dev 2016-10-01 07:01:25 UTC
removed