Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 373281

Summary: app-editors/xemacs-21.5.31 fails to emerge, because check-features.el can not be loaded
Product: Gentoo Linux Reporter: Juergen Rose <rose>
Component: Current packagesAssignee: XEmacs team <xemacs>
Status: RESOLVED WORKSFORME    
Severity: normal    
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: /var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log
patch to fix compilation of check-features.pl
New ebuild that applies the check-features patch

Description Juergen Rose 2011-06-28 04:48:59 UTC
'emerge -v1 xemacs' fails with:
...
Compiling /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/mule/custom-load.el...
Wrote /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/mule/custom-load.elc
Building finder database ...
rm -f /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src/../lisp/finder-inf.el
./xemacs -no-packages -batch    -eval "(setq finder-compile-keywords-quiet t)" \
        -eval "(setq lisp-directory \"/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src/../lisp\")" \
        -l finder -f finder-compile-keywords

Wrote /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/finder-inf.el
Building finder database ...(done)
Testing for Lisp shadows ...
./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"make[1]: *** [check-features] Error 255
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
make: *** [check-features] Error 2
emake failed
 * ERROR: app-editors/xemacs-21.5.31 failed (install phase):


Reproducible: Always




root@condor:/root(25)# emerge --info =app-editors/xemacs-21.5.31
Portage 2.1.10.3 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.39-gentoo-r2 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.39-gentoo-r2-x86_64-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-gentoo-2.0.3
Timestamp of tree: Sun, 26 Jun 2011 14:30:01 +0000
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.2
dev-util/cmake:           2.8.4-r1
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21
sys-devel/gcc:            4.4.5, 4.5.2
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.38 (virtual/os-headers)
sys-libs/glibc:           2.13-r2
Repositories: gentoo java-overlay lordvan science x11 sunrise arcon local x-cpan g-octave
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ rsync://ftp.fi.muni.cz/pub/linux/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo rsync://gd.tuwien.ac.at/opsys/linux/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo http://gentoo.oregonstate.edu"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/lordvan /var/lib/layman/science /var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/arcon /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="64bit R X Xaw3d a52 aac abiword accessibility acl acpi admin afs alsa amd64 ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion beagle berkdb blas blast bluetooth boo boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli consolekit corba cracklib crypt css cuda cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hvm hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea kqemu kvm ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lirc lm_sensors lua lzo mad mail maildir mapnik math matroska mkl mmx mmxext mng modules mono moonlight motif mozilla mp3 mp4 mpeg mpi mpi-threads mplayer mtp mudflap multilib musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool samba sasl science sdk sdl secure-delete semantic-desktop server session sip slang slp smbclient smp sms sndfile snmp soup sox speex spell sql sqlite sse sse2 ssl ssse3 startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 video virtualbox vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 xattr xcb xemacs xext xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="tda10045 tda10046lifeview" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nv nouveau vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-editors/xemacs-21.5.31 was built with the following:
USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule (multilib) neXt png postgres tiff -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xft -xim"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"



root@condor:/root(26)# emerge -pqv =app-editors/xemacs-21.5.31
[ebuild   R   ] app-editors/xemacs-21.5.31  USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xft -xim"
Comment 1 Juergen Rose 2011-06-28 04:53:30 UTC
Created attachment 278427 [details]
/var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log
Comment 2 Hans de Graaff gentoo-dev 2011-06-30 18:12:22 UTC
Hmm, with your combination of USE flags xemacs doesn't even compile for me. Are you sure that this is the correct set?
Comment 3 Juergen Rose 2011-07-01 05:29:28 UTC
root@condor:/root(2)# emerge -pv1 xemacs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-editors/xemacs-21.5.31  USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xft -xim" 0 kB


What is problematic with these flags? What flags should I remove? I am convinced that I could xemacs emerge with these flags in the past.
Comment 4 Hans de Graaff gentoo-dev 2011-07-01 06:01:56 UTC
(In reply to comment #3)
> root@condor:/root(2)# emerge -pv1 xemacs
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild   R    ] app-editors/xemacs-21.5.31  USE="X Xaw3d alsa berkdb gdbm gif
> gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -debug -dnd
> -eolconv -esd -freewnn -nas -pop -xface -xft -xim" 0 kB
> 
> 
> What is problematic with these flags? What flags should I remove? I am
> convinced that I could xemacs emerge with these flags in the past.

The combination of "motif -xft" exposed a bug in the xemacs source code causing compilation failure, at least with openmotif 2.3.3.

I fixed that last night, but I can't reproduce the check-features.el failure.
Comment 5 Juergen Rose 2011-07-01 08:58:36 UTC
At two systems at home 'emerge xemacs' fails with this check-features.el issue, at work, where I can check it now, I have the same USE flags, openmotif-2.3.3 is installed and the reemerge of xemacs-21.5.31 works like a charm:


root@moose:/root(4)# qlist -Iv openmotif
app-doc/openmotif-manual-2.3.0
x11-libs/openmotif-2.3.3


root@moose:/root(5)# emerge -pvD xemacs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-editors/xemacs-21.5.31  USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xft -xim" 0 kB


root@moose:/root(6)# emerge -vD xemacs

These are the packages that would be merged, in order:

...

--- replaced dir /usr/bin
--- replaced dir /usr
>>> Regenerating /etc/ld.so.cache...
>>> Original instance of package unmerged safely.
 * If you are upgrading from XEmacs 21.4 you should note the following
 * incompatibilities:
 * - Mule-UCS is no longer supported due to proper UTF-8 support in XEmacs 21.5
 * - The X resource class has changed from Emacs to XEmacs,
 *   settings in your .Xdefaults file should be updated accordingly.
>>> app-editors/xemacs-21.5.31 merged.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 382 info files.


root@moose:/root(7)# genlop -t xemacs | tail -n 15
     Mon May  2 15:15:18 2011 >>> app-editors/xemacs-21.5.31
       merge time: 1 minute and 48 seconds.

     Thu Jun 23 17:01:12 2011 >>> app-editors/xemacs-21.5.31
       merge time: 1 minute and 53 seconds.

     Fri Jun 24 03:28:39 2011 >>> app-editors/xemacs-21.5.31
       merge time: 2 minutes and 6 seconds.

     Fri Jul  1 10:13:17 2011 >>> app-editors/xemacs-21.5.31
       merge time: 1 minute and 55 seconds.

     Fri Jul  1 10:20:16 2011 >>> app-editors/xemacs-21.5.31
       merge time: 2 minutes and 22 seconds.


The only USE flag I have set especially for xemacs (i.e. in /etc/portage/package.use) is the mule flag, the rest is from /etc/make.conf.

If I look in the output 'emerge -vD xemacs' on moose (where it works) for check-features.el, I see:
...
Wrote /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/finder-inf.el
Building finder database ...(done)
./xemacs -no-packages -batch -l check-features.el
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
>>> Completed installing xemacs-21.5.31 into /var/tmp/portage/app-editors/xemacs-21.5.31/image/

strip: x86_64-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/etags-xemacs
   usr/bin/ellcc
   usr/bin/xemacs-21.5-b31
 
Could it be that the issue is a MAKEOPTS problem? At moose with 'MAKEOPTS="-j5"'
 it works, at condor probably with 'MAKEOPTS="-j3"' it fails.
Comment 6 Hans de Graaff gentoo-dev 2011-07-07 05:00:30 UTC
(In reply to comment #3)

> What is problematic with these flags? What flags should I remove? I am
> convinced that I could xemacs emerge with these flags in the past.

My problem was with motif[xft] and xemacs[-xft], which is something that the ebuild actually does not allow. I was compiling outside of the package manager so I didn't notice this. Using motif[-xft] and xemacs[-xft] should work fine.
Comment 7 Hans de Graaff gentoo-dev 2011-07-07 05:17:09 UTC
(In reply to comment #5)
> At two systems at home 'emerge xemacs' fails with this check-features.el issue,
> at work, where I can check it now, I have the same USE flags, openmotif-2.3.3
> is installed and the reemerge of xemacs-21.5.31 works like a charm:

> Could it be that the issue is a MAKEOPTS problem? At moose with
> 'MAKEOPTS="-j5"'
>  it works, at condor probably with 'MAKEOPTS="-j3"' it fails.

It's unlikely to be related to MAKEOPTS, but it's easy to test for by using MAKEOPTS="-j1" and trying to install.

check-features.el is not something that is generated, it just tests for working tooltalk and sparcworks support. I don't really see how this would fail, especially with a "could not load" error.

Things to try: go to the build directory, cd into src, and run "./xemacs -no-packages -batch check-features.el" by hand. It could be useful to use strace with it to determine what is really going on: "strace -o out ./xemacs -no-packages -batch check-features.el"
Comment 8 Juergen Rose 2011-08-17 07:07:07 UTC
I had this problem again on an other computer during 'emerge -uveDN system'.
The xft USE flag was originally meither for openmotif nor xemacs set. Adding it to both packages does not remove the error. MAKEOPTS="-j1" is set.

If I cd to /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src
and try './xemacs -no-packages -batch check-features.el', it runs without problems, but './xemacs -no-packages -batch -l check-features.el' fails:

Testing for Lisp shadows ...
./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"make[1]: *** [check-features] Error 255
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
make: *** [check-features] Error 2
emake failed
 * ERROR: app-editors/xemacs-21.5.31 failed (install phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_install
 *   environment, line 2767:  Called die
 * The specific snippet of code:
 *       emake prefix="${D}"/usr mandir="${D}"/usr/share/man/man1 infodir="${D}"/usr/share/info libdir="${D}"/usr/$(get_libdir) datadir="${D}"/usr/share install gzip-el || die;
 * 
 * If you need support, post the output of 'emerge --info =app-editors/xemacs-21.5.31',
 * the complete build log and the output of 'emerge -pqv =app-editors/xemacs-21.5.31'.
 * The complete build log is located at '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/environment'.
 * S: '/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31'

>>> Failed to emerge app-editors/xemacs-21.5.31, Log file:

>>>  '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log'
root@grizzly:/root(23)# cd /var/tmp/portage/app-editors/xemacs-21.5.31/           
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(26)# grep MAKEO /etc/make.conf
MAKEOPTS="-j1"
#MAKEOPTS="-j2"
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(28)# ./xemacs -no-packages -batch check-features.el
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(29)# echo $?
0
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(30)# ./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(31)# 


So I run 'strace -o strace_xemacs.log -f ./xemacs -no-packages -batch -l check-features.el' and searched for check-features.el in the result file:

root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(31)# strace -o strace_xemacs.log -f ./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(32)# grep check-features.el strace_xemacs.log
14152 execve("./xemacs", ["./xemacs", "-no-packages", "-batch", "-l", "check-features.el"], [/* 157 vars */]) = 0
14152 stat("/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src/check-features.el", 0x7fff99755780) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs/site-lisp/check-features.el.elc", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs/site-lisp/check-features.el.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs/site-lisp/check-features.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/mule/check-features.el.elc", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/mule/check-features.el.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/mule/check-features.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/check-features.el.elc", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/check-features.el.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/share/xemacs-21.5-b31/lisp/check-features.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib/xemacs/site-modules/check-features.el.ell", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib/xemacs/site-modules/check-features.el.so", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib/xemacs/site-modules/check-features.el.dll", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib/xemacs/site-modules/check-features.el.dylib", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib/xemacs/site-modules/check-features.el", 0x7fff997551c0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib64/xemacs-21.5-b31/x86_64-pc-linux/modules/check-features.el.ell", 0x7fff997551b0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib64/xemacs-21.5-b31/x86_64-pc-linux/modules/check-features.el.so", 0x7fff997551b0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib64/xemacs-21.5-b31/x86_64-pc-linux/modules/check-features.el.dll", 0x7fff997551b0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib64/xemacs-21.5-b31/x86_64-pc-linux/modules/check-features.el.dylib", 0x7fff997551b0) = -1 ENOENT (No such file or directory)
14152 stat("/usr/lib64/xemacs-21.5-b31/x86_64-pc-linux/modules/check-features.el", 0x7fff997551b0) = -1 ENOENT (No such file or directory)
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(33)# find . -name check-features.el

It seems, that there is really no check-features.el. If I go three directories upwards and search again, I find it:

root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src(34)# cd ../../..
root@grizzly:/var/tmp/portage/app-editors/xemacs-21.5.31(36)# find . -name check-features.el\*
./work/xemacs-21.5.31/lisp/check-features.elc
./work/xemacs-21.5.31/lisp/check-features.el


Then I removed /var/tmp/portage/app-editors/xemacs-21.5.31 and tried without success once more. As the next step I deinstalled xemacs and tried to install again. That works!

The next 'emerge -v1 xemacs' fails again with the usual error. I.e. 'emerge xemacs' works only if xemacs is not installed.

I have the feeling that this is an error.
Comment 9 Juergen Rose 2011-09-02 12:10:23 UTC
I hit this error again on the next system:

Wrote /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/finder-inf.el
Building finder database ...(done)
Testing for Lisp shadows ...
./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"make[1]: *** [check-features] Error 255
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
make: *** [check-features] Error 2
emake failed
 * ERROR: app-editors/xemacs-21.5.31 failed (install phase):


Any news?
Comment 10 Juergen Rose 2011-09-02 12:14:56 UTC
root@cheetah:/root(21)# emerge --info =app-editors/xemacs-21.5.31
Portage 2.1.10.11 (default/linux/x86/10.0/desktop, gcc-4.5.3, glibc-2.13-r4, 3.0.3 i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.0.3-i686-AMD_Athlon-tm-_XP_1800+-with-gentoo-2.0.3
Timestamp of tree: Fri, 02 Sep 2011 02:00:01 +0000
ccache version 3.1.6 [disabled]
app-shells/bash:          4.2_p10
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.2-r2, 3.2-r2
dev-util/ccache:          3.1.6
dev-util/cmake:           2.8.5-r2::science
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo java-overlay x11 sunrise science local x-cpan x-g-octave
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 skype-eula googleearth AdobeFlash-10.1 cadsoft"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de fr"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/science /usr/local/portage /var/lib/cpan /var/lib/g-octave"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext R X Xaw3d a52 aac abiword acl acpi admin afs alsa ao apache2 applet archive arpack asf aspell assistant audacious audiofile automap automount bash-completion beagle berkdb blas blast bluetooth boo boost branding bzip2 cairo cardbus cdda cddb cdf cdio cdparanoia cdr cgi chm cli consolekit corba cracklib crypt css cups curl cxx daap db dbase dbi dbm dbus declarative designer devhelp device-mapper dga dia djvu doc dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras fam fame ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpx fts3 fuse galago garmin gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp ginac git glade glib glpk gml gmp gmtsuppl gnome gnome-keyring gnome-print gnuplot gnutls gphoto2 gpm grammar graphics graphtft graphviz grass gs gsl gsm gstreamer gtk gudev guile harness hddtemp hdf hdf5 hdri http httpd hwdb iconv icq icu id3 ide imagemagick imap innodb inotify ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kdrive kerberos kpathsea ladspa lame lapack latex latex3 lcms ldap lensfun libffi libgda libnotify libsamplerate lm_sensors lua lzo mad mail maildir mapnik math matroska matrox mkl mmx mmxext mng modules mono moonlight motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking networkmanager nfs nls nntp nptl nptlonly nsplugin ntfs ntp numpy obex objc ocaml octave odbc ogdi ogg ole openexr opengl openmp overview pae pam pango pcre pda pdf perl plotutils plugins png podcast policykit portaudio posix postgres postscript ppds pppd preview-latex proj projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime readline reiserfs reports rle romio rpc rrdcgi rrdtool samba sasl science sdk sdl secure-delete semantic-desktop server session sip slang slp smbclient sms sndfile snmp soup sox speex spell sql sqlite sse ssl startup-notification stlport subtitles subversion suexec svg svm swig sysfs szip t1lib tcl tcpd tex tex4ht texmacs tgif theora threads thunderbird tidy tiff tk tntc tools truetype udev unicode usb userlocales utempter v4l2 video virtualbox vorbis wav webdav webdav-serf webkit wmf wxwidgets x264 x86 xattr xcb xemacs xext xft xine xml xmlreader xmlrpc xorg xpm xulrunner xv xvid xvmc yaml zlib zvbi" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="tda10045 tda10046lifeview" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de fr" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="mga matrox vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

app-editors/xemacs-21.5.31 was built with the following:
USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xft -xim"



root@cheetah:/root(23)# emerge -pqv =app-editors/xemacs-21.5.31
[ebuild   R   ] app-editors/xemacs-21.5.31  USE="X Xaw3d alsa berkdb gdbm gif gpm jpeg ldap motif mule neXt png postgres tiff xft* -athena -canna -debug -dnd -eolconv -esd -freewnn -nas -pop -xface -xim" 

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.




xft is set /etc/make.conf.
Comment 11 Juergen Rose 2011-09-02 12:57:49 UTC
And again I could use as a workaround, to delete xemacs and than emerge again world, what also emerged xemacs.
Comment 12 Juergen Rose 2012-01-13 14:48:39 UTC
Four month later 'emerge -vuNDe system' fails with this error:

Wrote /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/finder-inf.el
Building finder database ...(done)
./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"make[1]: *** [check-features] Error 255
make[1]: Leaving directory `/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
Comment 13 Hans de Graaff gentoo-dev 2012-01-14 08:58:14 UTC
Do you perhaps have an environment variable set up to find lisp or packages? Something like `EMACSEARLYPACKAGES',`EMACSLATEPACKAGES', `EMACSLASTPACKAGES' or something similar?
Comment 14 Juergen Rose 2012-02-02 15:54:59 UTC
I have this error at the next system, and there is not any environment variable containing EMACS
...
Testing for Lisp shadows ...
./xemacs -no-packages -batch -l check-features.el


xemacs exiting.
Cannot open load file: "check-features.el"make[1]: *** [check-features] Error 255
make[1]: Leaving directory `/var/tmp/portage_extra/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src'
make: *** [check-features] Error 2
 * ERROR: app-editors/xemacs-21.5.31 failed (install phase):
 *   emake failed
 * 
 * If you need support, post the output of 'emerge --info =app-editors/xemacs-21.5.31',
 * the complete build log and the output of 'emerge -pqv =app-editors/xemacs-21.5.31'.
 * The complete build log is located at '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/environment'.
 * S: '/var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31'

>>> Failed to emerge app-editors/xemacs-21.5.31, Log file:

>>>  '/var/tmp/portage/app-editors/xemacs-21.5.31/temp/build.log'
root@tiger:/root(24)# env | grep -i emacs 
VISUAL=emacs -nw
INFOPATH=/usr/share/info:/usr/share/binutils-data/i686-pc-linux-gnu/2.22/info:/usr/share/gcc-data/i686-pc-linux-gnu/4.5.3/info:/usr/share/info/emacs-23
root@tiger:/root(25)# env | grep -i lisp
Comment 15 Juergen Rose 2012-04-01 07:05:37 UTC
Any news?
Comment 16 Hans de Graaff gentoo-dev 2012-04-01 07:24:12 UTC
(In reply to comment #15)
> Any news?

No. I don't have much time for Gentoo at the moment and I can't reproduce this, which makes fixing this problem pretty much impossible for me...
Comment 17 CHI-YEH CHEN 2013-02-17 11:58:08 UTC
I also have this problem.
But I try link to work tree. 
be like this
	ln -s /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/lisp/check-features.el /var/tmp/portage/app-editors/xemacs-21.5.31/work/xemacs-21.5.31/src/check-features.el
into src_prepared() in xemacs-21.5.31.ebuild

It will build success.
Can anyone update this command reference environment to xemacs-21.5.31.ebuild.
Comment 18 Alexandre Ferreira 2013-04-11 04:27:26 UTC
Same problem here. The attached patch and ebuild allows it to compile cleanly in my machine. The problem is the missing $(LIST) for the check-features.el.
Comment 19 Alexandre Ferreira 2013-04-11 04:29:16 UTC
Created attachment 345166 [details, diff]
patch to fix compilation of check-features.pl

This patch just add the $(LIST) at the Makefile.in.in
Comment 20 Alexandre Ferreira 2013-04-11 04:30:05 UTC
Created attachment 345168 [details]
New ebuild that applies the check-features patch
Comment 21 Mats Lidell gentoo-dev 2013-04-11 21:51:59 UTC
Thanks for the patch. I'm working on the my first xemacs ebuilds (and have some other problems to get that right) but when I'm done with it I'll take a closer look on this.
Comment 22 Mats Lidell gentoo-dev 2014-07-05 16:23:37 UTC
I'm afraid I can't reproduce this problem. There has been some fixes related to loading elisp files during the build in the latest ebuilds. Is this still a problem in the latest, 21.5.34-r2, ebuild?
Comment 23 Mats Lidell gentoo-dev 2014-08-01 21:08:59 UTC
From the description it sounds like similar problems that has been solved with xemacs-21.5.34-r2. Please reopen bug if problem still occurs with xemacs-21.5.34-r2 or later.