Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 37268

Summary: iputils-021109.ebuild fails to compile
Product: Gentoo Linux Reporter: Derek Dolney <z23>
Component: Current packagesAssignee: Joshua Kinard <kumba>
Severity: normal CC: aliz, friemann, plasmaroo, vapier
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Package list:
Runtime testing required: ---

Description Derek Dolney 2004-01-04 19:10:48 UTC
This ebuild seems to have changed around Jan 4, though the Changelog says nothing about it. The new ebuild fails. Seems it can't find headers:

Calculating dependencies ...done!
>>> emerge (1 of 1) net-misc/iputils-021109 to /
>>> md5 src_uri ;-) iputils-ss021109-try.tar.bz2
>>> Unpacking source...
>>> Unpacking iputils-ss021109-try.tar.bz2 to /var/tmp/portage/iputils-021109/work
>>> Source unpacked.
gcc -march=athlon-tbird -O3 -fomit-frame-pointer -pipe -include ../include-glibc/glibc-bugs.h -I../include-glibc -I/usr/src/linux/include -DIPSEC_DEBUG -DIPSEC -DINET6 -Wall   -c -o ipsec_dump_policy.o ipsec_dump_policy.c
gcc -march=athlon-tbird -O3 -fomit-frame-pointer -pipe -include ../include-glibc/glibc-bugs.h -I../include-glibc -I/usr/src/linux/include -DIPSEC_DEBUG -DIPSEC -DINET6 -Wall   -c -o key_debug.o key_debug.c
In file included from ../include-glibc/netinet/ipsec.h:1,
                 from ipsec_dump_policy.c:37:
../include-glibc/net/pfkeyv2.h:5:27: linux/pfkeyv2.h: No such file or directory
In file included from /usr/src/linux/include/net/sock.h:37,
                 from /usr/src/linux/include/linux/ipsec.h:18,
                 from ../include-glibc/netinet/ipsec.h:2,
                 from ipsec_dump_policy.c:37:
/usr/src/linux/include/linux/timer.h:17: error: field `list' has incomplete type

...(truncated). I have this header only in /usr/src/linux-2.4.22-gentoo-r2/net/ipsec/libfreeswan/pfkeyv2.h

Portage 2.0.49-r20 (default-x86-1.4, gcc-3.3.2, glibc-2.3.3_pre20031222-r0, 2.4.22-gentoo-r2)
System uname: 2.4.22-gentoo-r2 i686 AMD Athlon(tm) Processor
Gentoo Base System version
CFLAGS="-march=athlon-tbird -O3 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-march=athlon-tbird -O3 -fomit-frame-pointer -pipe"
FEATURES="autoaddcvs ccache sandbox userpriv"
USE="3dnow X acpi alsa bonobo dvd fam gdbm gif gnome gpm gtk gtk2 java jpeg maildir mmx mozilla mpeg ncurses oggvorbis opengl oss pam perl png python quicktime readline slang spell ssl tcltk tetex truetype usb x86 xml2 xmms xv zlib"
Comment 1 Joshua Kinard gentoo-dev 2004-01-05 12:45:39 UTC
What linux-headers are you using?
Comment 2 Derek Dolney 2004-01-05 12:56:03 UTC
I'm using linux-headers-2.4.21-r1
Comment 3 Felix Riemann 2004-01-05 14:35:46 UTC
It seems to be related to the installed kernel, since it works with 
an installed 2.6 kernel using linux-headers-2.4.21 here. It didn't work during my 
last stage1 installation (2 days ago) with the live-cd-kernel (2.4.21 I think) and 
linux-headers-2.4.21, which I emerged before bootstrapping.
I had to emerge an older iputils to continue, but after emerging the new kernel an upgrade worked fine (besides of a missing dependency to dev-util/yacc)
The file pfkeyv2.h seems not exist in the 2.4.21 sources, but it does in the 2.6-sources.
Comment 4 Derek Dolney 2004-01-06 08:26:09 UTC
It also fails on my laptop which is running 2.4.20-gentoo-r9, also with linux-headers-2.4.21-r1
Comment 5 Kayne K 2004-01-07 08:06:48 UTC
I have also recieved this running gentoo-sources 2.4.20-r8 and 2.4.22-r2 and 2.4.22-r3.
Comment 6 Kayne K 2004-01-07 08:22:48 UTC
ditto on linux-headers-2.4.22
Comment 7 Kayne K 2004-01-07 09:22:41 UTC
ditto on linux-headers-2.4.23 as well
Comment 8 Joshua Kinard gentoo-dev 2004-01-08 02:36:33 UTC
Looks like these lines were recently added:

        use static && LDFLAGS="${LDFLAGS} -static"
        cd ${S}/libipsec && emake KERNEL_INCLUDE="/usr/include" || die
        cd ${S}/setkey && emake KERNEL_INCLUDE="/usr/include" || die
        cd ${S}/racoon && autoconf || die

Plasmaroo: your name is last in the cvs header, you add these lines or know who did and/or what they do?

If not, I'll comment them out until someone knows what they do and can implement them w/o causing the compile to hose itself.  This package is rather picky about how it's compiled.  I wish there was something better to replace it with.
Comment 9 Tim Yamin (RETIRED) gentoo-dev 2004-01-08 05:53:30 UTC
> This package is rather picky about how it's compiled.

Sure is - that's why I added those lines to get it to work properly on weird cases of GCC and linux-headers.

Now, after doing some testing and finding out that things were behaving totally differently for no apparent reason, one can easily say that sys-apps/portage-2.0.49-r21 messes this up. I tested iputils with those lines over various 2.4 headers over and over and over, and things worked. They still do with -r20, but not with -r21.

A hot-fix for 2.4 is to add "if [ -e ${ROOT}/usr/include/linux/pfkeyv2.h ]; then" ... "fi" ... around those lines but that would then not compile some libraries and also would kill 2.6 support.
Comment 10 merwan kashouty 2004-01-08 08:05:13 UTC
ok same issue here from stage1 and an emerge system on ~ppc , i went with the downgrade to iputils-020927 and use of /etc/portage/package.mask and umask files to get around this and continue the install
Comment 11 Tim Yamin (RETIRED) gentoo-dev 2004-01-08 09:31:19 UTC
OK, this is fixed - it seems that the subdirectory Makefiles pull off the /usr/src tree which is why you get those errors rather than the override. This is now fixed in CVS, ``emerge sync'' and things should work.
Comment 12 Derek Dolney 2004-01-08 09:50:17 UTC
Works for me now.