Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 372443

Summary: net-misc/remmina-plugins-0.9.2 does not compile against net-misc/freerdp-9999
Product: Gentoo Linux Reporter: Gabor MARTON <dodver>
Component: Current packagesAssignee: Markos Chandras (RETIRED) <hwoarang>
Status: RESOLVED FIXED    
Severity: normal CC: dan
Priority: Normal Keywords: InVCS
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: remmina live ebuild
remmina-plugins live ebuild
remmina-plugins live ebuild
remmina live ebuild

Description Gabor MARTON 2011-06-21 08:12:00 UTC
net-misc/remmina-plugins-0.9.2  USE="nls nx rdesktop ssh telepathy vnc xdmcp" won't compile, giving the following error:

remminapluginrdp.c: In function 'remmina_plugin_rdp_main':
remminapluginrdp.c:232: error: 'rdpSet' has no member named 'tls'
remminapluginrdp.c: In function 'remmina_plugin_rdp_init':
remminapluginrdp.c:362: error: 'rdpSet' has no member named 'tls'
make[2]: *** [remmina_plugin_rdp_la-remminapluginrdp.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
remminapluginrdpui.c: In function 'remmina_plugin_rdpui_create_colormap':
remminapluginrdpui.c:1746: error: 'RD_PALETTE' has no member named 'ncolors'
remminapluginrdpui.c:1754: error: 'RD_PALETTE' has no member named 'colors'
remminapluginrdpui.c:1755: error: 'RD_PALETTE' has no member named 'colors'
remminapluginrdpui.c:1756: error: 'RD_PALETTE' has no member named 'colors'
remminapluginrdpui.c: In function 'remmina_plugin_rdpui_pre_connect':
remminapluginrdpui.c:1912: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1913: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1915: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1916: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1922: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1925: warning: assignment from incompatible pointer type
remminapluginrdpui.c:1937: error: 'rdpInst' has no member named 'ui_create_colormap'
remminapluginrdpui.c:1939: error: 'rdpInst' has no member named 'ui_set_colormap'
remminapluginrdpui.c: In function 'remmina_plugin_rdpui_check_fds':
remminapluginrdpui.c:2016: error: 'rdpInst' has no member named 'rdp_send_input'
remminapluginrdpui.c:2021: warning: ignoring return value of 'read', declared with attribute warn_unused_result
make[2]: *** [remmina_plugin_rdp_la-remminapluginrdpui.lo] Error 1


Reproducible: Always

Steps to Reproduce:
1. emerge net-misc/remmina-plugins
2. Wait
3. And there is goes!
Actual Results:  
net-misc/remmina-plugins didn't manage to compile.

Expected Results:  
Compiled net-misc/remmina-plugins package

Portage 2.1.9.42 (default/linux/x86/10.0/desktop, gcc-4.4.5, libc-0-r0, 2.6.36-gentoo-r5-hatak i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r5-hatak-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.2
Timestamp of tree: Tue, 21 Jun 2011 07:15:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.5.4-r4, 2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.1.2, 4.3.4, 4.4.5
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.38
sys-libs/glibc:      2.12.2
virtual/os-headers:  0
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula AdobeFlash-10 AdobeFlash-10.1 Q3AEULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.inf.elte.hu/ http://de-mirror.org/distro/gentoo/ http://gentoo.mneisen.org/"
LANG="en_US"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync1.at.gentoo.org/gentoo-portage"
USE="X a52 aac accessibility acl acpi ads alsa amarok apache2 auto-completion automount bash-completion berkdb branding bzip2 cairo cdr cli consolekit cracklib crypt ctrlmenu cups curl cxx dahdi dbus declarative dga dri dts dvd dvdr embedded emboss encode exif extras fam ffmpeg firefox flac foomaticdb fortran fts3 gd gdbm gdu geoip geolocation gif gimp git gnutls gphoto2 gpm gtk h323 hardened httpd iconv icu id3 id3tag iproute2 ipv6 jabber java jpeg jpeg2k kde kdrive kipi lastfm latex lcms ldap lensfun libnotify libsamplerate libssh2 libsysfs libv4l2 lightning live login-watch logrotate logwatch mad maildir mktemp mmx mmxext mng modules mp2 mp3 mp3rtp mp3tunes mp4 mp4live mpeg mpeg2 mplayer msn mudflap musicbrainz mysql mysqli ncurses network newt nfs nls nptl nptlonly nsplugin nx nxclient ogg opengl openmp openvpn oscar otr pam pango pcre pdf perl pidgin plasma plotutils png policykit postscript ppds pppd prediction pvr python qt3support qt4 quotas rdesktop rdesktop-vrdp rdp rdpusb readline remote rtc samba schroedinger sdl semantic-desktop server session sip skins snmp sockets spell sql sqlite sse sse2 ssh ssl startup-notification static-libs stream subtitles subversion suidcheck svg sysfs syslog tcpd teamarena telepathy threads thunderbird tiff tk transparency truetype udev unicode unique usb userlocales v4l v4l2 vboxwebsrv vhosts video visualization vnc vorbis vte wav webkit win32codecs wma wmf x264 x86 xcb xdmcp xml xmp xorg xosd xscreensaver xulrunner xv xvid zaptel zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" FOO2ZJS_DEVICES="hpp1006" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Daniel M. Weeks 2011-06-22 08:29:12 UTC
What version of freerdp do you have installed and what use flags are enabled/disabled?
Comment 2 Gabor MARTON 2011-06-22 08:46:00 UTC
net-misc/freerdp-9999  USE="X alsa cups gnutls iconv ipv6 libsamplerate ssl -debug -nss -polarssl"

And that is the problem. I'm using the GIT version of freerdp. I reinstalled the older version net-misc/freerdp-0.8.2  USE="X alsa cups gnutls iconv ipv6 libsamplerate ssl -debug -nss -polarssl" and now remmina-plugins compiles fine.

My problem then is that this older release has a lot of problems with keyboard layouts. For example the cursor keys does not function as cursor keys, makes freerdp unusable.
Comment 3 Daniel M. Weeks 2011-06-22 23:05:21 UTC
The brokenness caused by freerdp API changes were fixed back in April and then again in June but a new version has not been released that includes those changes. (http://remmina.git.sourceforge.net/git/gitweb.cgi?p=remmina/remmina;a=summary)

I actually have the same problem with the current version of freerdp in the tree. I'll do a live remmina ebuild tonight and attach it/make it available in my overlay.
Comment 4 Daniel M. Weeks 2011-06-23 18:22:03 UTC
Created attachment 277899 [details]
remmina live ebuild
Comment 5 Daniel M. Weeks 2011-06-23 18:22:26 UTC
Created attachment 277901 [details]
remmina-plugins live ebuild
Comment 6 Gabor MARTON 2011-06-23 18:27:15 UTC
Thank you for your work. Could you please point to an url where I can read about how to use these ebuild? Or will they get into the portage tree?
Comment 7 Daniel M. Weeks 2011-06-23 18:28:26 UTC
Obviously both remmina ebuilds and the freerdp-9999 ebuild in the tree will need manual keywords (live ebuilds). However, they all seem to compile and play nice. I've listed the specific commits below as a reference/historical notation.

remmina:54e63fea0f6519aa77da9bcecc3215fc0f79aa15
freerdp:d6c5514f191aada3c308b1bdda3a3d6f9f422193
remmina-plugins:54e63fea0f6519aa77da9bcecc3215fc0f79aa15
Comment 8 Daniel M. Weeks 2011-06-23 18:29:26 UTC
Created attachment 277903 [details]
remmina-plugins live ebuild

Use the same source location as remmina-9999.
Comment 9 Daniel M. Weeks 2011-06-23 18:30:26 UTC
Created attachment 277905 [details]
remmina live ebuild

Use single source location (same as remmina-plugins-9999).
Comment 10 Daniel M. Weeks 2011-06-23 18:31:21 UTC
I've tweaked the ebuilds a bit to prevent a git-src directory from being created for each repo.
Comment 11 Daniel M. Weeks 2011-06-23 18:39:36 UTC
Gabor, I'm not a dev, but Markos is listed at the maintainer for Remmina so he'll decide if it goes in the tree.

As far as using the ebuilds as-is:
You will need to create an overlay and then add the ebuilds to it - editing them to include a keyword for your arch. If you're unfamiliar with overlays, I would recommend taking a look at http://en.gentoo-wiki.com/wiki/Overlay, specifically the section on Creating a Local Overlay. Feel free to send me an email if you have any questions.
Comment 12 Markos Chandras (RETIRED) gentoo-dev 2011-06-24 07:59:51 UTC
Give me some time to test and review the ebuilds :). Besides adding the EGIT* stuff did you change anything else in functionality? I can't run a diff right now.

btw, Dan would you like to become proxy maintainer for remmina{,-plugins}
Comment 13 Markos Chandras (RETIRED) gentoo-dev 2011-06-24 14:41:18 UTC
Both ebuilds are now on tree. Thank you
Comment 14 Gabor MARTON 2011-06-27 11:13:50 UTC
Thank you all for your work, now I'm using the *-9999 ebuilds from the portage tree. Thank you!