Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 364967

Summary: x11-apps/xlsclients-1.1.1 with x11-libs/xcb-util-0.3.8 - work/xlsclients-1.1.1/xlsclients.c:542:8: error: ‘WM_CLIENT_MACHINE’ undeclared (first use in this function)
Product: Gentoo Linux Reporter: Ooblick <ooblick>
Component: Current packagesAssignee: Gentoo X packagers <x11>
Status: VERIFIED FIXED    
Severity: normal CC: mitaspiotr, timbers2k, tomas.linhart
Priority: Normal    
Version: 10.1   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: build.log
emerge.info
proposed patch, fixes compilation with xcb-util-0.3.8

Description Ooblick 2011-04-26 17:46:57 UTC
Created attachment 271257 [details]
build.log

After upgrading the split xcb-utils to x11-libs/xcb-util-0.3.8, rebuilding xlsclients gives this error:make[1]: 


make[1]: Entering directory `/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1_build'
  CC     xlsclients.o
x86_64-pc-linux-gnu-gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1    -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wformat=2 -Wold-style-definition -Wdeclaration-after-statement   -O2 -march=native -pipe -floop-interchange -floop-strip-mine -floop-block -c /tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c: In function ‘print_client_properties’:
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:542:8: error: ‘WM_CLIENT_MACHINE’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:542:8: note: each undeclared identifier is reported only once for each function it appears in
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:545:8: error: ‘WM_COMMAND’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:550:8: error: ‘WM_NAME’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:553:8: error: ‘WM_ICON_NAME’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:556:8: error: ‘WM_CLASS’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:556:18: error: ‘STRING’ undeclared (first use in this function)
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c: In function ‘print_text_field’:
/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1/xlsclients.c:572:21: error: ‘STRING’ undeclared (first use in this function)
make[1]: *** [xlsclients.o] Error 1
make[1]: Leaving directory `/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1_build'
make: *** [all] Error 2
emake failed
 * ERROR: x11-apps/xlsclients-1.1.1 failed (compile phase):
 *   died running emake, base_src_make
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3257:  Called xorg-2_src_compile
 *   environment, line 4069:  Called autotools-utils_src_compile
 *   environment, line  483:  Called base_src_compile
 *   environment, line  614:  Called base_src_make
 *   environment, line  652:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "died running emake, $FUNCNAME";
 * 
 * If you need support, post the output of 'emerge --info =x11-apps/xlsclients-1.1.1',
 * the complete build log and the output of 'emerge -pqv =x11-apps/xlsclients-1.1.1'.
 * The complete build log is located at '/tmp/portage/x11-apps/xlsclients-1.1.1/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/x11-apps/xlsclients-1.1.1/temp/environment'.
 * S: '/tmp/portage/x11-apps/xlsclients-1.1.1/work/xlsclients-1.1.1'

>>> Failed to emerge x11-apps/xlsclients-1.1.1, Log file:

>>>  '/tmp/portage/x11-apps/xlsclients-1.1.1/temp/build.log'
Comment 1 Ooblick 2011-04-26 17:48:17 UTC
Created attachment 271259 [details]
emerge.info
Comment 2 Federico Cuello 2011-04-26 18:15:17 UTC
Created attachment 271261 [details, diff]
proposed patch, fixes compilation with xcb-util-0.3.8
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2011-04-26 18:58:16 UTC
Fixed in main tree.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2011-04-26 20:15:53 UTC
*** Bug 364979 has been marked as a duplicate of this bug. ***
Comment 5 Ooblick 2011-04-27 07:14:29 UTC
Works fine. Thanks.