Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 364249

Summary: Stable request for net-voip/sflphone-1.0.1
Product: Gentoo Linux Reporter: Jean-Noël Rivasseau (RETIRED) <elvanor>
Component: [OLD] Keywording and StabilizationAssignee: Jean-Noël Rivasseau (RETIRED) <elvanor>
Status: RESOLVED OBSOLETE    
Severity: enhancement CC: szaszendreistvan, thanasis, tomka
Priority: High Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: Build log
my emerge --info

Description Jean-Noël Rivasseau (RETIRED) gentoo-dev 2011-04-20 14:26:33 UTC
Following deps will also need to go stable:

>=dev-util/astyle-1.24
>=net-libs/pjsip-1.8.10
Comment 1 Jeroen Roovers gentoo-dev 2011-04-20 15:23:45 UTC
Forgot something?
Comment 2 Agostino Sarubbo gentoo-dev 2011-04-28 17:06:09 UTC
Created attachment 271473 [details]
Build log

/tmp/portage/net-libs/pjsip-1.8.10/work/pjproject-1.8.10/pjsip/lib/libpjsua.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
error: command 'x86_64-pc-linux-gnu-gcc' failed with exit status 1
Comment 3 Jean-Noël Rivasseau (RETIRED) gentoo-dev 2011-04-28 17:16:40 UTC
Hmm, I dont have an AMD64 box to test...
Comment 4 Ian Delaney (RETIRED) gentoo-dev 2011-05-03 17:43:57 UTC
AMD64

with:
=dev-util/astyle-1.24
=net-libs/pjsip-1.8.10
=net-libs/iax-0.2.2-r1

=net-voip/sflphone-0.9.12

Has no inbuilt tests.  Compiled and emerged.
No idea how to utilse it.  Best can come up with is running 

gentoo64 ~ # /usr/lib64/sflphone/sflphoned
SFLphone Daemon 0.9.12, by Savoir-Faire Linux 2004-2011
http://www.sflphone.org/
 17:42:04.538 os_core_unix.c  pjlib 1.8.10 for POSIX initialized
  PID TTY          TIME CMD
 4338 ?        00:00:24 pulseaudio
Comment 5 Ian Delaney (RETIRED) gentoo-dev 2011-05-03 17:44:43 UTC
Created attachment 271997 [details]
my emerge --info
Comment 6 Thomas Kahle (RETIRED) gentoo-dev 2011-05-22 12:21:28 UTC
on x86 

USE="-g711 -g722 -g7221 l16" emerge -1v =net-libs/pjsip-1.8.10

fails to link.  No further issues.  Please check.

i686-pc-linux-gnu-gcc -o ../bin/pjmedia-test \
             output/pjmedia-test/codec_vectors.o  output/pjmedia-test/jbuf_test.o  output/pjmedia-test/main.o  output/pjmedia-test/mips_test.o  output/pjmedia-test/rtp_test.o  output/pjmedia-test/test.o  output/pjmedia-test/sdp_neg_test.o ../lib/libpjmedia.a ../lib/libpjmedia-audiodev.a ../lib/libpjmedia-codec.a /var/tmp/portage/net-libs/pjsip-1.8.10/work/pjproject-1.8.10/pjlib/lib/libpj.a /var/tmp/portage/net-libs/pjsip-1.8.10/work/pjproject-1.8.10/pjlib-util/lib/libpjlib-util.a /var/tmp/portage/net-libs/pjsip-1.8.10/work/pjproject-1.8.10/pjnath/lib/libpjnath.a -L/var/tmp/portage/net-libs/pjsip-1.8.10/work/pjproject-1.8.10/third_party/lib -lresample -lmilenage -lsrtp -lportaudio   -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -lm -luuid -lnsl -lrt -lpthread  -lasound -lcrypto -lssl   -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu 
../lib/libpjmedia-codec.a(l16.o): In function `l16_recover':
l16.c:(.text+0x621): undefined reference to `pjmedia_plc_generate'
../lib/libpjmedia-codec.a(l16.o): In function `l16_decode':
l16.c:(.text+0x6ee): undefined reference to `pjmedia_plc_save'
../lib/libpjmedia-codec.a(l16.o): In function `l16_alloc_codec':
l16.c:(.text+0x978): undefined reference to `pjmedia_plc_create'
collect2: ld returned 1 exit status
make[2]: *** [../bin/pjmedia-test] Error 1
Comment 7 Agostino Sarubbo gentoo-dev 2011-05-22 12:27:17 UTC
(In reply to comment #6)
> fails to link.  No further issues.  Please check.

Similar issue reported in comment #2
Comment 8 Thomas Kahle (RETIRED) gentoo-dev 2011-05-22 12:33:15 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > fails to link.  No further issues.  Please check.
> 
> Similar issue reported in comment #2

I think these are different issues.  Firstly, your issue happens during src_install, mine during src_compile.  Secondly, you have USE="-l16", thirdly, I don't have any other issues.  This looks just like a small missing dep or USE dependency that upstream did not consider.  
In your build.log, why does it continue to merge after the error?
Comment 9 Agostino Sarubbo gentoo-dev 2011-05-22 12:52:00 UTC
(In reply to comment #8)
> I think these are different issues.
I mean is always related to ld

> In your build.log, why does it continue to merge after the error?
I don't know.
Comment 10 Thomas Kahle (RETIRED) gentoo-dev 2011-05-22 12:58:29 UTC
(In reply to comment #9)
> > In your build.log, why does it continue to merge after the error?
> I don't know.

Oh, I see line 79 of the ebuild is missing a 'die' statement. Maintainers, please fix this too.
Comment 11 Markos Chandras (RETIRED) gentoo-dev 2011-06-21 11:33:25 UTC
2 months and no activity. The package is obviously broken. amd64 will skip it for now. Please CC us back when you fix it
Comment 12 Jean-Noël Rivasseau (RETIRED) gentoo-dev 2011-07-22 09:47:32 UTC
I contacted upstream about the linking problem (for USE="-g711 -g722 -g7221 l16", which I can reproduce). Let's see what they reply.

To test sflphone, the best is to build the GUI client (USE="gnome") and launch it.
Comment 13 Ferry 2011-08-09 14:46:53 UTC
0.9.12 fails to build with recent webkit. Same error as for 0.9.13 which still isn't in portage.

https://bugs.gentoo.org/show_bug.cgi?id=371415
Comment 14 Jean-Noël Rivasseau (RETIRED) gentoo-dev 2011-11-26 16:21:23 UTC
We will now stabilize 1.0.1. I will cc back arches when one month has gone.
Comment 15 Jean-Noël Rivasseau (RETIRED) gentoo-dev 2012-03-02 14:53:33 UTC
Arches, please proceed.
Comment 16 Agostino Sarubbo gentoo-dev 2012-03-20 13:38:24 UTC
@elvanor:


#required by net-voip/sflphone-1.0.1[gnome], required by =net-voip/sflphone-1.0.1 (argument)               
=dev-libs/log4c-1.2.1 ~amd64                                                                               
#required by net-voip/sflphone-1.0.1, required by =net-voip/sflphone-1.0.1 (argument)                      
=dev-util/astyle-2.02.1 ~amd64                                                                             
#required by net-voip/sflphone-1.0.1, required by =net-voip/sflphone-1.0.1 (argument)
=net-libs/iax-0.2.2-r1 ~amd64
#required by net-voip/sflphone-1.0.1, required by =net-voip/sflphone-1.0.1 (argument)
=net-libs/pjsip-1.12 ~amd64
#required by net-voip/sflphone-1.0.1, required by =net-voip/sflphone-1.0.1 (argument)
=dev-libs/dbus-c++-0.9.0 ~amd64


Please open all stablereq and make it as a block.
Comment 17 kavol 2012-04-06 16:02:55 UTC
hm, is that okay that this wants to pull in GNOME stuff even with "-gnome"?

is pulseaudio really required?

and what about the KDE frontend?


# emerge -pv sflphone

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ~] net-libs/iax-0.2.2-r1  USE="-debug -snomhack" 137 kB
[ebuild  N     ] dev-libs/libyaml-0.1.2  USE="-doc -examples -test" 450 kB
[ebuild  N     ] net-libs/libasyncns-0.8-r2  USE="-debug -doc" 334 kB
[ebuild  N     ] dev-libs/json-c-0.9  333 kB
[ebuild  N    ~] net-libs/pjsip-1.12  USE="alsa cli speex -doc -epoll -examples -ext-sound -g711 -g722 -g7221 -gsm -ilbc -l16 -oss -python" 3,732 kB
[ebuild  N     ] media-libs/celt-0.7.1  USE="ogg" 416 kB
[ebuild  N     ] dev-libs/libatomic_ops-1.2-r1  180 kB
[ebuild  N     ] app-admin/eselect-esd-20060719  2 kB
[ebuild  N     ] gnome-extra/gnome-audio-2.22.2  USE="-debug" 1,703 kB
[ebuild  N     ] dev-util/cppunit-1.12.1-r1  USE="-doc -examples -static-libs" 0 kB
[ebuild  N    ~] dev-libs/dbus-c++-0.9.0  USE="-debug -ecore" 456 kB
[ebuild  N    ~] dev-util/astyle-2.02.1  USE="java -doc -static-libs" 150 kB
[ebuild  N     ] media-sound/pulseaudio-1.1-r1  USE="X alsa asyncns caps dbus gdbm glib orc ssl tcpd udev -avahi -bluetooth -doc -equalizer -gnome -ipv6 -jack -libsamplerate -lirc (-oss) -realtime (-system-wide) -test" 1,276 kB
[ebuild  N    ~] net-voip/sflphone-1.0.1  USE="speex -debug -doxygen -gnome -gsm -networkmanager -static-libs" 4,431 kB
Comment 18 Agostino Sarubbo gentoo-dev 2012-04-06 19:13:29 UTC
(In reply to comment #17)
> hm, is that okay that this wants to pull in GNOME stuff even with "-gnome"?
> 
> is pulseaudio really required?
> 
> and what about the KDE frontend?

is not the place to discuss this, please open new bug.
Comment 19 Agostino Sarubbo gentoo-dev 2012-04-10 06:22:20 UTC
(In reply to comment #16)
> Please open all stablereq and make it as a block.

No response in 20days, feel free to CC back arches when all is ready. Thanks.
Comment 20 Pacho Ramos gentoo-dev 2013-06-16 09:57:33 UTC
Closing until ready