Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 363649

Summary: =net-im/prosody-0.8.0 init-script doesn't work, "prosodyctl start" does.
Product: Gentoo Linux Reporter: ScytheMan <scytheman666>
Component: New packagesAssignee: Dirkjan Ochtman <djc>
Status: RESOLVED OBSOLETE    
Severity: normal CC: da_risk, rafaelmartins
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description ScytheMan 2011-04-14 22:57:52 UTC
Summary says mostly all.
When starting prosody via init-script:
prosody.err states:
Apr 15 00:46:46 localhost:posix error   Danger, Will Robinson! Prosody doesn't need to be run as root, so don't do it!
Apr 15 00:46:46 localhost:posix error   For more information on running Prosody as root, see http://prosody.im/doc/root
Apr 15 00:46:46 localhost:posix error   Failed to daemonize: already-daemonized

While module posix disabled, there is no error message but Prosody doesn't start, too.

When starting prosody via prosodyctl start, it works like a charm.

Maybe the initscript has to be reworked to use prosodyctl instead of prosody directly?
Comment 1 Frédéric Barthelery 2011-04-17 19:19:00 UTC
I think the issue is dependant of the version of baselayout used. With baselayout-1.x the -u option of start-stop-daemon does not change the user, you have to use the -c option too. With baselaout-2.x it works fine.
However with baselayout-1.x and the option -c and -b, I have a weird issue, the prosody process is killed but it works without the -b option.
Comment 2 ScytheMan 2011-04-25 02:03:30 UTC
I switched to =baselayout-2, now it works. Thanks for the hint.
Comment 3 ScytheMan 2011-07-03 02:21:32 UTC
As bl-2 is stable, closing as obsolete. hope this is ok