Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 363237

Summary: sys-fs/lessfs automake called by maintainer-mode
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Markos Chandras (RETIRED) <hwoarang>
Status: RESOLVED FIXED    
Severity: QA    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://blog.flameeyes.eu/2008/06/13/maintaner-mode
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 226305    
Attachments: Build log

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2011-04-12 06:43:07 UTC
Created attachment 269603 [details]
Build log

Hello,

You're receiving this canned (template-based) bug report because I found a problem with a package during my tinderbox run.

The package in question is running automake (and most likely other autotools) during compile phase by maintainer-mode. You can see in my blog post in the URL field why that's a problem, and how to address the issue, but in general, you don't want maintainer-mode rebuild during compile phase, especially since it can cause multiple run of econf.

The causes of maintainer-mode rebuild are various, but most likely it's because of a patch that changes Makefile.am or configure.ac/in and don't rebuild autotools properly. The way to fix this is almost always to inherit autotools eclass and run eautomake/eautoreconf (as needed; eautoconf should only be used when automake is not involved, which is not the case here) during src_unpack phase.

Thanks,
Diego
Comment 1 Markos Chandras (RETIRED) gentoo-dev 2011-04-13 11:21:49 UTC
Fixed. Thanks for reporting and for the url on your blog. It was very helpful