Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 362959

Summary: media-libs/gd installs libtool files referencing libpng14
Product: Gentoo Linux Reporter: nobody <noreply>
Component: New packagesAssignee: SpanKY <vapier>
Status: RESOLVED FIXED    
Severity: normal CC: graphics
Priority: Normal    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 354479    

Description nobody 2011-04-10 21:17:00 UTC
media-libs/gd (/usr/lib/libgd.la)


Reproducible: Always
Comment 1 SpanKY gentoo-dev 2011-04-11 04:29:10 UTC
no idea why this is a "problem"
Comment 2 Samuli Suominen gentoo-dev 2011-04-11 05:44:01 UTC
libgd.la ends up with dependency_libs of -lpng14 which will break when libpng-1.5.x gets dropped to ~arch eventually.

File:

/usr/lib/libgd.la:dependency_libs=' -L/usr/lib64 -ljpeg -lfontconfig -lexpat -lfreetype -lpng14 -lz -lm' 

revdep-rebuild is clueless of ordering the packages in right order for this, and lafilefixer is useless as well.  we don't want to end up in same situation as with libpng-1.2 to libpng-1.4 where all those "semi-invalid" bugs reports came in.

remove the .la file from the package if it's not required,
or empty the dependency_libs to '' in src_install() if it
is required for loading plugins (libltdl)

and the usual USE=static-libs if required

i'll fix it if you won't, feel free to reassign to me
Comment 3 Samuli Suominen gentoo-dev 2011-04-11 14:21:27 UTC
+  11 Apr 2011; Samuli Suominen <ssuominen@gentoo.org> gd-2.0.35-r2.ebuild:
+  Remove libtool and static archive if USE="static-libs" is not set wrt #362959
+  by St├ęphane Pagnon.
Comment 4 Samuli Suominen gentoo-dev 2011-04-11 14:23:50 UTC
Kept the libgd.la for USE=static-libs because gd has no pkg-config file, just in case.   So this is only semi-solved, people setting USE=static-libs will still get the migration problems.
Comment 5 SpanKY gentoo-dev 2011-04-12 02:10:46 UTC
the package still needs to be re-emerged on libpng upgrade like any other revdep rebuild case.  the .la doesnt really matter.
Comment 6 Samuli Suominen gentoo-dev 2011-04-12 04:52:39 UTC
(In reply to comment #5)
> the package still needs to be re-emerged on libpng upgrade like any other
> revdep rebuild case.  the .la doesnt really matter.

sure, media-libs/gd itself will break due to the NEEDED entry but this way _other_ packages that reference libgd.la in the .la files won't fail to build with dubious "can't find library -lpng14" message
Comment 7 Samuli Suominen gentoo-dev 2011-04-12 04:53:26 UTC
as in, the commit was for reverse dependencies of gd, not for gd