Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 36270

Summary: nxclient/nxserver 1.3 give me a "proxy libraries not found" error
Product: Gentoo Linux Reporter: Michael Imhof (RETIRED) <tantive>
Component: New packagesAssignee: Stuart Herbert (RETIRED) <stuart>
Severity: critical CC: cbradney, flokno
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Michael Imhof (RETIRED) gentoo-dev 2003-12-21 16:58:44 UTC
After upgrading the nxclient and the nxserver to 1.3.0 the following happens when i try to login onto the server using the client:
A nice windows pops up after auth that tells me:
"Proxy libraries not found"
I can close the message box and retry, result is the same.
Means that nx is unusable for me.

Reproducible: Always
Steps to Reproduce:
1.emerge -u world
2.use nxclient to connect to nxserver
3.use a username/passwd you just created (because of the other bug) connect and wait until auth has been completed successfully

Actual Results:  
The only thing i'm getting out of nx after that upgrade is the error described

Expected Results:  
That everything works as intended...
Comment 1 Stuart Herbert (RETIRED) gentoo-dev 2003-12-22 12:18:34 UTC
I can't reproduce this.  emerge -u world didn't work smoothly for me on a test machine I've put together (/usr/NX/nxhome needs renaming to /usr/NX/home, and the user 'nx' needs his home directory updating accordingly) but all the libraries upgraded no trouble at all.

Try emerge nxproxy to see if that fixes it.

Comment 2 Michael Imhof (RETIRED) gentoo-dev 2003-12-23 03:44:22 UTC
moving /usr/NX/nxhome to /user/NX/home results in Access denied for every (valid) usr/passwd. moving it back still gives me the "proxy libraries not found one"
Comment 3 Stuart Herbert (RETIRED) gentoo-dev 2003-12-23 05:28:26 UTC
Don't forget to change nx's homedir in /etc/passwd!

Can you verify whether nxcomp, nxproxy and nxssh have successfully merged on your machine?  Also, it might be worth running ldd on /usr/NX/nxserver, to see if any unresolved libraries are present.

Sure is a strange one.

Comment 4 Michael Imhof (RETIRED) gentoo-dev 2003-12-23 06:09:57 UTC
changed the entry in passwd, no change in the results
checked with ldd, nothing unresolved
all other things are merged as they should.
Comment 5 Michael Imhof (RETIRED) gentoo-dev 2003-12-23 07:21:23 UTC
after unmerging of both, the client and the server and doing a clean install and new config, the error with the proxy disappeared.

BUT it seems that the "Enable SSL encrytion of all traffic" is not working.
This is the output with the option enabled... it should contact on port 22...

NXPROXY - Version 1.3.0

Copyright (C) 2001,2003 NoMachine.
See for more information.

Info: Proxy running in client mode with pid '29139'.
Info: Connecting to remote host '' on SSH port 'localhost:34217'.

Comment 6 Michael Imhof (RETIRED) gentoo-dev 2003-12-23 07:26:14 UTC
New versions of nxclient and server were released on 21.12.2003.
Maybe you can prepare -r1 ebuild with those. I think they may fix my problem.
Comment 7 Stuart Herbert (RETIRED) gentoo-dev 2003-12-23 10:54:40 UTC
Bah.  Nomachine forgot to post an announcement about the new packages :(  I'm working on the ebuilds now; I'll add something more to this bug once the packages are in portage.

Comment 8 Stuart Herbert (RETIRED) gentoo-dev 2003-12-23 12:39:48 UTC
Okay, -r1 is in CVS (along with an improved eclass).  Let me know if that works any better for you.

Comment 9 Michael Imhof (RETIRED) gentoo-dev 2003-12-25 07:45:31 UTC
I finally found it.

I reemerged the complete serverpart (nxserver, nxssh, nxcomp and nxproxy) with
distcc and ccache disabled.

Now it works.

Maybe the ebuild should take care of this and disable distcc and ccache...
Comment 10 Chris Brown 2004-05-02 01:42:43 UTC
This happened to me recently, today
I cant help with any details cause I dont use it much
But it used to work ok (it has issues) then one day after a while of not using it, I got the "Proxy libraries not found" error
I tried reemerge some of the nx ebuilds but it didnt help
So I unmerged everything, client and server, then emerged them all and it worked

NB I emerged with ccache running and it works
Comment 11 Chris Brown 2004-05-02 01:52:05 UTC
I could add, this might of happened about the same time I started getting this error, while emerging different ebuilds (e.g. openbox), some worked others I got this error

/bin/sh ./libtool --silent --mode=link gcc  -mcpu=i586 -O2 -pipe -fomit-frame-pointer -DNDEBUG 
-DG_DISABLE_ASSERT   -o render/rendertest  render/render_rendertest-test.o parser/libobparser.l
a render/ -L/usr/X11R6/lib -lXft -lfreetype -lXrender -lfontconfig   -lglib-2.0  
 -lxml2 -lpthread -lz -lm   -lSM -lICE  -L/usr/X11R6/lib -lX11 
/usr/NX/lib/ undefined reference to `_NXSplitParams'
/usr/NX/lib/ undefined reference to `_NXEnableCleanAlloc'
/usr/NX/lib/ undefined reference to `_NXEnableCleanFlush'
/usr/NX/lib/ undefined reference to `_NXLostSequenceFunction'
/usr/NX/lib/ undefined reference to `_NXEnableImageFrame'
/usr/NX/lib/ undefined reference to `_NXFlushSize'
/usr/NX/lib/ undefined reference to `_NXColorParams'
/usr/NX/lib/ undefined reference to `_NXEnableImageSplit'
/usr/NX/lib/ undefined reference to `_NXEnableCleanImages'
/usr/NX/lib/ undefined reference to `_NXEnableImageMask'
/usr/NX/lib/ undefined reference to `_NXImageEnvironmentCached'
/usr/NX/lib/ undefined reference to `_NXCleanupEnvironmentCached'
/usr/NX/lib/ undefined reference to `_NXEnableCleanGet'
/usr/NX/lib/ undefined reference to `_NXEnableCleanSend'
collect2: ld returned 1 exit status

To fix this problem I commented out /usr/NX/lib from the LDPATH
machine portage # cat /etc/env.d/50nxserver

Comment 12 Stuart Herbert (RETIRED) gentoo-dev 2004-05-02 02:55:58 UTC

Your problem is completely unrelated to this bug.  Your problem is caused by env-update screwing up the order of  Bug 44028 is what you want to be looking at for that problem.

Many thanks,
Comment 13 Stuart Herbert (RETIRED) gentoo-dev 2004-06-26 15:10:44 UTC
Closing old bug
Comment 14 Michael Imhof (RETIRED) gentoo-dev 2004-06-28 04:13:54 UTC
The new ebuilds (1.3.2) are not diabling ccache and distcc...

So this proxy lib not found error is back again.
Comment 15 qeldroma 2004-07-05 08:08:25 UTC
I got this, too.
But i don't have ccache/distcc enabled?!
Comment 16 Stuart Herbert (RETIRED) gentoo-dev 2004-07-07 07:27:35 UTC
Okay, please try emerging nxcomp-1.3.2-r1.  This problem seems to be caused by nxclient manually looking for the proxy libraries in /usr/NX/lib, instead of letting find the libraries for it.

Best regards,
Comment 17 Michael Imhof (RETIRED) gentoo-dev 2004-07-07 08:24:32 UTC
Works for me!

Comment 18 Daniel Holth 2005-01-01 16:51:19 UTC
when as in finds NX libraries for nxclient/server, EVERY dynamically linked X11 app links to NX libraries. Then, when nx is unevenly upgraded, easy with portage, EVERY dynamically linked X11 app ceases to work.
Comment 19 Stuart Herbert (RETIRED) gentoo-dev 2005-02-17 03:20:08 UTC
Closing old bug.