Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 357093

Summary: sys-apps/portage-2.1.9.25 non-TTY emerge output contains BS
Product: Portage Development Reporter: Patrick <mail>
Component: Core - Interface (emerge)Assignee: Portage team <dev-portage>
Status: RESOLVED FIXED    
Severity: minor Keywords: InVCS
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 358927    

Description Patrick 2011-03-02 15:04:46 UTC
The output of emerge, even when piped into another command or redirected into a file (and with "--nospinner" option), contains one or more backspace(s).

This is bad because heirloom mailx (mail-client/nail) then puts the text into a file "attachment.bin", instead of leaving it in the mail body, where I want it. I think text output that does not go to a TTY should not have backspaces or any other control characters except tabs and newlines in it.

Reproducible: Always

Steps to Reproduce:
1. emerge -upvDN --nospinner world 2>&1 | hexdump -e '1/1 "%03d \n"' | grep 008

Actual Results:  
Output: 008 (there is one backspace in the output)

Expected Results:  
No output.
Comment 2 Patrick 2011-03-04 01:15:34 UTC
(In reply to comment #1)
Great, that was fast! Thanks! :)
Comment 3 Zac Medico gentoo-dev 2011-03-14 19:10:23 UTC
This is fixed in 2.1.9.43 and 2.2.0_alpha27.