Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 354837

Summary: kde-base/libkdegames-4.6.0: Make failed with syntax errors (erreur: expected ‘,’ or ‘...’ before ‘>’ token)
Product: Gentoo Linux Reporter: Arnaud JOLLY <mynameisnotjeanpaul>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal CC: metaluger, pkuegle
Priority: High Keywords: InOverlay
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: The build.log file
The environment file

Description Arnaud JOLLY 2011-02-14 10:07:11 UTC
When updating kde to version 4.6.0, I have a "Make Failed" error for this atom.
Looking at the build log, the first error is due to syntaxe error on object 

Reproducible: Always

Actual Results:  
Make Failed, abortion of the build.


Portage 2.1.9.39 (default/linux/x86/10.0/desktop/kde, gcc-4.3.5, glibc-2.13-r0, 2.6.36-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.36-gentoo-r4-i686-Intel-R-_Core-TM-2_Duo_CPU_E4600_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 13 Feb 2011 23:15:01 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.5.4-r4, 2.6.6-r1, 2.7.1, 3.1.3
dev-util/cmake:      2.8.3-r1
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.4
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.3.5, 4.4.4-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.36.1 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/ ftp://gentoo.imj.fr/pub/gentoo/ "
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/desktop-effects"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl alsa apache2 bash-completion berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib ctype cups cxx dbus dri dts dvd dvdr emboss encode examples exif fam firefox flac fontconfig fortran gdbm gdu gif gpm gtk hal iconv icu ipv6 java java6 jpeg kde latex lcms ldap libnotify mad mikmod mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pango pcre pdf perl php png policykit ppds pppd python qt3support qt4 readline sdl semantic-desktop session skins spell sqlite ssl startup-notification svg sysfs tcpd threads tiff truetype udev unicode usb utf8 vim-syntax vorbis win32codecs wxwindows x264 x86 xcb xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Arnaud JOLLY 2011-02-14 10:11:36 UTC
Created attachment 262439 [details]
The build.log file

This is the build.log file
Comment 2 Arnaud JOLLY 2011-02-14 10:12:29 UTC
Created attachment 262441 [details]
The environment file
Comment 3 Philipp Kügle 2011-02-16 18:03:31 UTC
I read here about a gcc issue: https://bugs.kde.org/show_bug.cgi?id=261488#c8

I switched to gcc-4.4.5 and libkdegames compiles.
Comment 4 Arnaud JOLLY 2011-02-18 13:48:36 UTC
Ok. That works fine. thanks.
Comment 5 Andreas K. Hüttel gentoo-dev 2011-02-27 15:00:04 UTC
This is the line that breaks with gcc-4.3: 

QPixmap spritePixmap(const QString& key, const QSize& size, int frame = -1, const QHash<QColor, QColor>& customColors = QHash<QColor, QColor>()) const;

@toolchain: are you interested in this? is this a know issue?

I'd suggest resolving as cantfix and recommending gcc-4.4 for kde builds...
Comment 6 Andreas K. Hüttel gentoo-dev 2011-02-27 20:52:37 UTC
*** Bug 356153 has been marked as a duplicate of this bug. ***
Comment 7 SpanKY gentoo-dev 2011-03-01 00:18:06 UTC
considering we stabilized gcc-4.4 quite some time ago, and we arent investigating most issues with <=gcc-4.3 (unless there is an obvious patch that already exists), i think that route is fine.  you could add a check to the libkdegames ebuild like:
  [[ $(gcc-version) == "4.3" ]] && die "sorry, but gcc-4.3 wont work #354837"
Comment 8 Robert Larkin 2011-03-08 23:54:56 UTC
Please follow the advice from Spanky if you can and not let us spend two days compiling (kde-4.6.1) just to find out we have to upgrade our tool chain and start over. My assumption is that it's okay to mask updates to gcc and glibc and only update them from time to time.  I'm sure a lot of people do that.
Comment 9 Andreas K. Hüttel gentoo-dev 2011-03-09 01:04:04 UTC
@toolchain: thanks, removing you again, we'll go that way.

It makes no sense to fix this in libkdegames only, since (as you noted correctly) if you keep compiling until you reach libkdegames and are then notified of a required gcc upgrade you can just start over again. 

So, I'd suggest we place somewhere in the kde4 eclasses a check that makes sure >=kde-4.6 is not compiled with <gcc-4.4. Working on it.
Comment 10 Andreas K. Hüttel gentoo-dev 2011-03-11 19:27:10 UTC
Added a check to the kde overlay kde4-meta eclass... We'll commit this patch to the in tree eclass after some testing.
Comment 11 Andreas K. Hüttel gentoo-dev 2011-03-13 08:41:52 UTC
Fixed in eclass, which now prevents kde-4.6 compilation with <=gcc-4.3
Comment 12 Andreas K. Hüttel gentoo-dev 2011-03-13 08:42:14 UTC
Fixed in eclass, which now prevents kde-4.6 compilation with <=gcc-4.3
Comment 13 Andreas Sturmlechner gentoo-dev 2011-03-13 11:21:02 UTC
What the...?

 * ERROR: kde-base/kdepim-icons-4.6.9999 failed (setup phase):
 *   Sorry, but gcc-4.3 and earlier wont work for KDE SC 4.6 (see bug 354837).
 * 
 * Call stack:
 *          ebuild.sh, line   56:  Called pkg_setup
 *          ebuild.sh, line 1439:  Called kde4-meta_pkg_setup
 *   kde4-meta.eclass, line  158:  Called kde4-meta_pkg_pretend
 *   kde4-meta.eclass, line  148:  Called die
 * The specific snippet of code:
 *      slot_is_at_least 4.6 ${SLOT} && ( [[ gcc-major-version -lt 4 ]] || \
 *              ( [[ gcc-major-version -eq 4 ]] && [[ gcc-minor-version -le 3 ]] ) ) \
 *              && die "Sorry, but gcc-4.3 and earlier wont work for KDE SC 4.6 (see bug 354837)."


-----------

# gcc-config -l
 [1] x86_64-pc-linux-gnu-4.5.2 *

Something's not quite right here. I'll take a closer look at it after lunch.
Comment 14 Andreas Sturmlechner gentoo-dev 2011-03-13 11:58:02 UTC
Ok, fixed by re-sync. :)
Comment 15 Stefano Takekawa 2011-05-10 07:34:27 UTC
Hi. If I'm not wrong, they found a work around, see https://bugs.kde.org/show_bug.cgi?id=261488#c9 . Now one can think to apply a patch and release the strict check on the version of gcc.