Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 353636

Summary: sys-apps/dbus-1.4.1: fd.o bug 14259 fixed, no need for patchfile anymore
Product: Gentoo/Alt Reporter: Charles Davis <cdavis5x>
Component: Prefix SupportAssignee: Gentoo Prefix <prefix>
Status: VERIFIED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: OS X   
Whiteboard:
Package list:
Runtime testing required: ---

Description Charles Davis 2011-02-03 20:12:48 UTC
The Gentoo distribution of D-Bus includes a patch for on-demand launch support under the Darwin Launcher Daemon (launchd). The fix was applied to D-Bus 1.4.1, so it is now no longer necessary. In fact, building with the patch now fails.

Reproducible: Always

Steps to Reproduce:
1. Build D-Bus (emerge dbus)

Actual Results:  
D-Bus build fails because the ebuild script applies a patch file (dbus-1.4.0-launchd_upstream_bug_14259_p2.patch) that is no longer necessary.

Expected Results:  
D-Bus should build successfully.
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-03 20:29:05 UTC
I removed *all* those patches that referenced the upstream bug. Hope that was correct. Less patches ftw, thanks.
Comment 2 Charles Davis 2011-02-07 17:27:37 UTC
Oops, wrong ebuild.

I meant to say 'sys-apps/dbus'. THAT's the one.
Comment 3 Charles Davis 2011-02-07 17:42:06 UTC
Patch files are still there...
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-02-07 17:46:29 UTC
(In reply to comment #3)
> Patch files are still there...
> 

Right, I somehow forgot to hit the commit button like I thought =P

(In reply to comment #1)
> I removed *all* those patches that referenced the upstream bug. Hope that was
> correct. Less patches ftw, thanks.
> 

This comment now applies, resolving. http://overlays.gentoo.org/proj/alt/changeset/59286