Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 352233

Summary: [gnome-overlay] x11-libs/vte-0.27.4 failed on compile
Product: Gentoo Linux Reporter: tman <cornicx>
Component: New packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 353071    
Attachments: /var/tmp/portage/x11-libs/vte-0.27.4/temp/automake-29976.out

Description tman 2011-01-20 13:42:24 UTC
* Package:    x11-libs/vte-0.27.4
 * Repository: gnome
 * USE:        amd64 elibc_glibc kernel_linux multilib userland_GNU
 * FEATURES:   sandbox
 * Applying vte-0.27.4-fix-gdk-targets.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4/gnome-pty-helper' ...
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy --foreign ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4' ...
 * Running aclocal ...
 [ ok ]
 * Running libtoolize --copy --force --install --automake ...
 [ ok ]
 * Running aclocal ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy --foreign ...
 [ !! ]

 * Failed Running automake !
 *  
 * Include in your bugreport the contents of:
 *  
 *   /var/tmp/portage/x11-libs/vte-0.27.4/temp/automake-17301.out

 * ERROR: x11-libs/vte-0.27.4 failed:
 *   Failed Running automake !
 *  
 * Call stack:
 *     ebuild.sh, line   56:  Called src_prepare
 *   environment, line 3251:  Called eautoreconf
 *   environment, line  996:  Called eautomake
 *   environment, line  965:  Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
 *   environment, line  463:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  
 * If you need support, post the output of 'emerge --info =x11-libs/vte-0.27.4',
 * the complete build log and the output of 'emerge -pqv =x11-libs/vte-0.27.4'.
 * This ebuild used the following eclasses from overlays:
 *   /usr/portage/local/layman/gnome/eclass/gnome2.eclass
 *   /usr/portage/local/layman/gnome/eclass/gnome2-utils.eclass
 * This ebuild is from a repository named 'gnome'
 * The complete build log is located at '/var/log/portage/x11-libs:vte-0.27.4:20110120-133825.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/vte-0.27.4/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4'


Reproducible: Always

Steps to Reproduce:
Comment 1 Gilles Dartiguelongue gentoo-dev 2011-01-21 12:59:11 UTC
 * Include in your bugreport the contents of:
 *  
 *   /var/tmp/portage/x11-libs/vte-0.27.4/temp/automake-17301.out

same as the other report.
Comment 2 tman 2011-01-21 14:19:33 UTC
Created attachment 260437 [details]
/var/tmp/portage/x11-libs/vte-0.27.4/temp/automake-29976.out
Comment 3 tman 2011-01-21 14:20:34 UTC
info in attachement
Comment 4 Gilles Dartiguelongue gentoo-dev 2011-01-21 14:48:26 UTC
looks like this package is not shipping introspection.m4...
Comment 5 MZ 2011-02-01 10:54:01 UTC
me help emerge gobject-introspection and then  vte-0.27.4

wrong dependencies in vte-0.27.4 ebuild???
Comment 6 tman 2011-02-02 12:59:17 UTC
i have installed (In reply to comment #5)
> me help emerge gobject-introspection and then  vte-0.27.4
> 
> wrong dependencies in vte-0.27.4 ebuild???
> 

this not resolve the problem

491  *   /usr/portage/local/layman/gnome/eclass/gnome2-utils.eclass
492  * This ebuild is from a repository named 'gnome'
493  * The complete build log is located at '/var/log/portage/x11-libs:vte-0.27.4:20110202-125655.log'.
455 vte.c:6358:35: error: dereferencing pointer to incomplete type
456 vte.c:6360:17: error: dereferencing pointer to incomplete type
457 vte.c:6360:23: warning: left-hand operand of comma expression has no effect
458 vte.c:6361:5: error: ‘GtkTargetPair’ undeclared (first use in this function)
459 vte.c:6361:5: note: each undeclared identifier is reported only once for each function it appears in
460 vte.c:6361:20: error: ‘pair’ undeclared (first use in this function)
461 vte.c:6361:43: error: expected expression before ‘)’ token
462 vtebg.c: In function ‘vte_bg_cache_item_free’:
463 vtebg.c:281:5: warning: dereferencing type-punned pointer will break strict-aliasing rules
464 vtebg.c: In function ‘vte_bg_cache_add’:
465 vtebg.c:341:8: warning: dereferencing type-punned pointer will break strict-aliasing rules
466 make[3]: *** [libvte2_90_la-vte.lo] Error 1
467 make[3]: *** Waiting for unfinished jobs....
468 vteaccess.c: In function ‘vte_terminal_accessible_finalize’:
469 vteaccess.c:881:11: warning: dereferencing type-punned pointer will break strict-aliasing rules
470 make[3]: Leaving directory `/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4/src'
471 make[2]: *** [all] Error 2
472 make[2]: Leaving directory `/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4/src'
473 make[1]: *** [all-recursive] Error 1
474 make[1]: Leaving directory `/var/tmp/portage/x11-libs/vte-0.27.4/work/vte-0.27.4'
475 make: *** [all] Error 2
476 emake failed
477  * ERROR: x11-libs/vte-0.27.4 failed:
478  *   compile failure
Comment 7 tman 2011-02-02 13:03:23 UTC
but the worksaorund is: 

emerge -1 gobject-introspection and then emerge  vte-9999.
the ebuild x11-libs/vte-0.27.4  seem to be hardly broken 

Comment 8 Gilles Dartiguelongue gentoo-dev 2011-05-02 09:29:55 UTC
Not a problem anymore until next time.