Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 351854

Summary: media-libs/libquicktime-1.2.2 poor programming practices lead to failure
Product: Gentoo Linux Reporter: Ingo Krabbe <ikrabbe.ask>
Component: Current packagesAssignee: media-video herd <media-video>
Status: RESOLVED FIXED    
Severity: normal CC: buraktuysuz, creffett, esqualante, JakesAddress, phajdan.jr, staff, stian.jenssen, zioalex
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 380169    
Bug Blocks:    
Attachments: Patch to remove deprecation warning when compiling against new gtk libraries
libquicktime-1.2.2-r1.ebuild
lqt_gtk.c.diff

Description Ingo Krabbe 2011-01-16 16:07:34 UTC
media-libs/quicktime-1.2.2 reports poor programming practices within lqt_gtk.c:335
Looks like a failure in parameter or result conversion.  Fix will be reported soon.

Reproducible: Always
Comment 1 Ingo Krabbe 2011-01-16 16:35:35 UTC
Created attachment 260012 [details, diff]
Patch to remove deprecation warning when compiling against new gtk libraries

utils/gtk/lqt_gtk.c
changed gtk_combo_box_new_text into gtk_combo_box_text_new as proposed by gtk documentation.
Comment 2 Ingo Krabbe 2011-01-16 16:36:55 UTC
The patch makes the package compile.  Please test against older/stable gtk+ and merge the patch file to the portage tree.
Comment 3 PaweĊ‚ Hajdan, Jr. (RETIRED) gentoo-dev 2011-01-17 08:30:12 UTC
(In reply to comment #2)
> The patch makes the package compile.  Please test against older/stable gtk+ and
> merge the patch file to the portage tree.

After you closed this bug it is unlikely the maintainers will look at it. If you want someone to take action, please re-open.
Comment 4 Ingo Krabbe 2011-01-17 08:40:27 UTC
That was a bit fast, please still review and fix the ebuild.
I just wanted to express that the patch works-for-me.
Comment 5 Alexis Ballier gentoo-dev 2011-01-19 15:06:51 UTC
please send that patch upstream first
Comment 6 Serkan Kaba (RETIRED) gentoo-dev 2011-03-30 06:03:02 UTC
*** Bug 361213 has been marked as a duplicate of this bug. ***
Comment 7 Burak 2011-03-30 19:56:01 UTC
It still fails with the same error. Please apply the patch upstream.
Comment 8 Stian 2011-04-03 18:52:05 UTC
Created attachment 268381 [details]
libquicktime-1.2.2-r1.ebuild

Added the patch to the ebuild, renamed the patch to lqt_gtk.c.diff.
Comment 9 Stian 2011-04-03 18:53:39 UTC
Created attachment 268383 [details]
lqt_gtk.c.diff

Renamed patch
Comment 10 Krellan 2011-05-22 03:04:38 UTC
The above patch works well.

Is there anything else that is holding up the merge of this fix, to the main Gentoo tree?

Whenever I do "emerge --sync", it becomes broken again, and I must remember to copy in the files again and run "ebuild digest" on it.

The libquicktime-1.2.2-r1 version cleanly builds.
Comment 11 Fabio Coatti 2011-05-22 08:46:16 UTC
why not use overlay, until it is fixed in main tree?
Comment 12 peter hiltz 2011-05-22 16:55:21 UTC
This bug is breaking my revdep-rebuild every time. Any timeline on getting it into the main trunk?
Comment 13 Rick Warner 2011-07-19 19:45:34 UTC
I had the same problem and this updated ebuild and patch resolved it for me.  Is this going into main portage soon?
Comment 14 Martin Weber 2011-08-09 21:47:38 UTC
Instead of waiting for a fix one can also use the newer media-libs/libquicktime-1.2.3. This works fine on my systems, no complaints about poor programming practices any more. Currently it is marked as ~amd64. In order to use it, try with

echo "=media-libs/libquicktime-1.2.3 ~amd64" >> /etc/portage/package.keywords

followed by e.g. 

emerge -1 libquicktime
Comment 15 Jan Seiffert 2011-08-21 21:45:59 UTC
confirmig,
libquicktime-1.2.3 solves the issue described here.
Can we get stabilization of libquicktime-1.2.3 for the 64 Bit archs?
Comment 16 Alecks Gates 2011-08-24 19:15:48 UTC
I can confirm as well, though building without the "gtk" USE flag compiles successfully.
Comment 17 Samuli Suominen gentoo-dev 2012-03-30 13:00:27 UTC
Comment on attachment 268383 [details]
lqt_gtk.c.diff

Verified this patch is part of upstream 1.2.4 release.
Comment 18 Samuli Suominen gentoo-dev 2012-03-30 13:03:59 UTC
1.2.4 in Portage and solves this bug