Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 346077

Summary: app-emulation/emul-linux-x86-medialibs needs to include gstreamer and gst-plugins-base
Product: Gentoo Linux Reporter: Francisco J. Vazquez <dv>
Component: Current packagesAssignee: AMD64 Project <amd64>
Severity: enhancement CC: ao, g3ntaro, gstreamer, hsggebhardt, j0inty, m.debruijne, Martin.vGagern, matthias.grobarek, mgorny, mkyral, nbowler, nikoli, rion4ik, rose, stefano.priore, willard.dawson
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 165270    
Attachments: build.log

Description Francisco J. Vazquez 2010-11-19 14:25:40 UTC
Configure phase:

checking gst/app/gstappsink.h presence... yes
checking for gst/app/gstappsink.h... yes
checking for gst_pad_get_caps_reffed in -lgstreamer-0.10... no
configure: error: gstreamer-0.10 32-bit development files not found, gstreamer support disabled
This is an error since --with-gstreamer was requested.

Probably should depend on some emul-linux-x86-yaddayadda.

Reproducible: Always

emerge --info

Portage 2.2.0_alpha4 (default/linux/amd64/10.0/desktop/gnome, gcc-4.5.1, glibc-2.12.1-r3, 2.6.36 x86_64)
System uname: Linux-2.6.36-x86_64-AMD_Phenom-tm-_II_X4_965_Processor-with-gentoo-2.0.1
Timestamp of tree: Fri, 19 Nov 2010 13:30:19 +0000
app-shells/bash:     4.1_p9
dev-java/java-config: 2.1.11-r2
dev-lang/python:     2.6.6-r1, 3.1.2-r4
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1-r1
sys-apps/openrc:     0.6.4
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.5.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4
sys-devel/make:      3.82
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
Repositories: gentoo gnome local-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/openvpn/easy-rsa"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
FEATURES="assume-digests binpkg-logs distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--hash-style=gnu -Wl,--sort-common -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/gnome /usr/local/portage/overlay"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdr cjk cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fbcon firefox flac fortran gdbm gdu gif gnome gnome-keyring gpm gstreamer gtk iconv imap ipv6 jingle joystick jpeg jpeg2k lcms libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png policykit pppd pulseaudio python qt3support readline sdl session spell sse sse2 ssl startup-notification subversion svg symlink sysfs tcpd threads tiff truetype udev unicode usb vaapi vorbis x264 xcb xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-2" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Steffen 'j0inty' Stollfuß 2010-11-19 15:54:10 UTC
Created attachment 254847 [details]


I ran into the same error with wine and the gstreamer USE flag. Wine was missing the lib32 gstreamer development files.

checking for gst_pad_get_caps_reffed in -lgstreamer-0.10... no
configure: error: gstreamer-0.10 32-bit development files not found, gstreamer support disabled
This is an error since --with-gstreamer was requested.

Best Regards
Comment 2 SpanKY gentoo-dev 2010-11-19 22:25:17 UTC
not wine's problem
Comment 3 Ivan Trombley 2010-11-20 02:29:47 UTC
Why is the gstreamer USE flag there for x86_64?
Comment 4 Marco Napetti 2010-11-20 09:13:01 UTC
Same problem here, but disabling win32 use flag build goes right.
Comment 5 Juergen Rose 2010-11-20 10:34:05 UTC
If I disable win32 for wine in /etc/portage/package.use:

rose@lynx:/home/rose(1)$ grep wine /etc/portage/package.use
app-emulation/wine -win32

I also can compile wine:

rose@lynx:/home/rose(2)$ emerge -pvD wine

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-emulation/wine-1.3.6  USE="X alsa cups dbus fontconfig gecko gnutls gsm gstreamer jpeg lcms ldap mp3 ncurses opengl oss perl png pulseaudio samba ssl threads truetype win64 xml (-capi) -custom-cflags (-esd) (-gphoto2) (-hal) -jack -nas -openal (-scanner) -test -win32 -xcomposite -xinerama" 0 kB

rose@lynx:/home/rose(3)$ genlop -t wine | tail -n 6
     Thu Nov 11 13:47:04 2010 >>> app-emulation/wine-1.3.6
       merge time: 38 minutes and 33 seconds.

     Sat Nov 20 11:26:42 2010 >>> app-emulation/wine-1.3.6
       merge time: 18 minutes and 33 seconds.

but no binary /usr/bin/wine is installed:
rose@lynx:/home/rose(4)$ equery f wine | grep bin
Comment 6 Pacho Ramos gentoo-dev 2010-11-20 11:31:01 UTC
Maybe we should mask "gstreamer" USE flag for wine on amd64
Comment 7 matthias.grobarek 2010-11-20 12:37:39 UTC
Wouldn’t it be easy to fix this by adding the 32-bit gstreamer libs to app-emulation/emul-linux-x86-medialibs, or alternatively create a seperate ebuild for these libs called app-emulation/emul-linux-x86-gstreamer?

(“easy” not in the way *I* feel able to do it but maybe one of the emul-linux ebuild maintainers can do it?)

Until then, I agree that +gstreamer should be masked in wine for amd64. Or maybe 1.3.7 fixes this already? The WineHQ announcement talks about “a lot of fixes to the GStreamer support”.
Comment 8 Paramonov Valeriy 2010-11-21 06:48:57 UTC
+1. And adding the 32-bit unixodbc, mysql, postgresql, firebird libs to
app-emulation/emul-linux-x86-database for LIB_ODBC_DRIVER_MANAGER wine feature work fine.. Database sharing beetwen win/lin on amd64 does not working now.
Comment 9 Pacho Ramos gentoo-dev 2010-11-21 10:32:44 UTC
+  21 Nov 2010; Pacho Ramos <> arch/amd64/ChangeLog,
+  arch/amd64/package.use.mask:
+  Mask gstreamer USE flag on wine due bug #346077
Comment 10 SpanKY gentoo-dev 2010-11-21 21:02:56 UTC
*** Bug 346321 has been marked as a duplicate of this bug. ***
Comment 11 Mart Raudsepp gentoo-dev 2010-12-19 23:53:23 UTC
Note that there can be various additional nasties with distributing some gstreamer plugins as binaries. Patents, licenses, et cetera, primarily in regards to the external libraries depended on... This goes in particular for gst-plugins-ugly and anything inheriting gst-plugins-ugly.eclass and also gst-plugins-bad and some things inheriting gst-plugins-bad.eclass.
I guess it's up for the amd64 team to decide if these should be part of the same big soundlibs or medialibs emul packages.
@amd64, feel free to chat me up on this or anything else gstreamer on IRC for additional advice.
Comment 12 Pacho Ramos gentoo-dev 2010-12-20 08:41:20 UTC
My original intention was to only include gstreamer and gst-plugins-base, I think they wouldn't have licensing issues, no? Thanks
Comment 13 Sergey Ilinykh 2011-01-09 20:37:59 UTC
what if want to compile with gstreamer with use flags -win32 +win64?
as reported above this should work.
but with masked flag its impossible now.
Comment 14 Pacho Ramos gentoo-dev 2011-01-30 11:26:26 UTC
Fixed in 20110129
Comment 15 Mart Raudsepp gentoo-dev 2011-01-31 14:55:40 UTC
While things will probably compile now for 32bit wine, the support will probably be rather useless, as no useful decoders are included. Though I'm not intimately familiar of what winegstreamer needs, as I haven't closely tracked at which point it takes over from gstreamer with appsink, or tested yet