Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 346055

Summary: gnome-base/gvfs-1.6.6 fails to build
Product: Gentoo Linux Reporter: fkhp <fkhp101>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: cornicx, flameeyes, uzytkownik2
Priority: High Keywords: InVCS
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: with masked >=glib-2.27
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 353071, 355389    
Attachments: patch (for glib verison 2.27.5)

Description fkhp 2010-11-19 10:10:50 UTC
GEN    org.gtk.Private.GPhoto2VolumeMonitor.service
make[4]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/monitor/gphoto2'
make[3]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/monitor/gphoto2'
make[3]: Entering directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/monitor'
make[3]: Nothing to be done for `all-am'.
make[3]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/monitor'
make[2]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/monitor'
Making all in gconf
make[2]: Entering directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/gconf'
  CC     libgiogconf_la-gapplookupgconf.lo
gapplookupgconf.c:41:59: error: expected ')' before '*' token
gapplookupgconf.c: In function 'g_app_lookup_gconf_register_type':
gapplookupgconf.c:44:81: error: 'lookup_iface_init' undeclared (first use in this function)
gapplookupgconf.c:44:81: note: each undeclared identifier is reported only once for each function it appears in
gapplookupgconf.c:44:188: error: 'G_TYPE_DESKTOP_APP_INFO_LOOKUP' undeclared (first use in this function)
gapplookupgconf.c: At top level:
gapplookupgconf.c:99:51: error: expected ')' before '*' token
gapplookupgconf.c:165:47: error: expected ')' before '*' token
gapplookupgconf.c: In function 'g_app_lookup_gconf_register':
gapplookupgconf.c:174:35: error: 'G_DESKTOP_APP_INFO_LOOKUP_EXTENSION_POINT_NAME' undeclared (first use in this function)
make[2]: *** [libgiogconf_la-gapplookupgconf.lo] Error 1
make[2]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6/gconf'
make[1]: Leaving directory `/var/tmp/paludis/gnome-base-gvfs-1.6.6/work/gvfs-1.6.6'
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in gnome-base/gvfs-1.6.6::gentoo:
!!! In gnome2_src_compile at line 3711
!!! compile failure


Reproducible: Always
Comment 1 Rafał Mużyło 2010-11-19 11:49:19 UTC
What's your version of glib ?
Comment 2 fkhp 2010-11-19 15:22:34 UTC
(In reply to comment #1)
> What's your version of glib ?
> 
installed 2 slots:               
1.2.10-r5 {:1} 
2.27.3* {:2} 
Comment 3 Gilles Dartiguelongue gentoo-dev 2010-11-19 15:46:33 UTC
full build.log and emerge --info please.
Comment 4 Rafał Mużyło 2010-11-19 17:23:23 UTC
...and try not using unstable glib releases.
The header mentioned (/usr/include/gio-unix-2.0/gio/gdesktopappinfo.h) is in glib 2.26 (probably even earlier), so it seems that the development release is messing things up.
Comment 5 fkhp 2010-11-20 05:17:16 UTC
(In reply to comment #4)
> ...and try not using unstable glib releases.
> The header mentioned (/usr/include/gio-unix-2.0/gio/gdesktopappinfo.h) is in
> glib 2.26 (probably even earlier), so it seems that the development release is
> messing things up.
> 
downgrade to 2.26 resolved the problem.
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-11-20 09:29:39 UTC
This is a known problem, reopening for proper resolution.
Comment 7 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-11-20 09:31:55 UTC
You're using a version of glib from the gnome overlay which does not have keywords because it is known to be broken. Use gvfs-1.6.5 (in the overlay, unkeyworded), or wait till gvfs-1.7.0 is released, or wait till someone puts a git snapshot in the overlay.
Comment 8 Pacho Ramos gentoo-dev 2010-11-20 19:25:03 UTC
*** Bug 346177 has been marked as a duplicate of this bug. ***
Comment 9 yanglh 2011-01-06 10:28:06 UTC
Created attachment 259021 [details, diff]
patch (for glib verison 2.27.5)

this patch can help
Comment 10 Gilles Dartiguelongue gentoo-dev 2011-01-06 11:29:40 UTC
we well not fix gvfs-1.6.6 for glib 2.27, just use 1.6.5 in overlay.
Comment 11 Gilles Dartiguelongue gentoo-dev 2011-01-06 14:06:32 UTC
*** Bug 350680 has been marked as a duplicate of this bug. ***
Comment 12 Gilles Dartiguelongue gentoo-dev 2011-02-08 16:29:06 UTC
*** Bug 354095 has been marked as a duplicate of this bug. ***
Comment 13 Diego Elio Pettenò (RETIRED) gentoo-dev 2011-02-08 16:37:35 UTC
So if you mark this as duplicate, let's drop overlay keyword and reopen. This happened on tinderbox without overlays involved.
Comment 14 Gilles Dartiguelongue gentoo-dev 2011-02-08 16:49:23 UTC
it happened with a masked package, big news, I haven't had time to add gvfs-1.7 to the tree. I appreciate your work but please don't try to proactively test incomplete stuff, thanks.
Comment 15 Diego Elio Pettenò (RETIRED) gentoo-dev 2011-02-08 16:58:06 UTC
Then please state so when you dupe the bug, rather than duping it against a "gnome-overlay". The unmask was there from when you asked me to test the _previous_ version of glib.
Comment 16 Gilles Dartiguelongue gentoo-dev 2011-02-08 17:02:50 UTC
sorry I didn't think you would keep this unmask for longer than needed.
Comment 17 Gilles Dartiguelongue gentoo-dev 2011-02-25 21:55:33 UTC
reopening before fixing.
Comment 18 Gilles Dartiguelongue gentoo-dev 2011-02-25 22:03:26 UTC
+  25 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org> gvfs-1.6.6-r1.ebuild:
+  Fix build with >=glib-2.27, bug #346055.
+
Thanks for reporting.