Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 344345

Summary: virtual/jre and virtual/jdk needs sparc icedtea6-bin adding to avoid pulling in ibm-jdk-bin on SPARC
Product: Gentoo Linux Reporter: Alex Buell <alex.buell>
Component: New packagesAssignee: Java team <java>
Status: RESOLVED FIXED    
Severity: normal CC: xmw
Priority: High    
Version: 10.1   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 247140, 159780, 344659    

Description Alex Buell 2010-11-06 08:52:53 UTC
As part of preparation work to get dev-java/icedtea (source) and dev-java/icedtea6-bin up and running on sparc, could we please have sparc added so that it only pulls in icedtea6-bin and icedtea on sparc, instead of ibm-jdk-bin 

It is also intended to have both 32 bit and 64 bit versions of icedtea up and running on multilibbed SPARC, otherwise 32 bit will only be available in the near future.

Ideas welcome.
Comment 1 Michael Weber (RETIRED) gentoo-dev 2010-11-06 11:38:49 UTC
*** Bug 344347 has been marked as a duplicate of this bug. ***
Comment 2 Ralph Sennhauser (RETIRED) gentoo-dev 2012-06-05 15:36:30 UTC
emerge jdk:1.6 and emerge jdk:1.7 both should pull in icedtea from source now. The issue was icedtea-bin missing the -* keyword.

ibm-jdk-bin is masked by -* keyword and maybe also license. icedtea only by missing ~sparc keyword and is preferred by the virtual as well.

Whether there will be an icedtea-bin or not after icedtea from source is established for sparc is up to the sparc team.

Thanks for the report.