Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 342321

Summary: dev-util/insight-6.8.1 version bump
Product: Gentoo Linux Reporter: Peter Asplund <peterasplund>
Component: New packagesAssignee: Olivier Crete (RETIRED) <tester>
Status: RESOLVED FIXED    
Severity: major CC: alecm_88, dev-tools, esqualante, jimtahu, luke-jr+gentoobugs
Priority: High Keywords: Bug, EBUILD
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://sourceware.org/insight/
See Also: https://bugs.gentoo.org/show_bug.cgi?id=231874
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 343189    
Attachments: Proposed ebuild
insight-6.8_p1.ebuild, which works with current patches

Description Peter Asplund 2010-10-23 14:24:10 UTC
Updated Insight 6.8-1 available 
Insight 6.8 has been available for some time, and the current release tarball has issues with newer versions of X11. As a result, I am making available a patched Inisght 6.8-1 release which should fix all outstanding issues with X11.

Reproducible: Always
Comment 1 Peter Asplund 2010-10-27 20:11:17 UTC
Created attachment 252299 [details]
Proposed ebuild

This ebuild worked for me, at least to get it compiling (which the current version in portage (6.8) didn't do) and running.

I'm not sure if there is anything that needs to be fixed in it though. Hope it helps!
Comment 2 Luke-Jr 2011-01-26 15:56:43 UTC
insight-6.8-DESTDIR.patch is missing
Comment 3 Luke-Jr 2011-01-26 15:59:17 UTC
As is the other patch... but they seem to work with the 6.6 patches.
Comment 4 Oleh Kravchenko 2011-01-26 16:38:14 UTC
I am tried to run all version of Insight in Gentoo, but none of them don't even start successfully!

WTF? =(
Comment 5 Alec Meyers 2011-01-26 17:09:33 UTC
Created attachment 260791 [details]
insight-6.8_p1.ebuild, which works with current patches

Here's the ebuild I use, which works with the patches in the "current" version's FILESDIR.
Comment 6 Oleh Kravchenko 2011-01-26 18:15:39 UTC
(In reply to comment #5)
> Created an attachment (id=260791) [details]
> insight-6.8_p1.ebuild, which works with current patches
> 
> Here's the ebuild I use, which works with the patches in the "current"
> version's FILESDIR.
> 

Thank you very much!! :) It's works!
Comment 7 Peter Asplund 2011-09-14 19:39:17 UTC
Any chance the improved ebuild will reach portage anytime? It's a shame to have software that doesn't compile in portage.
Comment 8 fuzion 2011-12-18 05:20:17 UTC
What's the ETA to get insight 6.8.1 into portage? Another year or two? There's still a closed bug that was marked fixed over a year ago that's still present due to insight 6.8:
https://bugs.gentoo.org/show_bug.cgi?id=231874
Comment 9 Peter Asplund 2012-01-29 22:53:37 UTC
I've just gotten a portage overlay (AzP) and the fixed ebuild is in that overlay. Feel free to test it out.
Comment 10 Peter Asplund 2012-02-08 13:18:50 UTC
Friendly reminder that we have software in stable that doesn't compile, and a patch here that works...
Comment 11 Tomáš Chvátal (RETIRED) gentoo-dev 2012-03-06 13:39:06 UTC
Hopefully fixed in main tree.
Comment 12 Peter Asplund 2012-03-06 16:42:04 UTC
"Hopefully"? No changes has been made to the ebuild since 2008 (the version bump to 6.8, which is the version that doesn't compile), so to be fixed it must have been fixed in Xorg by reverting the API-changes.

Have you tried compiling it? I've been using this patch ever since, so I haven't seen the issue since I supplied this fix.
Comment 13 Alec Meyers 2012-03-06 17:13:28 UTC
Peter, calm down - Tomáš isn't insight's maintainer - I asked him about this bug on his blog and he went out of his way and fixed it, making a good number of changes to the ebuild as well.

I just tried compling insight-6.8.1 and it builds fine, and starts.

Did you sync yet?
Comment 14 Peter Asplund 2012-03-07 10:16:08 UTC
"Peter, calm down"

Sorry, I realize my post sounded a bit harsh, that's the problem with written language =) It really wasn't meant that way! I just wanted to point out that no changes had been made to the ebuild according to znurt. But I just checked packages.gentoo.org and it seems to be commited now, great!
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-util/insight/ChangeLog?view=markup

Thanks for getting the fix in, it was a long time coming :)