Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 341699

Summary: Request that sys-fs/btrfs-progs-0.19-r1 be marked as ~ppc64
Product: Gentoo Linux Reporter: Yang Dehua <yangdh>
Component: Current packagesAssignee: Joe Peterson (RETIRED) <lavajoe>
Status: VERIFIED FIXED    
Severity: normal Keywords: KEYWORDREQ
Priority: High    
Version: unspecified   
Hardware: PPC64   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Yang Dehua 2010-10-18 23:18:19 UTC
I have used btrfs under PPC64 for a while. and haven't encountered any problems. Could it be marked as testing? I use kernel 2.6.34-gentoo-r1, and other info as following:

Reproducible: Always

Steps to Reproduce:
1. mkfs.btrfs  /dev/sdb5
2.
3.

Actual Results:  
A functional disk partition


emerge --info
Portage 2.1.8.3 (default/linux/powerpc/ppc64/10.0/64bit-userland, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r1 ppc64)
=================================================================
System uname: Linux-2.6.34-gentoo-r1-ppc64-PPC970,_altivec_supported-with-gentoo-1.12.13
Timestamp of tree: Mon, 18 Oct 2010 08:30:01 +0000
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.5-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.65-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.33
ACCEPT_KEYWORDS="ppc64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -mpowerpc64 -fno-strict-aliasing -fomit-frame-pointer -pipe"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mcpu=970 -mtune=970 -maltivec -mabi=altivec -mpowerpc64 -fno-strict-aliasing -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.ucsb.edu/pub/mirrors/linux/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo http://lug.mtu.edu/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_US zh_CN"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acl aiglx alsa altivec asf aspell automount berkdb browserplugin bzip2 cairo cdr chardet cjk cli consolekit cpdflib cracklib crypt cups curl cxx dba dbus dri dts dvd dvdnav dvdr eds emerald encode esd exif extras faac faad2 fb ffmpeg flac foomaticdb fortran gd gd-external gdbm gimpprint glitz gmp gnome gnomecd gnutls gpm gstreamer gtk gtk2 hal ibm iconv imagemagick imlib ipv6 java jpeg jpeg2k lcms ldap mad mbox mng modules mp3 mpeg mpg mudflap mysql nas ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png policykit ppc64 ppds pppd python qt qt3support readline reflection samba saslradeon sdl secure-delete session slang spell sqlite ssl svg sysfs tcpd theora threads tiff unicode v4l v4l2 vcd vidix vorbis webkit wma xanim xcb xcomposite xine xml xml2 xmms xorg xulrunner xv xvid zlib" ALSA_CARDS="aoa" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US zh_CN" PHP_TARGETS="php-5.2" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="ati radeon fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Samuli Suominen gentoo-dev 2010-10-23 09:05:44 UTC
ok

+  23 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
+  btrfs-progs-0.19-r1.ebuild:
+  Keyword ~ppc64 wrt #341699 by Yang Dehua.
Comment 2 Samuli Suominen gentoo-dev 2010-10-23 09:19:55 UTC
Because dev-python/matplotlib wasn't keyworded, I masked USE=debug-utils for now. If you want USE=debug-utils unmasked, please open a new bug for matplotlib keywording... once you have tested it.