Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 339625

Summary: update for the ati-faq documentation
Product: [OLD] Docs on www.gentoo.org Reporter: Enrico Tagliavini <enrico.tagliavini>
Component: Other documentsAssignee: Docs Team <docs-team>
Status: VERIFIED WONTFIX    
Severity: normal CC: x11
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://www.gentoo.org/doc/en/ati-faq.xml
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: the xml patch
A little improvement, inspired by bug 257536
fix a little typo

Description Enrico Tagliavini 2010-10-03 20:10:58 UTC
currently the Gentoo Linux ATI FAQ is a bit out of date. I've tried to update it a bit and i also extended it. I'll attach a patch in minutes

Reproducible: Always

Steps to Reproduce:
Comment 1 Enrico Tagliavini 2010-10-03 20:12:25 UTC
Created attachment 249480 [details, diff]
the xml patch

this is the patch to be applied to the original xml doc file. Tested with xmllint, reports no errors. Works with gorg too.
Comment 2 Enrico Tagliavini 2010-10-03 22:05:32 UTC
Created attachment 249484 [details, diff]
A little improvement, inspired by bug 257536
Comment 3 Enrico Tagliavini 2010-10-03 22:27:54 UTC
Created attachment 249488 [details, diff]
fix a little typo

sorry, this should be the final one...... for now :)
Comment 4 nm (RETIRED) gentoo-dev 2010-10-03 23:03:03 UTC
Sorry, but this patch will not be added:

- It doesn't contain anything we'd like to add to the guide that's not already present
- It rearranges other information already present for no apparent reason
- It uses invalid/nonstandard configuration instructions, such as the kernel configs
- It still has GuideXML and spelling mistakes
- It nests methods inside completely unnecessary GuideXML tags, such as <dd>
- It addresses ~arch/hardmasked packages, which we don't document

We won't be applying this patch, but I do thank you for your suggestions.
Comment 5 Enrico Tagliavini 2010-10-17 02:26:07 UTC
Ok time to answer, sorry for the late but i was quite surprised by your answer Josh. Took me some time to clear my ideas.

Let me do a honest, but still kind and sane criticism, no flame at all really.

> - It uses invalid/nonstandard configuration instructions, such as the kernel
configs
Ok might be true, i didn't found a standard which stands the rule for kernel configs (i might just missed it) but this can be solved easly i think, so this is not the problem.

> - It still has GuideXML and spelling mistakes
Touché, mi english is bad as my GuideXML, but again this can easly be fixed with a little mentoring and english lessons :)

> - It nests methods inside completely unnecessary GuideXML tags, such as <dd>
I followed an example in the GuideXML Guide...... i might misinterpret it, this is my first attempt with GuideXML, i already mentioned a possible solution, so again this is not the real problem imho

> - It addresses ~arch/hardmasked packages, which we don't document
Wait what? x11-drivers/ati-drivers has 2 stable x86 and amd64 version in the main portage tree! (but it is true there was a time it missed them) Why ati-faq exist then? For radeon only? But it mentions ati-drivers more then one time. It also explain how to use the ati opengl implementation. Btw if it is unsupported it should be mentioned somewhere i think. I really don't get this.

> - It rearranges other information already present for no apparent reason
The reason is clearness, mix radeon and fglrx stuff is not worth imho, this is just a personal feeling motivated by what i see on irc: ati-drivers users are a little confused most of the times, and i try my best to help them.

> - It doesn't contain anything we'd like to add to the guide that's not already
present
Ehm..... who is "we"? Couse i talked about this with scarabeus in #gentoo-desktop before even thinking the idea of changing this myself. I just said "Mhm ati-faq might need an update" and he said me if i was proposing myself as volunteer...... why not? Anyway i think also lu_zero might wish to update this guide himself, but i know he has no time for sure. How do i know? Becouse i help him packaging/testing ati-drivers, see the ati-drivers changelog if you don't believe me.

So in short i saw ati-faq guide and we can say it is a bit poor. I compared to the nvidia one, and i thought i might help improving it since i have a good expirience with fglrx, both on the user and mantainer side.

> We won't be applying this patch, but I do thank you for your suggestions.
That's ok, i will continue my support work on IRC as i already done. Fglrx is a bit complicated sometimes, and trying to avoid it might be worth, this is a gentoo decision not mine. I think it is a pity to try to drop off it, since it can be usefull imho, i prefer it over radeon for now for various reasons, and i'm not alone.
Thank you for your time and sorry for the bother. I just wish to clarify my will