Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 336855

Summary: net-im/bitlbee-1.2.8: _FORTIFY_SOURCE indicates presence of overflow
Product: Gentoo Linux Reporter: Harm Geerts <gentoo+bugs>
Component: Current packagesAssignee: C├ędric Krier <cedk>
Status: RESOLVED FIXED    
Severity: QA    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 259417    
Attachments: build.log

Description Harm Geerts 2010-09-11 19:38:05 UTC
Merge fails with the following QA notice.

>>> Completed installing bitlbee-1.2.8 into /var/tmp/portage/net-im/bitlbee-1.2.8/image/

strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/sbin/bitlbee
ecompressdir: bzip2 -9 /usr/share/man

QA Notice: Package has poor programming practices which may compile
           fine but exhibit random runtime failures.

/usr/include/bits/string3.h:107: warning: call to __builtin___strcpy_chk will always overflow destination buffer

 Please file a bug about this at http://bugs.gentoo.org/
 with the maintaining herd of the package.

ERROR: net-im/bitlbee-1.2.8 failed:
  install aborted due to poor programming practices shown above

Call stack:
  misc-functions.sh, line 975:  Called install_qa_check 
  misc-functions.sh, line 660:  Called die 
The specific snippet of code: 
                                die "install aborted due to" \

If you need support, post the output of 'emerge --info =net-im/bitlbee-1.2.8',
the complete build log and the output of 'emerge -pqv =net-im/bitlbee-1.2.8'.
The complete build log is located at '/var/tmp/portage/net-im/bitlbee-1.2.8/temp/build.log'.
The ebuild environment file is located at '/var/tmp/portage/net-im/bitlbee-1.2.8/temp/environment'.
S: '/var/tmp/portage/net-im/bitlbee-1.2.8/work/bitlbee-1.2.8'

Reproducible: Always




emerge --info 
Portage 2.1.9.3 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.12.1-r1, 2.6.34-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.34-gentoo-r2-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.1
Timestamp of tree: Sat, 11 Sep 2010 18:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.1_p7
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r3, 3.1.2-r4
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.6.3
sys-apps/sandbox:    2.3-r1
sys-devel/autoconf:  2.13, 2.67
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.10
sys-devel/make:      3.81-r2
virtual/os-headers:  2.6.35 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA ETQW RTCW-ETEULA dlj-1.1 AdobeFlash-10 AdobeFlash-10.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -msse4 -msse4.1 -msse4.2 -mcx16 -msahf -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -msse4 -msse4.1 -msse4.2 -mcx16 -msahf -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache collision-protect distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.cambrium.nl/pub/os/linux/gentoo/ http://gentoo.tiscali.nl/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo/ http://distfiles.gentoo.org/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US nl nl_NL fy fy_NL"
MAKEOPTS="-j9 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/etc/portage/overlays/freevo2 /etc/portage/overlays/general"
SYNC="rsync://mirror.cambrium.nl/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 bash-completion berkdb bzip2 cli cracklib crypt cxx dbus dga fortran gdbm gif gpm gtk hal iconv inotify ipv6 jpeg jpeg2k kde kdehiddenvisibility lzo mmx mmxext modules mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre png policykit pppd python qt3support qt4 readline reflection sdl semantic-desktop session sse sse2 ssl svg sysfs tcpd tiff truetype unicode xcb xcomposite xml xorg xpm xv zlib" ALSA_CARDS="emu10k1x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="soundvision" ELIBC="glibc" INPUT_DEVICES="evdev keyboard" KERNEL="linux" LCD_DEVICES="hd44780" LINGUAS="en en_US nl nl_NL fy fy_NL" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Harm Geerts 2010-09-11 19:38:45 UTC
Created attachment 246898 [details]
build.log
Comment 2 Tim Harder gentoo-dev 2011-10-11 19:42:12 UTC
Only 3.0.3 remains in the tree and I think this specific issue has been fixed since 1.2.8 although other QA notices still exist.