Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 334641

Summary: dev-libs/libtecla does not respect LDFLAGS
Product: Gentoo Linux Reporter: Diego Elio Pettenò (RETIRED) <flameeyes>
Component: New packagesAssignee: Gentoo Science Related Packages <sci>
Status: RESOLVED FIXED    
Severity: QA CC: esigra
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 331933    
Attachments: Build log

Description Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-26 14:54:48 UTC
See attached build log.

(Please do not complain about the need for looking at the build log until you can provide an easy way to open bugs with the correct data picked out of a tinderbox log. Thanks.)
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2010-08-26 14:55:02 UTC
Created attachment 244743 [details]
Build log
Comment 2 Kacper Kowalik (Xarthisius) (RETIRED) gentoo-dev 2010-10-14 13:45:00 UTC
+*libtecla-1.6.1-r1 (14 Oct 2010)
+
+  14 Oct 2010; Kacper Kowalik <xarthisius@gentoo.org>
+  -libtecla-1.6.0-r1.ebuild, libtecla-1.6.1.ebuild,
+  +libtecla-1.6.1-r1.ebuild, +files/libtecla-1.6.1-ldflags.patch,
+  +files/libtecla-1.6.1-parallel_build.patch:
+  Respect LDFLAGS wrt bug 334641. Thanks to Diego for the report. Fix
+  parallel build, add missing dies and explicit RDEPEND. Drop old.
+
Comment 3 Justin Lecher gentoo-dev 2011-01-07 18:24:55 UTC
*** Bug 350992 has been marked as a duplicate of this bug. ***
Comment 4 Justin Lecher gentoo-dev 2011-01-07 18:25:10 UTC
Seems not to be fixed.
Comment 5 Justin Lecher gentoo-dev 2011-01-07 19:16:13 UTC
The problem are LDFLAGS with spaces in between
Comment 6 Justin Lecher gentoo-dev 2012-05-08 19:38:08 UTC
+*libtecla-1.6.1-r2 (08 May 2012)
+
+  08 May 2012; Justin Lecher <jlec@gentoo.org> +libtecla-1.6.1-r2.ebuild,
+  +files/libtecla-1.6.1-LDFLAGS2.patch,
+  +files/libtecla-1.6.1-parallel_build2.patch,
+  +files/libtecla-1.6.1-prll-install.patch, metadata.xml:
+  Move to EAPI=4, respect LDFLAGS, #334641; fix parallel install, #377987
+