Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 333073

Summary: net-proxy/squid-3.1.6-r1 broken with -ipv6
Product: Gentoo Linux Reporter: Will B. <wbricks>
Component: Current packagesAssignee: Gentoo Network Proxy Developers (OBSOLETE) <net-proxy+disabled>
Status: RESOLVED DUPLICATE    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://bugs.squid-cache.org/show_bug.cgi?id=2753
Whiteboard:
Package list:
Runtime testing required: ---

Description Will B. 2010-08-16 21:02:05 UTC
If the system is built with the -ipv6 flag, the latest stable Squid proxy is broken for HTTPS requests.  This appears to be a known bug - the URL reflects a similar bug filed with Debian.

Reproducible: Always

Steps to Reproduce:
1. Build system with -ipv6
2. Attempt to access an HTTPS site using Squid
3.

Actual Results:  
The following error was encountered while trying to retrieve the URL: https://www.paypal.com/*

Socket Failure

The system returned: (97) Address family not supported by protocol

Squid is unable to create a TCP socket, presumably due to excessive load. Please retry your request.

Your cache administrator is root.

Expected Results:  
Access to the website.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581901

The upstream bug seems to indicate that it's fixed in 3.1.3, but that doesn't appear to be the case in Gentoo world (and perhaps not upstream either).  I'm currently rebuilding my system with +ipv6 to confirm that works.

Another host system of mine is built with +ipv6 and I didn't trigger this issue, leading me to believe that is indeed the fix.  I'll update in an hour or so when everything rebuilds.
Comment 1 Will B. 2010-08-16 21:03:24 UTC
Further reading into the upstream bug indicates that might be a separate issue specific to DNS handling.
Comment 2 Will B. 2010-08-16 22:59:36 UTC
Rebuilt with +ipv6 and everything works as expected.  That would appear to be the workaround.
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2010-08-17 19:22:16 UTC

*** This bug has been marked as a duplicate of bug 331965 ***