Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 333049

Summary: dev-perl/Tk parallel make failure
Product: Gentoo Linux Reporter: Jeroen Roovers (RETIRED) <jer>
Component: Current packagesAssignee: Gentoo Perl team <perl>
Status: RESOLVED FIXED    
Severity: QA CC: esigra, jstein
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 331933, 351559    
Attachments: dev-perl:perl-tk-804.028-r2:20100816-173721.log
dev-perl:perl-tk-804.029:20100816-175327.log

Description Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 18:25:20 UTC
^G
 * QA Notice: Files built without respecting LDFLAGS have been detected
 *  Please include the following list of files in your report:
 * /usr/lib/perl5/vendor_perl/5.8.8/powerpc-linux/auto/Tk/Tk.so
^G
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 18:25:43 UTC
Created attachment 243257 [details]
dev-perl:perl-tk-804.028-r2:20100816-173721.log
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 18:26:13 UTC
Created attachment 243259 [details]
dev-perl:perl-tk-804.029:20100816-175327.log
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 18:38:39 UTC

*** This bug has been marked as a duplicate of bug 233354 ***
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 18:42:33 UTC
(In reply to comment #17)
> (In reply to comment #16)
> > Try with MAKEOPTS=-j1. Looks like a parallel make issue.
> Parallel build issue it is... Sorry for the noise 

OK, so it's specific to this package...
Comment 5 Torsten Veller (RETIRED) gentoo-dev 2010-08-16 19:03:55 UTC
Jepp, i agree. Workaround added.
Comment 6 Jeroen Roovers (RETIRED) gentoo-dev 2010-08-16 20:15:52 UTC
(In reply to comment #5)
> Jepp, i agree. Workaround added.

Not perfect, as now all ebuild phases run slower, instead of just src_install() where the issue is. How about this:

Index: perl-tk-804.029.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-perl/perl-tk/perl-tk-804.029.ebuild,v
retrieving revision 1.2
diff -u -B -r1.2 perl-tk-804.029.ebuild
--- perl-tk-804.029.ebuild      16 Aug 2010 19:02:24 -0000      1.2
+++ perl-tk-804.029.ebuild      16 Aug 2010 20:15:33 -0000
@@ -34,4 +34,7 @@
 myconf="X11ROOT=${EPREFIX}/usr XFT=1 -I${EPREFIX}/usr/include/ -l${EPREFIX}/usr/$(get_
libdir)"                                                                                mydoc="ToDo VERSIONS"
 
-MAKEOPTS+=" -j1" #333049
+src_install() {
+       MAKEOPTS+=" -j1" #333049
+       perl-module_src_install
+}

Or this:

Index: perl-module.eclass
===================================================================
RCS file: /var/cvsroot/gentoo-x86/eclass/perl-module.eclass,v
retrieving revision 1.126
diff -u -B -r1.126 perl-module.eclass
--- perl-module.eclass  15 Jul 2010 11:44:48 -0000      1.126
+++ perl-module.eclass  16 Aug 2010 20:14:05 -0000
@@ -205,6 +205,7 @@
                        || die "./Build ${mytargets} failed"
        elif [[ -f Makefile ]] ; then
                emake ${myinst} ${mytargets} \
+                       OTHERLDFLAGS="${LDFLAGS}" \
                        || die "emake ${myinst} ${mytargets} failed"
        fi
 
Comment 7 Torsten Veller (RETIRED) gentoo-dev 2010-08-20 07:10:54 UTC
(In reply to comment #6)
> (In reply to comment #5)
> Not perfect,

True.

> where the issue is. How about this:
> 
> Index: perl-tk-804.029.ebuild
> ===================================================================

> -MAKEOPTS+=" -j1" #333049
> +src_install() {
> +       MAKEOPTS+=" -j1" #333049
> +       perl-module_src_install
> +}

Doesn't help. It still recreates blib/arch/auto/Tk/Tk.so during src_install.

> Or this:
> 
> Index: perl-module.eclass
> ===================================================================

>         elif [[ -f Makefile ]] ; then
>                 emake ${myinst} ${mytargets} \
> +                       OTHERLDFLAGS="${LDFLAGS}" \
>                         || die "emake ${myinst} ${mytargets} failed"
>         fi

It shouldn't have to recreate anything for the all target.

I really think we have to understand the underlying problem.


BTW: This only happens if EU::MM-6.56 installed:
| -pure_vendor_install ::
| +pure_vendor_install :: all
Comment 8 Larry the Git Cow gentoo-dev 2021-10-07 23:59:00 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=adf81142c9a79a79425eda7a3827dbef16905f1b

commit adf81142c9a79a79425eda7a3827dbef16905f1b
Author:     Andreas K. Hüttel <dilfridge@gentoo.org>
AuthorDate: 2021-10-07 23:52:11 +0000
Commit:     Andreas K. Hüttel <dilfridge@gentoo.org>
CommitDate: 2021-10-07 23:52:11 +0000

    dev-perl/Tk: Parallel make seems to work now, fingers crossed.
    
    Closes: https://bugs.gentoo.org/333049
    Package-Manager: Portage-3.0.28, Repoman-3.0.3
    Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>

 dev-perl/Tk/Tk-804.36.0.ebuild | 1 -
 1 file changed, 1 deletion(-)