Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 332393

Summary: dev-vcs/mercurial has problems with >=dev-lang/python-2.6.5-r3
Product: Gentoo Linux Reporter: Benjamin Schindler <beschindler>
Component: [OLD] DevelopmentAssignee: Krzysztof Pawlik (RETIRED) <nelchael>
Severity: normal CC: arfrever, denilsonsa, djc, gentoo, junghans
Priority: High    
Version: unspecified   
Hardware: All   
OS: All   
Package list:
Runtime testing required: ---

Description Benjamin Schindler 2010-08-12 08:05:19 UTC
I have python-2.6.5 as my default python env (installed dev-lang/python-2.6.5-r3). 

With complex repositories, basic authentication to webserver can fail according to this bugreport:
I patched mercurial with the issue2255fix-basicauth.diff patch (the other patch is in 1.6.0) and it fixes the issue. It seems that gentoo packported changes to urllib2 to 2.6.5 which breaks mercurial. 

Since the urllib2 changes are to appear in 2.6.6 (which is quite a broken package according to the mercurial devs), it might make sense to patch mercurial with this patch. 1.4 (stable) is affected too by this problem (tried it). According to one of their devs, they want to move away from urllib2 as it seems to be too broken, but until they do that, I think mercurial should be patched. 1.4 too if the patch applies (haven't tried)

Reproducible: Always

bschindl@hundertwasser /local/bschindler/projects/icos_dhcp $ emerge --info
Portage 2.2_rc67 (default/linux/amd64/10.0, gcc-4.4.4, glibc-2.11.2-r0, 2.6.32-gentoo-r7 x86_64)
System uname: Linux-2.6.32-gentoo-r7-x86_64-Intel-R-_Xeon-R-_CPU_E5430_@_2.66GHz-with-gentoo-1.12.13
Timestamp of tree: Thu, 12 Aug 2010 06:45:03 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.5-r3, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.4-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_LICENSE="* -@EULA dlj-1.1 skype-eula googleearth AdobeFlash-10.1"
CFLAGS="-O2 -pipe -march=native"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb /var/lib/redmine/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde /usr/local/portage"
USE="X aac accessibility acl alsa amd64 bash-completion berkdb bzip2 cairo chm cleartype cli consolekit cracklib crypt cups cupsddk curl cxx dbus dri dvd encode exif expat fam ffmpeg fortran gdbm gif git gnome gpm gtk hal iconv inotify ipv6 jpeg jpeg2k kde kdrive kerberos kpathsea latex ldap libnotify lm_sensors mad mercurial mmx mng modules mp3 msn mudflap multilib mysql ncurses nls nptl nptlonly opengl openmp oscar pam pch pcre pdf perl png policykit ppds pppd python qt3support qt4 raw rdp readline reflection samba sasl sdl semantic-desktop session snmp sound spell spl sql sse sse2 ssl startup-notification subversion svg sysfs taglib tcpd theora threads unicode vim-syntax vorbis webkit xattr xcb xcomposite xinerama xorg xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Benjamin Schindler 2010-08-12 08:09:49 UTC
Okay, I wrote too fast, just to clarify: 

* Vanilla python-2.6.5 works fine with unpatched mercurial (several people in #mercurial tested)
* gentoo-2.6.5 doesn't work, debian patched as well so doesn't work either

* issue2255fix.diff is in 1.6.0 (probably required for the second patch, but don't know)
* issue2255fix-basicauth.diff is required to fix the issue
* If the test here: returns true, the system is affected by the bug (was here)

I didn't write what actually is the problem: hg in, hg pull return an authorization failure with complex repos where there are many requests, which leaves one unable to pull against servers which use BASIC authentication (DIGEST is fixed with 1.6.0 afaik)
Comment 2 Jory A. Pratt gentoo-dev 2010-08-12 17:53:45 UTC

*** This bug has been marked as a duplicate of bug 329517 ***
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-08-13 16:05:57 UTC
dev-vcs/mercurial needs to be fixed.
Comment 4 Krzysztof Pawlik (RETIRED) gentoo-dev 2010-08-19 12:54:33 UTC
Dirkjan: how easy/troublesome would be using the patch from in 1.6.1-r1?
Comment 5 Christoph Junghans (RETIRED) gentoo-dev 2010-08-30 19:13:09 UTC
fixed in mercurial-1.6.3 (at least for me)
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-09-23 20:29:36 UTC
Please test >=dev-vcs/mercurial-1.6.3.
Comment 7 Denilson Sá Maia 2010-09-23 22:52:24 UTC
(In reply to comment #5)
> fixed in mercurial-1.6.3 (at least for me)

I can confirm that. I'm using that mercurial version as soon as it hit portage, and haven't found any issues.