Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 331867

Summary: app-misc/anki version bump please; 1.0 was released
Product: Gentoo Linux Reporter: Josiah Worcester <josiahw>
Component: Current packagesAssignee: Patrick Lauer <patrick>
Severity: enhancement CC: alastairmurray, paluszak
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: anki-1.0 ebuild
anki-1.0 ebuild

Description Josiah Worcester 2010-08-09 16:42:32 UTC
Anki ( has released a 1.0, but the latest version in portage is

Reproducible: Always
Comment 1 Jakub Paluszak 2010-08-11 21:33:43 UTC
Created attachment 242505 [details]
anki-1.0 ebuild
Comment 2 Jakub Paluszak 2010-08-11 21:35:35 UTC
I have attached a working ebuild for anki, a slightly modified ebuild for anki- It works for me, pls check it out and say if you have any problems.
Comment 3 Paul Berens 2010-08-13 01:14:00 UTC
Seems to work for most part, but the graphs seems borked, but I think this may be another issue anyway.
Comment 4 Jakub Paluszak 2010-08-13 06:07:49 UTC
(In reply to comment #3)
> Seems to work for most part, but the graphs seems borked, but I think this may
> be another issue anyway.

Graphs work ok for me (dev-python/numpy-1.4.1, dev-python/matplotlib- on stable x86. I'll check amd64 later, but they seem to be working all right there too.

Comment 5 Alastair Murray 2010-08-14 16:34:58 UTC
Re: broken graphs

Drawing graphs now requires >=dev-python/PyQt4-4.7, but the attached 1.0 ebuild (and in in-tree version) only requires >=dev-python/PyQt4-4.4, perhaps you have an older version? (Though there is a 4.7 version stable, so perhaps not.)

Either way, the dependency should be on >=4.7, see bug #307035 and (the changes).  PyQt4-4.7.3 is stable on both amd64 and x86 (the only keyworded arches for this ebuild), and I've been using a git checkout of Anki with that version for a while without issue, so the bump should be safe.
Comment 6 Jakub Paluszak 2010-08-14 17:57:07 UTC
Created attachment 242973 [details]
anki-1.0 ebuild

True, I updated deps. PyQt-4.7 is required now, as *strongly recommended* upstream.
Comment 7 Patrick Lauer gentoo-dev 2010-08-18 17:27:45 UTC
+  18 Aug 2010; Patrick Lauer <> anki-,
+  +anki-1.0.ebuild:
+  Bump to 1.0, fixes #331867.

Thanks :)