Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 328355

Summary: dev-libs/openssl: ABI slot for 0.9.8
Product: Gentoo Linux Reporter: Samuli Suominen <ssuominen>
Component: Current packagesAssignee: Gentoo's Team for Core System packages <base-system>
Status: VERIFIED FIXED    
Severity: enhancement CC: deepee, leho, nx, realnc
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Attachments: openssl-0.9.8o-r1installing only 2 libs
Try #2

Description Samuli Suominen gentoo-dev 2010-07-15 07:19:13 UTC
We have at least app-emulation/vmware-workstation in tree still using .so.0.9.8.
I guess we need slotted ebuild for the old version for a while.

Patch will follow...
Comment 1 Samuli Suominen gentoo-dev 2010-07-15 07:20:33 UTC
Created attachment 238845 [details, diff]
openssl-0.9.8o-r1installing only 2 libs
Comment 2 Bernard Cafarelli gentoo-dev 2010-07-15 12:59:53 UTC
Add net-misc/nxclient to the list... (nxssh binary needs libcrypto.so.0.9.8)
Comment 3 SpanKY gentoo-dev 2010-07-15 14:31:47 UTC
you'll need to block openssl-0.9.8*:0 in RDEPEND

the PDEPEND isnt useful

is there a config option to disable static ?  or at least change the make in src_compile so it only generates the library and not the helper `openssl` and such.
Comment 4 Samuli Suominen gentoo-dev 2010-07-15 15:02:55 UTC
Created attachment 238897 [details, diff]
Try #2

- Drop needless PDEPEND
- Add missing blocker
- "make build_libs" instead of "make all rehash", still builds static archives though, there's no sane way to disable them (no configure option, the building of shared targets expects them to be around)
Comment 5 Andreas K. Hüttel gentoo-dev 2010-07-15 16:09:39 UTC
*** Bug 196667 has been marked as a duplicate of this bug. ***
Comment 6 SpanKY gentoo-dev 2010-07-15 19:41:00 UTC
looks fine; go for it.  connect 4.
Comment 7 Samuli Suominen gentoo-dev 2010-07-17 10:02:11 UTC
+*openssl-0.9.8o-r1 (17 Jul 2010)
+
+  17 Jul 2010; Samuli Suominen <ssuominen@gentoo.org>
+  +openssl-0.9.8o-r1.ebuild:
+  This ebuild will only install libcrypto.so.0.9.8 and libssl.so.0.9.8 for
+  binary-only pkgs wrt #328355.
Comment 8 Nikos Chantziaras 2010-07-18 09:47:59 UTC
This change is problematic. On my system, the same files are owned by two different packages now. openssl-0.9.8o-r1 as well as openssl-1.0.0a, because 1.0.0a will still say "Old versions of installed libraries were detected on your system [...]" and then own *.so.0.9.8 files.
Comment 9 Samuli Suominen gentoo-dev 2010-07-18 09:54:33 UTC
(In reply to comment #8)
> This change is problematic. On my system, the same files are owned by two
> different packages now. openssl-0.9.8o-r1 as well as openssl-1.0.0a, because
> 1.0.0a will still say "Old versions of installed libraries were detected on
> your system [...]" and then own *.so.0.9.8 files.
> 

Same story with every preserve_old_lib addition, you can observe it with libpng, gmp, or any other ebuild using preserve_old_lib (just grep the tree for fun), nothing new here, move along...
You just have to follow the postinst stuff first, then re-emerge openssl to get the files out of CONTESTS, and then emerge the slotted one
Comment 10 Nikos Chantziaras 2010-07-18 10:03:45 UTC
(In reply to comment #9)
> 
> Same story with every preserve_old_lib addition, you can observe it with
> libpng, gmp, or any other ebuild using preserve_old_lib (just grep the tree for
> fun), nothing new here, move along...
> You just have to follow the postinst stuff first, then re-emerge openssl to get
> the files out of CONTESTS, and then emerge the slotted one

I have to do that every single time I need to emerge openssl 1.x?  (Because obviously it's gonna find the older 0.9 version installed since now it gets pulled a dep by vmware and other binary packages.)
Comment 11 SpanKY gentoo-dev 2010-07-18 19:39:17 UTC
should have been a new bug, but oh well

http://sources.gentoo.org/dev-libs/openssl/openssl-1.0.0a.ebuild?r1=1.2&r2=1.3