Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 328095

Summary: Handbook (ARM) missing FSTAB example in Chap 8 "Configuring Your System"
Product: [OLD] Docs on www.gentoo.org Reporter: John L. Poole <jlpoole56>
Component: Installation HandbookAssignee: nm (RETIRED) <nightmorph>
Status: RESOLVED FIXED    
Severity: normal CC: docs-team
Priority: High    
Version: unspecified   
Hardware: ARM   
OS: Linux   
URL: http://www.gentoo.org/doc/en/handbook/handbook-arm.xml?part=1&chap=8
Whiteboard:
Package list:
Runtime testing required: ---

Description John L. Poole 2010-07-13 12:17:42 UTC
Chapter 8 of the Gentoo Linux ARM Handbook at
http://www.gentoo.org/doc/en/handbook/handbook-arm.xml?part=1&chap=8
has:
vvvvvvvvvvvvvvvvvv
Now use the example below to create your /etc/fstab:

auto makes mount guess for the filesystem (recommended for removable media as they can be created with one of many filesystems) and user makes it possible for non-root users to mount the CD. 

^^^^^^^^^^^^^^^^

I think there is suppose to be a table showing an example /etc/fstab file.  Instead, the paragraph "auto makes..." follows.  Compare with the x86 handbook at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=8 where there is a listing.

Reproducible: Always

Steps to Reproduce:
1. http://www.gentoo.org/doc/en/handbook/handbook-arm.xml?part=1&chap=8


Actual Results:  
Now use the example below to create your /etc/fstab:

auto makes mount guess for the filesystem (recommended for removable media as they can be created with one of many filesystems) and user makes it possible for non-root users to mount the CD. 

Expected Results:  
Now use the example below to create your /etc/fstab:

[A table listing of fstab]

auto makes mount guess for the filesystem (recommended for removable media as they can be created with one of many filesystems) and user makes it possible for non-root users to mount the CD.
Comment 1 nm (RETIRED) gentoo-dev 2010-07-13 20:38:35 UTC
Yup, this was missed when we went to the 'programmable' handbooks. At the time, I think the ARM handbook was so different it didn't have a real /boot partition, so it didn't receive the same generic example that all the other handbooks did, the ones that setup a /boot partition (pretty much everything except PowerPC). I believe we intended to give ARM its own particular suggested fstab and partition layout, but it looks like we never did.

The rest of it is standard enough that I'll give it the basic, default fstab text, since hb-install-arm-disk.xml does mention /boot as being /dev/sda1.

Thanks for reporting; fixed in CVS.