Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 326393

Summary: kde-4.6.2 and earlier: shutdown, reboot, logout does not work when sytemsounds are active
Product: Gentoo Linux Reporter: Rich Gannon <rich>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: major CC: akborder, andy.dalton, dirk, gothiger, junk.vernerey, misiek303, neoannagul, orzel, sharkman.ru
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
URL: https://bugs.kde.org/show_bug.cgi?id=228005
Whiteboard:
Package list:
Runtime testing required: ---

Description Rich Gannon 2010-07-01 02:53:30 UTC
Everything was working fine in KDE 4.3.  Since KDE 4.4.4 was installed two days ago once it went stable, I can not logout, shutdown, or reboot from within KDE, however I can put the computer to sleep (suspend to RAM) without issue.

I can shutdown and reboot from KDM when not logged into KDE.

In addition, if I restart xdm to logout of KDE, any subsequent login is crash riden.  KDE applications crash at random because sockets weren't closed from the previous session.  I'm not sure if this is normal, but I've never experienced it when I did that in previous versions of KDE.

Reproducible: Always

Steps to Reproduce:
1. Login to KDE 4.4.4
2. Use the K menu to logout, reboot, or shutdown
3. Confirm action (if configured to do so)
Actual Results:  
Nothing happens.

Expected Results:  
Logout, reboot, or shutdown as expected.

I ran an emerge -e world after experiencing the problems, which made no difference.  All programs are up to date as of today, as well.

I also removed the .kde4 directory, .kderc file, and all other files that may or may not contribute to the issue (.mcop, .dbus, .local, .config, .qt, etc.).  Logging into a fresh, first run session made no different at all.

rich@area51 ~ $ groups
lp wheel floppy audio cdrom video cdrw usb users plugdev

rich@area51 ~ $ emerge --info
Portage 2.1.8.3 (default/linux/x86/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.34-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.34-gentoo-r1-i686-Intel-R-_Core-TM-_i7_CPU_940_@_2.93GHz-with-gentoo-1.12.13
Timestamp of tree: Wed, 30 Jun 2010 17:00:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2 -mtune=native -msse4 -mfpmath=sse -mcx16 -mpopcnt -msahf -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=core2 -mtune=native -msse4 -mfpmath=sse -mcx16 -mpopcnt -msahf -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j14"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var"
PORTDIR="/usr/portage"
SYNC="rsync://home.richgannon.info/gentoo-portage"
USE="X a52 aac acl aim alsa amarok berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt cups cxx dbus dhcp divx dri dts dvd dvdr dvdread embedded esd fam ffmpeg firefox foomaticdb fortran gdbm gif glibc-omitfp glitz gmplayer gpm gtk gtk2 hal iconv java javascript jpeg kde lame lm_sensors logitech-mouse mad mmap mmx mmxext modules mp3 mpeg mplayer mudflap ncurses nls nptl nptlonly nvidia offensive openal opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime rdp readline reflection samba sdl semantic-desktop session smp spl sse sse2 sse3 ssl svg symlink sysfs tcpd threads tiff truetype truetype-fonts type1-fonts unicode usb v4l vdpau vidix vnc win32codecs x264 x86 xine xinerama xorg xpm xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

rich@area51 ~ $ cat /etc/portage/package.keywords 
sys-apps/lm_sensors ~x86
sys-kernel/gentoo-sources ~x86
sys-fs/btrfs-progs ~x86
x11-drivers/nvidia-drivers ~x86
media-video/nvidia-settings ~x86
x11-libs/libvdpau ~x86

rich@area51 ~ $ cat /etc/portage/package.use
x11-libs/pixman -sse2
media-video/mkvtoolnix wxwidgets
dev-python/PyQt4 sql webkit
dev-java/sun-jdk nsplugin
x11-libs/qt-sql mysql

rich@area51 ~ $ rc-status
Runlevel: default
 consolekit                                                             [ started  ]
 cupsd                                                                  [ started  ]
 dbus                                                                   [ started  ]
 hald                                                                   [ started  ]
 hddtemp                                                                [ started  ]
 hdparm                                                                 [ started  ]
 local                                                                  [ started  ]
 net.eth0                                                               [ started  ]
 nfs                                                                    [ started  ]
 portmap                                                                [ started  ]
 rdate                                                                  [ started  ]
 rsyncd                                                                 [ started  ]
 sshd                                                                   [ started  ]
 udev-postmount                                                         [ started  ]
 wol                                                                    [ started  ]
 xdm                                                                    [ started  ]
Comment 1 Rich Gannon 2010-07-01 03:28:47 UTC
I should also note that I experience the same issue on two other computers of mine.  Each have different hardware, and software varies a bit but all 3 are running the latest ebuilds and no special KDE configuration or add-ons.
Comment 2 annagul 2010-07-01 08:04:41 UTC
kde-4.4.4 here, and I don't have this issue.
Comment 3 Rich Gannon 2010-07-01 17:02:05 UTC
A bit of an update.  I changed my profile from default/linux/x86/10.0 to default/linux/x86/10.0/desktop/kde, which added acpi and consolekit to the USE flags (among other unrelated USE flags), rebuilt with emerge -NDuv world and revdep-rebuild for good measure.  No change, still.
Comment 4 Aidar 2010-07-07 10:34:38 UTC
I have observed the same symptoms of, and only on x86 system on x86_64 and it works.
Comment 5 Michal Augustyniak 2010-07-07 15:31:52 UTC
same thing on my t61p, upgraded kde to 4.4.4 last weekend and shutdown, reboot does not work any more
Comment 6 Luc VERNEREY 2010-07-07 20:55:05 UTC
Same here. Logout/shutdown doesn't work anymore since 4.3.x.
Upgraded to 4.4.4 hoping to see works again, but it's still stucked.

Comment 7 Luc VERNEREY 2010-07-07 21:00:13 UTC
Can this thread in the forums contains THE solution or just a workaround?

http://forums.gentoo.org/viewtopic-t-814931-highlight-restart.html
Comment 8 Rich Gannon 2010-07-07 21:59:57 UTC
(In reply to comment #7)
> Can this thread in the forums contains THE solution or just a workaround?
> 
> http://forums.gentoo.org/viewtopic-t-814931-highlight-restart.html
> 

For some that may fix the issue.  In my case, the problem is not the files in .kde4/ or the .kderc file.  I setup a new user as suggested in that thread and not even that user can logout, shutdown, or reboot.
Comment 9 Michal Augustyniak 2010-07-07 22:16:13 UTC
For me new user cannot shutdown, reboot and logout either

> For some that may fix the issue.  In my case, the problem is not the files in
> .kde4/ or the .kderc file.  I setup a new user as suggested in that thread and
> not even that user can logout, shutdown, or reboot.
> 

Comment 10 Luc VERNEREY 2010-07-08 11:37:20 UTC
(In reply to comment #9)
> For me new user cannot shutdown, reboot and logout either
> > For some that may fix the issue.  In my case, the problem is not the files in
> > .kde4/ or the .kderc file.  I setup a new user as suggested in that thread and
> > not even that user can logout, shutdown, or reboot.
> > 


On my side, it worked for a new user I created. However, I still don't know what file(s) do the mess in my default profile and needs to be trashed in order for the logout to work again.
Comment 11 Roli 2010-07-09 08:00:37 UTC
Because of an akonadi error while starting KMail, I did
(see userbase.kde.org/Akonadi_4.4/Troubleshooting, search for "Nepomuk Indexing Agents have been Disabled")

 qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit
 rm -r ~/.kde/share/apps/nepomuk
 rm -r ~/.kde4/share/apps/nepomuk
 nepomukserver

Then I did the usual thing after recognising that ~/.kde exists again after a KDE upgrade (because I hate when some programs write to .kde/ and others to .kde4/)

 rm -f ~/.kde
 ln -s .kde4 .kde

Then I couldn't logout, shutdown etc. this session. That means, the window which says "Turning off computer in 30 seconds" didn't show up. The "lock/logout" panel from the taskbar didn't react, too.

After reading http://forums.gentoo.org/viewtopic-t-834293.html (I didn't follow any advice because I had to leave the house in 2 minutes), I did:

 Switching to console
 /etc/init.d/xdm stop
 shutdown -h now

and after a reboot, I can logout, shutdown etc.

Now I don't know If the things I did before were causing the problem or solving them (especially the rm -f ~/.kde thing).

BTW, I experienced something strange in the beginning of the session I couldn't logout etc. : all of my konqueror windows were restored twice, everything else only once.

Hope this helps to track down the bug.
Comment 12 Michal Augustyniak 2010-07-09 16:38:45 UTC
It gotta be something else, we have different issue. Deleting .kde4 directory does not help, also new created user cannot shutdown.

I am still looking because I can't sleep and live without this my shutdown action working. I tried remering xorg, nvidia drivers and all drivers such s keyboard and mouse. Tried add hal flag to xorg, desktop had more issues after that but shutdown still wasn't working.

Google says deleting ~/.kde4 directory helps so it could be not kde related.


>  qdbus org.kde.NepomukServer /nepomukserver org.kde.NepomukServer.quit
>  rm -r ~/.kde/share/apps/nepomuk
>  rm -r ~/.kde4/share/apps/nepomuk
>  nepomukserver
> 
Comment 13 Luc VERNEREY 2010-07-09 20:53:45 UTC
I beat you all, read this (true story) :

I simply moved the .kde4/share/config to another location.
I powered off the computer
On next day, seeing that my KDE desktop was completely reset to new (lost my mails, my prefs, everything), I simply moved back the /config previously "saved" to it's initial location.

I can logout fairwell now.

I really don't understand why, but it works.
Comment 14 Michal Augustyniak 2010-07-13 00:57:00 UTC
It does not work for me. any way it is not the same like removing entire .kde4 folder, not sure what you did here but like we said it does not work even for new created users.

Any help, clues from developers ???


> I beat you all, read this (true story) :
> 
> I simply moved the .kde4/share/config to another location.
> I powered off the computer
> On next day, seeing that my KDE desktop was completely reset to new (lost my
> mails, my prefs, everything), I simply moved back the /config previously
> "saved" to it's initial location.
> 
> I can logout fairwell now.
> 
> I really don't understand why, but it works.
> 

Comment 15 Michal Augustyniak 2010-07-13 01:46:02 UTC
I found it.

Go to your settings and turn off system notifications for logout I checked also "No audio output". No reboot necessary it should just work and It worked for me.
The problem is that system tried to play sound but it could not some reason and not completing logging out.
Comment 16 Rich Gannon 2010-07-13 02:12:33 UTC
This error shows up in .xsession_errors after I attempt to shut down or reboot.

ksmserver(7193)/kdecore (KLibrary) kde4Factory: The library "/usr/lib/kde4/solid_hal_power.so" does not offer a qt_plugin_instance function.

I don't know why Logout doesn't work either, but this may contribute to the issue.
Comment 17 Rich Gannon 2010-07-13 03:08:47 UTC
(In reply to comment #15)
> I found it.
> 
> Go to your settings and turn off system notifications for logout I checked also
> "No audio output". No reboot necessary it should just work and It worked for
> me.
> The problem is that system tried to play sound but it could not some reason and
> not completing logging out.
> 

Disabling the audio did work under the "System Settings > Notifications" menu!  Verified on 3 systems.
Comment 18 Michal Augustyniak 2010-07-13 20:01:02 UTC
sorry for posting the audio solution here but it is sort of the base problem.

So the reboot was not working because of broken sound palyback of LOGOUT. So disabling it got my reboot/shudown/logut working again.

Then I fixed my playback, I switched to gstreamer, xine has more problems for me. After that still could not play the ogg files, so I installed gst-plugins-ogg and gst-plugins-vorbis since kde4 ogg tracks are ogg vorbis format.

That's all, let me know if you will need help to get system notification working.
Comment 19 Sven Eden 2010-07-20 12:00:02 UTC
(In reply to comment #15)
> I found it.
> 
> Go to your settings and turn off system notifications for logout I checked also
> "No audio output". No reboot necessary it should just work and It worked for
> me.
> The problem is that system tried to play sound but it could not some reason and
> not completing logging out.
> 

YAY! This was bugging me for weeks, and I never even thought about the possibility that the sound playback had been re-enabled (The machine in question has no sound card/chip) during some KDE update.
Thanks a lot, after disabling all sound output it now works flawlessly again!
Comment 20 Andreas K. Hüttel gentoo-dev 2010-11-02 23:38:12 UTC
Does anyone know- is this problem still there in kde-4.5.x?
Comment 21 Andreas K. Hüttel gentoo-dev 2011-01-09 13:57:43 UTC
(In reply to comment #20)
> Does anyone know- is this problem still there in kde-4.5.x?
> 

According to upstream bug yes.
Comment 22 Andreas K. Hüttel gentoo-dev 2011-04-08 19:51:02 UTC
Anyone still seeing this with kde-4.6?
Comment 23 Andreas K. Hüttel gentoo-dev 2011-04-17 20:22:19 UTC
No regression compared to 4.4, so does not block stabilization
Comment 24 Tiger 2011-04-20 20:09:39 UTC
After upgrading KDE to the latest version, I've got the bug you described too.
I've found how to fix it after trying to configure phonon in system settings of KDE. While doing this it simply crashed.

So I did emerge phonon and it looked like this :

[ebuild   R   ] media-libs/phonon-4.5.0  USE="-debug -gstreamer -pulseaudio -vlc -xine" 0 kB

I remember after that I wouldn't install vlc player then I added -vlc for that ebuild in my /etc/portage/packages.use.
But phonon needs an engine to works. I got no warning for this.

After installing phonon with USE="xine" and then restart KDE current session (alt+F1, login, killall startkde), it fixed my KDE shutdown/logout trouble.

I noticed too that emerge phonon with USE="xine" didn't pull phonon-kde xine USE up.

I hope this help some people.
Comment 25 Tiger 2011-04-20 20:16:07 UTC
(In reply to comment #22)
> Anyone still seeing this with kde-4.6?

Yes.

I'm on ~amd64 and switched profile before KDE update from,
 default/linux/amd64/10.0
to,
 default/linux/amd64/10.0/desktop/kde

The upgrade was from KDE-4.4.x to the latest in portage.
Comment 26 Andreas K. Hüttel gentoo-dev 2011-04-26 11:38:43 UTC
Still present in 4.6.2, needs to be added to the upgrade guide
Comment 27 Thomas Capricelli 2011-04-26 12:41:11 UTC
hi. i've recently updated to kde 4.6.2, and though i did not have the problem until now, i'm now hit by this bug. Now that i've disabled the 'logout sound', everything is back to normal. 'dilfridge' on irc had suggested this to me and pointed me to this bug.

For your information.
Comment 28 Tiger 2011-04-27 10:49:44 UTC
Disable sound is just a work around and don't help to fix anything. Could you paste "emerge phonon" as example just to check it ?
Comment 29 Thomas Capricelli 2011-04-28 22:25:29 UTC
it says:

[ebuild   R   ] media-libs/phonon-4.5.0  USE="gstreamer vlc xine (-aqua) -debug -pulseaudio"
Comment 30 Tiger 2011-04-29 23:40:57 UTC
Did you check phonon settings via systemsettings application ?
It seems that many people actually have this problem related to their phonon settings and have fixed it by configuring it or reinstalling the backend (ie xine/gstreamer/vlc). If it don't fix it I suggest to you to try only one backend.
Comment 31 Johannes 2011-05-15 21:37:19 UTC
I had the same problem since I upgraded to the latest KDE and ati-drivers 11.4. Downgrading to 11.3 solved the problem.
Comment 32 Andreas K. Hüttel gentoo-dev 2011-07-17 08:51:46 UTC
This may be resolved now, as we now require ogg and vorbis support in all phonon backends. 

If you still have this problem after sync and update, please protest here and I'll reopen...