Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 323619

Summary: app-text/gocr needs tkispell-0.18 from CPAN
Product: Gentoo Linux Reporter: Michael Weber (RETIRED) <xmw>
Component: New packagesAssignee: TeX project <tex>
Status: CONFIRMED ---    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: http://cpansearch.perl.org/src/RKIES/tkispell-0.18/
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 323113    

Description Michael Weber (RETIRED) gentoo-dev 2010-06-11 23:21:24 UTC
app-text/gocr calls tkispell to spell-check it's current text buffer.

I would have contributed an ebuild, but unfortuaely I know nothing about perl CPAN modules or g-cpan, which refused `g-cpan -g tkispell`.
Comment 1 David Abbott gentoo-dev 2010-07-03 18:17:08 UTC
tkispell is from 2004 with no updates
http://search.cpan.org/~rkies/tkispell-0.18/
One of its deps is Tk-SimpleFileSelect also from 2004 with no updates
http://search.cpan.org/~rkies/Tk-SimpleFileSelect-0.68/
Comment 2 Andreas K. Hüttel gentoo-dev 2014-10-11 08:49:38 UTC
* added dev-perl/tkispell
* patched it to work with aspell's ispell-aspell compatibility script (we don't have ispell anymore)

No idea if it works, but you got your wish. Perl out.