Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 318819

Summary: kde-base/dolphin-4.4.3: always crash if I run it (dbus problem)
Product: Gentoo Linux Reporter: Andi Sugandi <andisugandi>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Severity: normal CC: esigra, misiek303
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 313999    

Description Andi Sugandi 2010-05-07 04:00:11 UTC
After emerge (upgrade, hard-masked) kde-4.4.3, dolphin always crash if I run it.

Reproducible: Always

Steps to Reproduce:
1. autounmask =kde-base/kde-meta-4.4.3
2. emerge kde-meta:4.4
3. run: dolphin

Actual Results:  
<unknown program name>(4829)/: Communication problem with  "dolphin" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.UnknownObject" : " "No such object path '/MainApplication'" " 

Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'std::bad_alloc'
  what():  std::bad_alloc

The KDE Crash Handler, drkonqi info:

Application: Dolphin (dolphin), signal: Aborted
[KCrash Handler]
#5  0x00007f4dcb493315 in raise () from /lib64/
#6  0x00007f4dcb494811 in abort () from /lib64/
#7  0x00007f4dcbd1b264 in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/
#8  0x00007f4dcbd196a6 in ?? () from /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/
#9  0x00007f4dcbd196d3 in std::terminate() () from /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/
#10 0x00007f4dcbd19755 in __cxa_rethrow () from /usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/
#11 0x00007f4dcd4dba89 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/
#12 0x00007f4dcd4dde26 in QCoreApplication::exec() () from /usr/lib64/qt4/
#13 0x000000000043764e in _start ()

$ emerge --info
Portage (default/linux/amd64/10.0/desktop/kde, gcc-4.3.4, glibc-2.10.1-r1, 2.6.33-gentoo-r2 x86_64)
System uname: Linux-2.6.33-gentoo-r2-x86_64-AMD_Athlon-tm-_Neo_Processor_MV-40-with-gentoo-1.12.13
Timestamp of tree: Thu, 06 May 2010 10:30:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63-r1
sys-devel/automake:  1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/gentoo-quebec /usr/local/portage/layman/benf"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm hal iconv ipv6 jpeg kde lcms ldap libnotify mad mikmod mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf perl png ppds pppd python qt3 qt3support qt4 readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Comment 1 Andreas K. Hüttel archtester gentoo-dev 2010-06-06 18:05:05 UTC
Is this still happening with kde 4.4.4?
Comment 2 Andi Sugandi 2010-06-11 01:56:50 UTC
(In reply to comment #1)
> Is this still happening with kde 4.4.4?

Great, the issue is fixed now.

Comment 3 Michal Augustyniak 2010-08-11 04:35:11 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > Is this still happening with kde 4.4.4?
> Great, the issue is fixed now.

still is crashing when I hover on png files