Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 318649

Summary: Stabilize sci-mathematics/octave-3.2.4-r1
Product: Gentoo Linux Reporter: Sébastien Fabbro (RETIRED) <bicatali>
Component: New packagesAssignee: Gentoo Science Mathematics related packages <sci-mathematics>
Status: RESOLVED FIXED    
Severity: normal CC: esigra, jlec
Priority: High Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 245715, 261568, 318647    
Bug Blocks: 245160, 263872, 302468    

Description Sébastien Fabbro (RETIRED) gentoo-dev 2010-05-05 17:10:29 UTC
Please do. Let's finally get rid of octave < 3.2.
Tests will probably fail (bug #304963), and we have not looked yet which ones are actually valid tests, it might take a while (help welcome). But octave-3.2.4-r1 is more stable than any previous ones, so please proceed.
Thanks.
Comment 1 Sébastien Fabbro (RETIRED) gentoo-dev 2010-05-05 17:16:40 UTC
Actually removing the hdf5 bug dependency since octave-3.2.4-r1 does not depend on  hdf5 anymore.
Comment 2 Jeroen Roovers gentoo-dev 2010-05-13 06:30:40 UTC
Stable for HPPA.
Comment 3 Markus Meier gentoo-dev 2010-05-16 19:04:01 UTC
amd64/x86 stable
Comment 4 Michel Lang 2010-05-17 16:09:52 UTC
octave-3.2.4-r1 solely depends on graphicsmagick, isn't that conflicting with bug #314431 ?

On my system this results in several blocks with packages depending on imagemagick:

  ('ebuild', '/', 'media-gfx/graphicsmagick-1.3.12', 'merge') pulled in by
    media-gfx/graphicsmagick[cxx] required by ('ebuild', '/', 'sci-mathematics/octave-3.2.4-r1', 'merge')

  ('installed', '/', 'media-gfx/imagemagick-6.5.8.8', 'nomerge') pulled in by
    media-gfx/imagemagick required by ('installed', '/', 'media-plugins/kipi-plugins-0.8.0', 'nomerge')
    media-gfx/imagemagick required by ('installed', '/', 'kde-base/kopete-4.4.3', 'nomerge')
    media-gfx/imagemagick[png] required by ('installed', '/', 'app-editors/kile-2.1_beta4', 'nomerge')
    (and 4 more)
Comment 5 Sébastien Fabbro (RETIRED) gentoo-dev 2010-05-17 17:19:57 UTC
(In reply to comment #4)
> octave-3.2.4-r1 solely depends on graphicsmagick, isn't that conflicting with
> bug #314431 ?

No. octave can not be built with imagemagick. This actually was the reason why I pushed graphicsmagick back in the tree.

> On my system this results in several blocks with packages depending on
> imagemagick:

If you want to avoid blocks, you can add USE=-imagemagick when you build graphicsmagick.

Also I am not sure these questions deal with the stability of octave.


Comment 6 nixnut (RETIRED) gentoo-dev 2010-05-24 12:44:46 UTC
ppc stable
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2010-06-13 15:08:44 UTC
alpha/sparc stable
Comment 8 Justin Lecher gentoo-dev 2010-06-22 13:49:17 UTC
@ppc64
Please proceed as this would fix many open bugs.
Comment 9 Samuli Suominen gentoo-dev 2010-07-09 10:20:00 UTC
ppc64 stable