Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 314935

Summary: x11-drivers/xf86-video-intel-2.11.0 - X freezes
Product: Gentoo Linux Reporter: Vladimír Čunát <vcunat>
Component: [OLD] Core systemAssignee: Gentoo X packagers <x11>
Status: RESOLVED UPSTREAM    
Severity: normal CC: joel, tsdh
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
URL: http://bugs.freedesktop.org/show_bug.cgi?id=27497
Whiteboard:
Package list:
Runtime testing required: ---

Description Vladimír Čunát 2010-04-13 07:58:55 UTC
During regular work (in kile) X froze with only mouse moving, but I still could switch to textmode VTs. I'm posting the output of dmesg (I rather took a longer part).
I think this error might be kernel-related, because X wouldn't work even after restarting the xdm service.
I've got gentoo-sources-2.6.33, xorg-server-1.7.6 and xf86-video-intel-2.11.0.

...
ata1.00: configured for UDMA/100
ata1: EH complete
Hangcheck: hangcheck value past margin!
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-1: master_xfer[0] W, addr=0x50, len=1
i2c i2c-1: master_xfer[1] R, addr=0x50, len=128
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-1: master_xfer[0] W, addr=0x50, len=1
i2c i2c-1: master_xfer[1] R, addr=0x50, len=128
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-1: master_xfer[0] W, addr=0x50, len=1
i2c i2c-1: master_xfer[1] R, addr=0x50, len=128
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-1: master_xfer[0] W, addr=0x50, len=1
i2c i2c-1: master_xfer[1] R, addr=0x50, len=128
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-0: master_xfer[0] W, addr=0x50, len=1
i2c i2c-0: master_xfer[1] R, addr=0x50, len=1
i2c i2c-0: NAK from device addr 0x50 msg #0
i2c i2c-1: master_xfer[0] W, addr=0x50, len=1
i2c i2c-1: master_xfer[1] R, addr=0x50, len=128
sr0: CDROM (ioctl) error, command: cdb[0]=0x4a 4a 01 00 00 10 00 00 00 08 00
sr: Sense Key : 0x0 [current]
sr: ASC=0x0 ASCQ=0x0
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000
[drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 1318811 at 1318810)
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/i915/i915_gem_tiling.c:490 i915_gem_set_tiling+0x253/0x260()
Hardware name: 1550
failed to reset object for tiling switch
Modules linked in: bridge stp llc lib80211_crypt_wep snd_pcm_oss snd_mixer_oss btrfs zlib_deflate fuse ipw2200 ohci1394 sg libipw sr_mod 8139too cdrom cfg80211 rfkill ieee1394 lib80211 unix
Pid: 5333, comm: X Not tainted 2.6.33-gentoo-gf7f44f9 #2
Call Trace:
[<c12072e3>] ? i915_gem_set_tiling+0x253/0x260
[<c12072e3>] ? i915_gem_set_tiling+0x253/0x260
[<c102613f>] ? warn_slowpath_common+0x6f/0xd0
[<c12072e3>] ? i915_gem_set_tiling+0x253/0x260
[<c10261eb>] ? warn_slowpath_fmt+0x2b/0x30
[<c12072e3>] ? i915_gem_set_tiling+0x253/0x260
[<c11ea055>] ? drm_ioctl+0x165/0x330
[<c1207090>] ? i915_gem_set_tiling+0x0/0x260
[<c1080cfd>] ? do_sync_read+0xad/0xf0
[<c11e9ef0>] ? drm_ioctl+0x0/0x330
[<c108ccbf>] ? vfs_ioctl+0x1f/0x80
[<c108d393>] ? do_vfs_ioctl+0x73/0x5c0
[<c10404f3>] ? ktime_get_ts+0xe3/0x100
[<c10404f3>] ? ktime_get_ts+0xe3/0x100
[<c108d91d>] ? sys_ioctl+0x3d/0x70
[<c1002c90>] ? sysenter_do_call+0x12/0x26
---[ end trace 17bdaf2ab07d3636 ]---

Reproducible: Couldn't Reproduce
Comment 1 Tassilo Horn 2010-04-13 18:10:28 UTC
This seems to related to bug 310829, or maybe even a duplicate.

Anyway, is really a very serious issue.  The last few days I've had at least 5 such freezes, including freezes with data loss.  I contrast to you, I never was able to switch to a VT, neither could I use Magic SysRQ keys to bring the system down somewhat cleanly.

The difference between your and my system seems to be, that I use xorg-server-1.8.0.  This suggests that the bug is introduces by the xf86-video-intel-2.11.0, or maybe by libdrm.  What's your version?  Mine is libdrm-2.4.20.

For now, I'll downgrade the xf86-video-intel driver.  I'll report back if that solves the issue for me.
Comment 2 Rémi Cardona gentoo-dev 2010-04-13 20:14:33 UTC
There isn't much I can do about such bugs, they're beyond my knowledge of the driver.

Please file a bug upstream [1] and paste the URL here so I can track the issue.

Thanks

[1] http://intellinuxgraphics.org/how_to_report_bug.html
Comment 3 Tassilo Horn 2010-04-14 05:53:44 UTC
Upstream bug: http://bugs.freedesktop.org/show_bug.cgi?id=27497
Comment 4 Rémi Cardona gentoo-dev 2010-04-14 06:15:51 UTC
Reopening
Comment 5 Rémi Cardona gentoo-dev 2010-04-14 06:27:18 UTC
Alright, let's track the bug upstream directly.

Thanks
Comment 6 Rémi Cardona gentoo-dev 2010-04-14 06:33:04 UTC
*** Bug 310829 has been marked as a duplicate of this bug. ***