Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 314149

Summary: mail-client/mozilla-thunderbird-3.0.3 asks multiple times for the same password
Product: Gentoo Linux Reporter: Marcin Deranek <marcin.deranek>
Component: Current packagesAssignee: Mozilla Gentoo Team <mozilla>
Severity: minor    
Priority: High    
Version: unspecified   
Hardware: AMD64   
OS: Linux   
Package list:
Runtime testing required: ---

Description Marcin Deranek 2010-04-09 13:47:10 UTC
While switched to thunderbird 3 I noticed that sometimes (so far I was not able to figure out when) thunderbird asks 2 times for the same IMAP password. This is a minor annoyance.

Reproducible: Always

Steps to Reproduce:
1. Create a subfolder in a folder on IMAP server eg. INBOX/subfolder
2. Make INBOX/subfolder the active folder (should be highlighted)
3. Close Thunderbird
4. Start Thunderbird
5. Thunderbird will ask 2 times for the password of the account where INBOX/subfolder resides.

Please make sure Thunderbird does not store your password otherwise you might not see it.
Actual Results:  
Thunderbird should ask for the password of the certain account only once.

Expected Results:  
I had to type password 2 times.

gringo@dell ~ $ emerge --info
Portage (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.33-tuxonice x86_64)
System uname: Linux-2.6.33-tuxonice-x86_64-Intel-R-_Core-TM-2_Duo_CPU_U9400_@_1.40GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 09 Apr 2010 01:45:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4-r1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r3, 1.10.3
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.33
CFLAGS="-march=native -mtune=native -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,now"
LINGUAS="en pl"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow X a52 aac aalib accessibility acpi adns alsa amd64 ao apm audiofile avahi bash-completion bcmath berkdb bidi bluetooth bzip2 cairo caps cdda cddb cdparanoia cdr clamav cli consolekit cracklib crypt cscope css ctype cups curl curlwrappers dbus dga dri dts dv dvb dvd dvdr encode enscript evo exif expat fbcon ffmpeg fftw firefox flac flatfile fontconfig foomaticdb ftp gd gdbm ggi gif gimp ginac glut gmp gnome gnome-keyring gnutls gphoto2 gpm graphviz gsm gstreamer gtk gtkhtml guile gzip hal hdf5 iconv icu idn ieee1394 imagemagick imap imlib ipv6 javascript jbig jingle jpeg jpeg2k lame lcms ldap libcaca libgda libnotify libsamplerate libwww lzo m17n-lib mad maildir matroska mbox memlimit mhash mikmod mime mmap mmx mng modplug modules mozilla mp3 mp4 mpeg mplayer mtp mudflap multilib musepack musicbrainz ncurses networkmanager nptl nptlonly nsplugin offensive ogg openal opengl openmp osc oss pam pango pch pcmcia pcntl pcre pdf perl plotutils png policykit portaudio posix ppds pppd profile qt3support quicktime raw rdesktop readline recode reflection samba sdl session sharedmem shorten simplexml slang slp smp sndfile snmp sockets sox speex spell sse sse2 ssl startup-notification suid svg sysfs syslog sysvipc szip taglib tcl tcpd theora threads tidy tiff tk truetype unicode usb v4l v4l2 vcd videos vim-syntax vorbis wavpack wifi wmf wxwidgets wxwindows x264 xcb xcomposite xface xft xine xinerama xml xmlrpc xmp xorg xosd xpm xsl xulrunner xv xvid yaz zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en pl" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" 
Comment 1 Stefan Behte (RETIRED) gentoo-dev Security 2010-04-09 17:53:55 UTC
Does this also happen with 3.0.4?
Comment 2 Marcin Deranek 2010-04-09 19:52:18 UTC
Just tried it on other ~amd64 system and behaviour is identical (3.0.4). One more important thing I just discovered: account where subfolder resides has to be marked as "Check for new messages at startup". This way mailbox get one auth "hit" by "Check for new messages at startup" and 2nd by active subfolder (for folder in top directory it doesn't).
Comment 3 Jory A. Pratt gentoo-dev 2010-07-18 15:19:45 UTC
Please see if you can duplicate this with a new profile. I have tried on several machines and been unable to. If you can please feel free to reopen.

You just have to mv .thunderbird .thunderbird-bak to test. If you can not duplicate it with the fresh profile email me directly and I will give you all info to re-import your mail from the older profile.
Comment 4 Marcin Deranek 2010-07-29 08:37:02 UTC
Looks like thunderbird 3.1.x solves the problem (upgrade is sufficient). I tried to start from scratch with thunderbird 3.0.5, but problem was still there.