Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 312467

Summary: sys-apps/portage-2.2_rc67: --keep-going does not keep it going
Product: Portage Development Reporter: Sebastian Pipping <sping>
Component: Core - Interface (emerge)Assignee: Portage team <dev-portage>
Status: RESOLVED DUPLICATE    
Severity: normal CC: devurandom, orzel
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Sebastian Pipping gentoo-dev 2010-03-31 19:00:58 UTC
my portage exists after a failure in "7 of 31" despite --keep-going.
the ramaining packages include things like app-text/dos2unix does not seems affected by a failure of mysql compilcation to me.

i'm on x86, testing.  any other info you need?
Comment 1 Thomas Capricelli 2010-06-09 21:44:37 UTC
i confirm this bug using sys-apps/portage-2.2_rc67. I have use the option --keep-going since it exists, and only in the last weeks/months did it stop working.
This is a typical output, you'll not that it does say "*** Resuming merge...", though it does not actually keep on going.


sudo emerge -qvta --keep-going -j 4 --load-average=7 -uD @world

[nomerge      ] dev-db/pgadmin3-1.10.2  USE="-debug" 
[nomerge      ]  virtual/postgresql-base-8.3 
[ebuild     U ]   dev-db/postgresql-base-8.3.11-r1 [8.3.11] USE="nls pam readline ssl threads zlib -doc -kerberos -ldap -pg-intdatetime" LINGUAS="fr it -af -cs -de -es -fa -hr -hu -ko -nb -pl -pt_BR -ro -ru -sk -sl -sv -tr -zh_CN -zh_TW" 
[nomerge      ] kde-misc/kaya-0.2  USE="(-aqua) (-kdeenablefinal) -test" RUBY_TARGETS="ruby18" 
[ebuild     U ]  kde-base/kdebindings-ruby-4.4.4 [4.4.3] USE="okular phonon plasma qwt semantic-desktop webkit -akonadi (-aqua) -debug (-kdeenablefinal) -kdeprefix -qscintilla (-kdevplatform%*)" RUBY_TARGETS="ruby18"                                                                                                                                
[nomerge      ] app-cdr/k3b-9999-r1  USE="dvd encode ffmpeg flac lame mad sndfile sox vcd vorbis wav (-aqua) -debug -emovix (-kdeenablefinal) -musicbrainz -taglib" 
[ebuild  N    ]  kde-base/libkcddb-4.4.4  USE="(-aqua) -debug (-kdeenablefinal) -kdeprefix -musicbrainz" 
[nomerge      ] dev-util/kdevelop-4.0.0  USE="cmake cxx qmake (-aqua) -debug (-kdeenablefinal) -qthelp" LINGUAS="fr it -ca -ca@valencia -da -de -en_GB -es -et -gl -nds -pt -pt_BR -sv -tr -uk -zh_CN -zh_TW"                                                                                                                                           
[ebuild     U ]  dev-util/kdevplatform-1.0.0-r1 [1.0.0] USE="subversion (-aqua) -cvs -debug (-kdeenablefinal)" LINGUAS="fr it -ca -ca@valencia -da -de -en_GB -es -et -gl -nds -pt -pt_BR -sv -tr -uk -zh_CN -zh_TW"                                                                                                                                    
[nomerge      ] kde-base/kdeplasma-addons-4.4.4  USE="exif qwt rss semantic-desktop (-aqua) -debug -desktopglobe (-kdeenablefinal) -kdeprefix -qalculate -scim" 
[nomerge      ]  kde-base/kdepimlibs-4.4.4  USE="handbook semantic-desktop (-aqua) -debug (-kdeenablefinal) -kdeprefix -ldap -test" 
[ebuild     U ]   app-office/akonadi-server-1.3.85 [1.3.80] USE="mysql server sqlite -postgres" 
[blocks b     ] kde-base/kdebase-runtime-meta:4.4[-kdeprefix] ("kde-base/kdebase-runtime-meta:4.4[-kdeprefix]" is blocking kde-base/kdebase-runtime-meta-4.4.81)
[uninstall    ]  kde-base/kdebase-runtime-meta-4.4.81  USE="handbook semantic-desktop (-aqua) -kdeprefix" 
[ebuild  NS   ] kde-base/kdebase-runtime-meta-4.4.4 [4.4.81] USE="handbook semantic-desktop (-aqua) -kdeprefix" 
[blocks b     ] kde-base/smoke:4.4[-kdeprefix] ("kde-base/smoke:4.4[-kdeprefix]" is blocking kde-base/smoke-4.4.81)
[uninstall    ]  kde-base/smoke-4.4.81  USE="okular phonon qwt semantic-desktop webkit -akonadi (-aqua) -attica (-kdeenablefinal) -kdeprefix -multimedia -qimageblitz -qscintilla"                                                                                                                                                                      
[ebuild     U ] kde-base/smoke-4.4.4 [4.4.3-r1] USE="okular phonon qwt semantic-desktop webkit -akonadi (-aqua) (-kdeenablefinal) -kdeprefix -multimedia -qimageblitz -qscintilla (-kdevplatform%*)"                                                                                                                                                    
[blocks b     ] kde-base/kapptemplate:4.4[-kdeprefix] ("kde-base/kapptemplate:4.4[-kdeprefix]" is blocking kde-base/kapptemplate-4.4.81)
[uninstall    ]  kde-base/kapptemplate-4.4.81  USE="handbook (-aqua) -debug (-kdeenablefinal) -kdeprefix" 
[ebuild  NS   ] kde-base/kapptemplate-4.4.4 [4.4.81] USE="handbook (-aqua) -debug (-kdeenablefinal) -kdeprefix" 
[nomerge      ] media-video/camorama-0.19-r2  USE="-debug" 
[nomerge      ]  gnome-base/libgnomeui-2.24.3  USE="-doc" 
[nomerge      ]   gnome-base/libbonoboui-2.24.3  USE="-doc -test" 
[nomerge      ]    gnome-base/libgnome-2.28.0  USE="branding -debug -doc -esd" 
[nomerge      ]     gnome-base/gvfs-1.4.3-r1  USE="avahi bluetooth cdda gnome gphoto2 hal http udev -archive -bash-completion -doc -fuse -gdu -gnome-keyring -samba" 
[nomerge      ]      net-libs/libsoup-gnome-2.28.2  USE="-debug -doc" 
[ebuild     U ]       net-libs/libproxy-0.4.2 [0.2.3-r3] USE="kde networkmanager perl%* python webkit xulrunner -debug% -gnome -vala%" 
[nomerge      ] x11-libs/qt-assistant-4.6.2-r2  USE="exceptions pch (-aqua) -debug -trace" 
[blocks b     ]  >x11-libs/qt-demo-4.6.2-r9999 (">x11-libs/qt-demo-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-assistant-4.6.2-r2, x11-libs/qt-qt3support-4.6.2)                                                                                                                                                                        
[nomerge      ]   x11-libs/qt-assistant-4.6.3 [4.6.2-r2] USE="exceptions pch (-aqua) -debug -trace" 
[blocks b     ]    <x11-libs/qt-demo-4.6.3 ("<x11-libs/qt-demo-4.6.3" is blocking x11-libs/qt-sql-4.6.3, x11-libs/qt-qt3support-4.6.3, x11-libs/qt-assistant-4.6.3)
[ebuild     U ]     x11-libs/qt-demo-4.6.3 [4.6.2] USE="exceptions kde pch (-aqua) -debug" 
[blocks b     ]  >x11-libs/qt-demo-4.6.2-r9999 (">x11-libs/qt-demo-4.6.2-r9999" is blocking x11-libs/qt-sql-4.6.2, x11-libs/qt-assistant-4.6.2-r2, x11-libs/qt-qt3support-4.6.2)                                                                                                                                                                        
[ebuild     U ]   x11-libs/qt-assistant-4.6.3 [4.6.2-r2] USE="exceptions pch (-aqua) -debug -trace" 
[blocks b     ]    <x11-libs/qt-qt3support-4.6.3 ("<x11-libs/qt-qt3support-4.6.3" is blocking x11-libs/qt-sql-4.6.3, x11-libs/qt-demo-4.6.3, x11-libs/qt-assistant-4.6.3)
[ebuild     U ]     x11-libs/qt-qt3support-4.6.3 [4.6.2] USE="accessibility exceptions kde pch phonon (-aqua) -debug" 
[ebuild     U ]      x11-libs/qt-sql-4.6.3 [4.6.2] USE="exceptions iconv mysql odbc pch qt3support sqlite (-aqua) -debug (-firebird) -postgres" 
[nomerge      ] dev-db/mysql-workbench-5.2.22  USE="nls readline -debug -static-libs" 
[nomerge      ]  virtual/mysql-5.1 
[ebuild     U ]   dev-db/mysql-5.1.46 [5.1.45-r1] USE="community embedded perl ssl -big-tables -cluster -debug -extraengine -latin1 -max-idx-128 -minimal -pbxt -profiling (-selinux) -static -test -xtradb%"                                                                                                                                           

Would you like to merge these packages? [Yes/No] >>> Verifying ebuild manifests
>>> Starting parallel fetch
>>> Emerging (1 of 14) dev-db/mysql-5.1.46
>>> Jobs: 0 of 14 complete, 1 running               Load avg: 0.75, 1.81, 3.20
>>> Failed to emerge dev-db/mysql-5.1.46, Log file:
>>>  '/var/tmp/portage/dev-db/mysql-5.1.46/temp/build.log'
>>> Jobs: 0 of 14 complete, 1 failed                Load avg: 0.35, 1.43, 2.94
*** Resuming merge...
 * CPV:  dev-db/mysql-5.1.46
 * REPO: gentoo

...
(whole mysql failure. Mysql fails because of gcc 4.5, it's known and not the pb here)
...

* ERROR: dev-db/mysql-5.1.46 failed:
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 4488:  Called mysql_src_compile
 *   environment, line 3938:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 * 
 * If you need support, post the output of 'emerge --info =dev-db/mysql-5.1.46',
 * the complete build log and the output of 'emerge -pqv =dev-db/mysql-5.1.46'.
 * The complete build log is located at '/var/tmp/portage/dev-db/mysql-5.1.46/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/mysql-5.1.46/temp/environment'.
 * S: '/var/tmp/portage/dev-db/mysql-5.1.46/work/mysql'

 * Messages for package dev-db/mysql-5.1.46:

 * MySQL MY_DATADIR is /var/lib/mysql
 * MySQL datadir found in /var/lib/mysql
 * A new one will not be created.

 * Messages for package dev-db/mysql-5.1.46:

 * MySQL MY_DATADIR is /var/lib/mysql
 * MySQL datadir found in /var/lib/mysql
 * A new one will not be created.
 * ERROR: dev-db/mysql-5.1.46 failed:
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   48:  Called src_compile
 *   environment, line 4488:  Called mysql_src_compile
 *   environment, line 3938:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed";
 * 
 * If you need support, post the output of 'emerge --info =dev-db/mysql-5.1.46',
 * the complete build log and the output of 'emerge -pqv =dev-db/mysql-5.1.46'.
 * The complete build log is located at '/var/tmp/portage/dev-db/mysql-5.1.46/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-db/mysql-5.1.46/temp/environment'.
 * S: '/var/tmp/portage/dev-db/mysql-5.1.46/work/mysql'
 * One or more packages are either masked or have missing dependencies:
 * 
 *   >=kde-base/kdelibs-4.4.81[-kdeprefix,semantic-desktop,-aqua] pulled in by:
 *     ('installed', '/', 'kde-base/smoke-4.4.81', 'nomerge')
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 * 
 * The following package has failed to build or install:
 * 
 *  ('ebuild', '/', 'dev-db/mysql-5.1.46', 'merge'), Log file:
 *   '/var/tmp/portage/dev-db/mysql-5.1.46/temp/build.log'
 * 
orzel@berlioz /home/orzel% 
Comment 2 Thomas Capricelli 2010-06-09 22:02:31 UTC
i've just switched back to 2.2_rc62 (the only other 2.2 presently in portage), and there, --keep-going works as expected. So the bug is only in rc67.


Would you like to merge these packages? [Yes/No] 
>>> Verifying ebuild manifests
>>> Starting parallel fetch
>>> Emerging (1 of 17) sys-devel/libtool-2.2.10
>>> Installing (1 of 17) sys-devel/libtool-2.2.10
>>> Emerging (2 of 17) dev-db/mysql-5.1.46
>>> Failed to emerge dev-db/mysql-5.1.46, Log file:
>>>  '/var/tmp/portage/dev-db/mysql-5.1.46/temp/build.log'
>>> Jobs: 1 of 17 complete, 1 failed                Load avg: 0.31, 0.35, 1.02
*** Resuming merge...
>>> Starting parallel fetch
>>> Emerging (1 of 15) media-sound/lilypond-2.12.3
>>> Emerging (2 of 15) x11-libs/qt-sql-4.6.3
...
Comment 3 Dennis Schridde 2011-06-19 09:24:31 UTC
Possible duplicates: bug #263630, bug #312467, bug #312789, bug #340287, bug #342713, bug #362355
Comment 4 Dennis Schridde 2011-07-02 10:15:21 UTC
Please have a look at the possible duplicates bug #263630, bug #312467, bug #312789, bug #340287, bug #342713, bug #362355, and then raise the priority of the appropriate bugs. This issue is really annoying me by now, because it prevents a proper update of @world since months.
Comment 5 Zac Medico gentoo-dev 2011-08-13 00:36:42 UTC
(In reply to comment #1)
>  * One or more packages are either masked or have missing dependencies:
>  * 
>  *   >=kde-base/kdelibs-4.4.81[-kdeprefix,semantic-desktop,-aqua] pulled in by:
>  *     ('installed', '/', 'kde-base/smoke-4.4.81', 'nomerge')

This is the same symptom as bug 378187, hopefully fixed now.

*** This bug has been marked as a duplicate of bug 378187 ***