Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 31108

Summary: Gnome 2.4 makes all xterms be dirty grey
Product: Gentoo Linux Reporter: Shevek <gentoo>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Severity: normal CC: mr_bones_
Priority: High    
Version: 1.4   
Hardware: All   
OS: Linux   
Package list:
Runtime testing required: ---

Description Shevek 2003-10-14 03:51:16 UTC
I run xterm or xterm -rv under gnome. In both cases, the text comes out dirty grey on black.

I am running the latest (as of this date) gnome 2.4.

Before the upgrade, last week, when I was running 2.2, it worked perfectly, as expected, i.e. I get either black on white, or white on black if I use the -rv switch.

Under all other window managers (enlightenment, olvwm, etc), it works perfectly, as expected.

I can't see any changes in app-defaults or anything pertinent in xrdb. So what has gnome-2.4 done to my xterms, and can it be fixed please?
Comment 1 Shevek 2003-10-14 03:51:57 UTC
(oops) I meant it is now black on dirty grey, not dirty grey on black.
Comment 2 Shevek 2003-10-15 04:10:59 UTC
This is an xrdb problem. Something in gnome is setting all foreground and
background attributes to 000000 and dcdad5. This is not happening in the
other windowmanagers. I have grepped all likely looking files in ~/.??*,
/usr/share/gnome* and /etc/X11/* but I can't find where these entries are
coming from. After removing them from xrdb by hand, this seems to work better.

*Box.background:        #dcdad5
*Box.foreground:        #000000
*Button.activeBackground:       #dcdad5
*Button.activeForeground:       #000000
*Button.background:     #dcdad5
*Button.foreground:     #000000


including *background and *foreground, which were catching xterm.

Can someone please suggest where these entries are coming from, and fix it
by default?
Comment 3 foser (RETIRED) gentoo-dev 2003-10-26 12:10:38 UTC
your 'emerge info' & your xfree version please 

i don't see this behaviour
Comment 4 Shevek 2003-11-04 06:34:20 UTC
Portage 2.0.49-r3 (default-x86-1.4, gcc-3.2.3, glibc-2.3.1-r4, 2.4.21)
System uname: 2.4.21 i686 AMD Duron(tm) Processor 
CFLAGS="-mcpu=athlon -O3 -pipe"
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-mcpu=athlon -O3 -pipe"
FEATURES="sandbox ccache autoaddcvs"
USE="x86 oss apm avi crypt cups encode foomaticdb gif jpeg kde libg++ mad
mikmod mpeg ncurses nls pdflib png quicktime spell truetype xml2 xmms xv
zlib gtkhtml alsa gdbm berkdb slang readline arts tetex aalib nas bonobo
svga tcltk java guile mysql X sdl gpm tcpd pam libwww ssl perl python esd
imlib oggvorbis gnome gtk qt motif opengl mozilla ldap cdr scanner 3dfx curl
dga dvd ethereal evo fbcon gb gd gtk2 imap ipv6 jikes kerberos ladcca lcms
libgda matroska matrox mbox odbc plotutils samba sasl slp snmp sse tiff usb
wmf Xaw3d xinerama xml"


The funny thing is that xrdb contained a large number of background and foreground
settings, some for emacs, some for various X widgets, and some generic global
*background and *foreground entries.
Comment 5 foser (RETIRED) gentoo-dev 2004-02-29 08:15:01 UTC
I can't reproduce this, reopen if its still a problem.
Comment 6 Shevek 2004-03-01 00:50:15 UTC
Yes, of course this is still a problem. Nothing has been done to fix it. I tend to put xterm*foregound and xterm*background entries in some sensible default resources file. However, by default this problem is still outstanding.

Comment 7 Mr. Bones. (RETIRED) gentoo-dev 2004-03-01 01:24:11 UTC
I can still see behavior that I think is the same although, for me, it's blue
text on light grey background.

Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.4.24)
System uname: 2.4.24 i686 AMD Athlon(tm) processor
Gentoo Base System version
distcc 2.12.1 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
CFLAGS="-mcpu=i686 -O3 -pipe -Wall"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/X11/app-defaults /etc/X11/rstart /etc/X11/serverconfig /etc/X11/starthere /etc/X11/xdm /etc/bash_completion /etc/gconf /etc/pango /etc/sound/events /etc/ssmtp /usr/X11R6/lib/X11/xkb /etc/env.d"
CXXFLAGS="-mcpu=i686 -O3 -pipe -Wall -Wno-deprecated"
FEATURES="autoaddcvs ccache cvs sandbox"
USE="3dnow X apm arts avi berkdb cdr crypt cscope cups dvd encode esd foomaticdb gdbm gif gnome gpm gtk gtk2 guile java jpeg libg++ libwww mad mikmod mmx mozilla moznocompose moznoirc moznomail mpeg nas ncurses noreiserfs oggvorbis opengl oss pam pdflib perl png ppds python quicktime readline sdl slang spell sse ssl tcpd tiff truetype x86 xml2 xmms xv zlib"

Comment 8 Shevek 2004-03-01 01:50:07 UTC
It depends on your theme. I happen to have a black/dirty-grey theme. You must have a blue theme.
Comment 9 foser (RETIRED) gentoo-dev 2004-03-01 08:55:11 UTC
@ comment #6 : sometimes problems 'resolve' themselves because either some updated package got a fix we are not aware of or the user made a mistake which got fixed by now and it just works again. I hardly know what you mean with 'dirty grey' and can't seem to reproduce it myself, so no I can't do much about it. It is not something you can shove onto our plate and just let go of it, i do expect you to be looking into this as well.

Now mr.bones here is a dev who can reproduce it, so maybe he could look into it. I have simply no clue.
Comment 10 Mike Gardiner (RETIRED) gentoo-dev 2004-12-10 02:22:03 UTC
Is this still a problem with the latest gnome-terminal? I can't reproduce either.
Comment 11 Mr. Bones. (RETIRED) gentoo-dev 2004-12-10 02:43:16 UTC
I think it's still like that.  I guess the default color is black on grey.
Comment 12 Leonardo Boshell (RETIRED) gentoo-dev 2005-03-17 04:49:04 UTC
Hi guys. The described behaviour is still present in Gnome, and probably will not change.

The control-center package, through its gnome-settings-daemon, defines xrdb values using information from /usr/share/control-center-2.0/xrdb/ and Gnome's own settings. The main purpose of that seems to be setting reasonable defaults for legacy applications, so they match the general look-and-feel of the desktop.

Of course, it could be argued whether this should be the default or not, but it is the way Gnome works.

The fact that Shevek didn't see this 'problem' before Gnome 2.4 was probably a bug in previous Gnome versions.

Searching through Gnome's bugzilla and mailing lists, it seems like this is not considered a bug (apparently there are no related reports and no one have raised the issue) and that most people just uses ~/.Xdefaults or ~/.Xresources to customize things like xterm's colors.

I think this should be closed as INVALID or WONTFIX.
Comment 13 Mr. Bones. (RETIRED) gentoo-dev 2005-03-17 07:45:09 UTC
I agree.  I believe x11-misc/xtermcontrol makes it easy enough to change how the xterms look as well.
Comment 14 Seemant Kulleen (RETIRED) gentoo-dev 2005-04-14 11:22:20 UTC
closing this, as I'm cleaning up *xterm related bugs at the moment, and this one is apparently not-a-bug.