Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 310903

Summary: media-sound/amarok (all versions!): Logging out in KDE does not keep Amarok in the session but closes it.
Product: Gentoo Linux Reporter: Navid Zamani <navid.zamani>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: VERIFIED WORKSFORME    
Severity: minor    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Navid Zamani 2010-03-23 12:12:39 UTC
KDE has a feature where when you log out, it keeps you apps, and restores them when you log in again.
This works as advertised for Kopete and other KDE programs.
But when Amarok runs while you log out, it closes itself (while the Kopete windows stays there). It is not stored in the session, and not restored when logging in again.

Reproducible: Always

Steps to Reproduce:
see above
Actual Results:  
see above

Expected Results:  
Amarok should be stored in the session and restored on next login.
(Could be related to bug 310897, if there is a general problem with storing parts of its configuration.)
Comment 1 Navid Zamani 2010-04-15 12:17:02 UTC
Update: Not related to bug 310897.

This bug exists since KDE 3.5 times and still is there.
I wonder why nobody cares for that long? I’m not the only one getting that, am I?
Additional info: I have the Amarok main window open, and not minimized to the system tray, when I shut down.
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-04-15 16:34:10 UTC
I can't reproduce it here. If I leave amarok open when I close the session, it opens up on next login.
Comment 3 Navid Zamani 2010-04-15 18:51:11 UTC
Weird. I just did a couple of tests.
I created a new user just for this, logged in, ran amarok, logged out, logged in again, and it got restored too.
Then I closed amarok, copied in “.kde4/share/{apps,config}/amarok*”, fixed the rights, re-started amarok, , logged out, logged in again, and it still got restored.
I also checked if it’s window-manager dependent with the same procedure. No change with either compiz or kwin.

Meanwhile on my normal user account, I still can reproduce the problem every single time.

I checked, and apparently, the amarok session gets nicely stored in “.kde4/share/config/session/amarok_*”.

Is there something besides “.kde4/share/{apps,config}/amarok*”, that plays into the whole thing, cause I’m at a loss here. :(
I think I may just copy stuff over to the other account, until it stops working...
The weird thing is, that I get no log error, indicating that there is no restoration.
I noticed that KDE(4) as a whole is really lacking in terms of logging. Which smells more like Windows app behavior, than Linux, where it usually is seen as a virtue. Sad story... :/
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-04-15 18:57:43 UTC
Please open an upstream bug about this and put the link in the URL field of this bug. I have no idea how to troubleshoot this issue.
Comment 5 Navid Zamani 2010-05-17 13:25:22 UTC
Hey, I stopped using Amarok 2, because they removed essential basic functions and don’t plan to ever add them again. So it became useless to me, and I don’t know how a sane person can bear with that p.o.s. anymore. So this bug is resolved for me to. I’m now using my own software-independent metastorage, together with MPD by the way. Luckily, I could write a script that exports all the labels and album covers from the sqlite database. And I’m not falling into the lock-in trap again. Ever. :)

(I consider this bug closed. If anyone is interested in this export script, I would be willing to help, though. But I won’t help anyone with Windows^H^H^H^H^H^H^HKDE4 problems anymore.)