Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 308341

Summary: app-crypt/ssh-multiadd: Verify and potentially improve Python-related code
Product: Gentoo Linux Reporter: Arfrever Frehtes Taifersar Arahesis (RETIRED) <arfrever>
Component: Current packagesAssignee: Python Gentoo Team <python>
Status: RESOLVED FIXED    
Severity: normal CC: dabbott, robert
Priority: Highest    
Version: unspecified   
Hardware: All   
OS: All   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 308257    
Attachments: Updates to version 1.3.2 and includes attempts at fixing the python problems and some other small problems.
ssh-multiadd-1.3.1-r1.ebuild

Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2010-03-07 17:45:51 UTC
- If this package could support installation for multiple versions of Python,
  then please try to adjust the ebuilds to support it.
- Ensure that the ebuilds do not use deprecated functions or variables.
- Please check if Python 3 is supported by this package.
- If this package does not support Python 3:
  - Specify dependency on Python 2.
    You can use PYTHON_DEPEND helper variable, which should be set before
    inheriting of python eclass.
  - If this package cannot support installation for multiple versions of
    Python, then set active version of Python using
    python_set_active_version().
  - Ensure that shebangs in installed scripts specify correct version of
    Python. If shebangs are too generic (e.g. '#!/usr/bin/python'), then you
    can use python_convert_shebangs() to convert shebangs.
    (Wrapper scripts generated by python_generate_wrapper_scripts() do not
    require any changes.)

Please see documentation [1] for more details.
[1] http://www.gentoo.org/proj/en/Python/developersguide.xml
Comment 1 Robert R. Russell 2010-03-10 05:03:49 UTC
Created attachment 222949 [details, diff]
Updates to version 1.3.2 and includes attempts at fixing the python problems and some other small problems.

This patch updates ssh-multiadd to version 1.3.2, specifies a working version of python, and runs python_convert_shebangs on the python script.

This is a very basic attempt someone will need to double check it for accuracy.

The patch in ${FILESDIR} works with just a rename.
Comment 2 David Abbott gentoo-dev 2010-05-02 01:36:26 UTC
Created attachment 229969 [details]
ssh-multiadd-1.3.1-r1.ebuild
Comment 3 Ian Delaney (RETIRED) gentoo-dev 2011-11-12 08:10:11 UTC
re-assigned to python team. Please review
Comment 4 Maxim Koltsov (RETIRED) gentoo-dev 2011-11-12 19:49:13 UTC
Done, thanks Ian.