Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC

Bug 307251

Summary: dev-db/mysql-5.1.44-r1: GCC 4.3 or later checked too late
Product: Gentoo Linux Reporter: Sebastian Pipping <sping>
Component: New packagesAssignee: Gentoo Linux MySQL bugs team <mysql-bugs>
Status: RESOLVED INVALID    
Severity: normal CC: hppa, toolchain
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard: 2010/03/23: waiting for GCC bug
Package list:
Runtime testing required: ---

Description Sebastian Pipping gentoo-dev 2010-03-01 00:58:13 UTC
A build failure with

  "Active GCC too old! Must have at least GCC4.3"

is a bit late in my eyes.  How about a "!<sys-devel/gcc-4.3" blocker, instead?
Comment 1 Mark Loeser (RETIRED) gentoo-dev 2010-03-01 01:02:06 UTC
The blocker shouldn't be used since you should be able to have older versions of gcc installed at the same time.
Comment 2 Sebastian Pipping gentoo-dev 2010-03-01 01:10:34 UTC
Good point.  I guess we cannot require GCC as people may be using a different compiler?  Anything we could that dependency make conditional of?  Too bad there is no "gcc" use flag.  Other ideas?
Comment 3 Xake 2010-03-01 09:45:02 UTC
inherit toolchain

src_setup() {
if tc_version_is_at_least 4.3 || die "Active GCC too old! Must have at least GCC4.3"
}

Or is that too ugly? I think we do not really need to think about requiring gcc, as IIRC portage does not really handle anything else especially good.
Comment 4 Sebastian Pipping gentoo-dev 2010-03-01 16:10:17 UTC
Looking at the ebuild I find the line

DEPEND="|| ( >=sys-devel/gcc-4 >=sys-devel/gcc-apple-4 )"

If that's in there anyway why not bump it to gcc-4.3?
Btw why is GCC 4.3 required anyway?
Comment 5 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-03-01 20:03:52 UTC
(In reply to comment #3)
> src_setup() {
...
> }
The existing check is ALREADY in a pkg_setup block in the eclass. We can't have it any earlier.

(In reply to comment #4)
> DEPEND="|| ( >=sys-devel/gcc-4 >=sys-devel/gcc-apple-4 )"
> If that's in there anyway why not bump it to gcc-4.3?
> Btw why is GCC 4.3 required anyway?
I've just bumped the DEPEND, but that doesn't help the check, as the ACTIVE gcc still needs to be >=4.3.

C++ template use is why the newer GCC is required. 4.2 can work depending on which parts of the server you omit, but 4.3 is needed in general.

Comment 6 Jeroen Roovers gentoo-dev 2010-03-02 03:53:36 UTC
So the check was good, and the DEPEND now breaks HPPA.
Comment 7 Jeroen Roovers gentoo-dev 2010-03-02 03:53:59 UTC
  DEPEND.bad                    11
   dev-db/mysql/mysql-5.0.83.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.84.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.84-r1.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.87.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.88.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.90.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.90-r1.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.0.90-r2.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.1.39-r1.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.1.44.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
   dev-db/mysql/mysql-5.1.44-r1.ebuild: ~hppa(default/linux/hppa/10.0) ['>=sys-devel/gcc-4.3']
Comment 8 Ryan Hill (RETIRED) gentoo-dev 2010-03-02 04:29:53 UTC
if it's checked at configure time then that's early enough.
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-03-15 19:08:40 UTC
HPPA:
What should we do regarding you on the MySQL ebuilds?
Either we trace down the parts that actually need 4.3 and "fix" them to work with GCC 4.2, or we see about dropping the ~hppa keyword on the ebuilds that need a newer GCC.

What's the holdup for HPPA support on the newer GCC?
Comment 10 Mark Loeser (RETIRED) gentoo-dev 2010-03-15 19:22:01 UTC
(In reply to comment #9)
> What's the holdup for HPPA support on the newer GCC?

bug #272645
Comment 11 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-03-24 03:39:14 UTC
ok, that mask is in place, and i've also removed the ~hppa keywords to make repoman really happy as it was being cranky at me.
Comment 12 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2010-04-01 20:42:17 UTC
Ok, following a discussion with upstream https://lists.launchpad.net/maria-discuss/msg00116.html the actual code that was broken in 5.0.8[3-6] with older GCC versions was replaced in 5.0.87, and I have confirmed that it compiles even with hardened gcc 3.4.6, so I'm closing this as invalid now.
Comment 13 Jeroen Roovers gentoo-dev 2010-04-01 22:51:11 UTC
I removed the package.mask entries in arch/hppa profile.