Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 306431

Summary: gnome-base/gvfs-1.4.3 (and Gnome/Nautilus) cannot see or mount drives without gdu USE flag
Product: Gentoo Linux Reporter: Christophe <cjouny>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: chrissicool, djphazer, tdalman, wsheets
Priority: High Keywords: InVCS
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 288249    

Description Christophe 2010-02-22 20:30:36 UTC
As part of Gnome-2.28, the system installed without gdu USE flag is crippled and you cannot see or mount CD, DVD, USB. I am NOT talking about automount, just being able to see the drives icons in Nautilus.

Without gdu on, Nautilus does not show drive (CD, DVD, USB). 
As a consequence automount does not work either (checking the preferences has no effect) but of course it is fixed by use of +gdu flag.

My step-by-step debugging on the forums:
http://forums.gentoo.org/viewtopic-p-6182035.html#6182035

I am all for minimal system, but I think showing DVD drives and USB drives is now considered part of what the minimum system should do.

As gdu seems to be a new USE flag (I did not have it before), it should be on by default or at least a strong warning should be added in gvfs, nautilus and/or gnome ebuilds saying that functionality will be lost if gdu flag is not added.




Reproducible: Always

Steps to Reproduce:
1. compile gvfs without gdu USE flag
2. relog
3. 

Actual Results:  
Nautilus computer shows only the Filesystem icon and inserting a drive does nothing.

Expected Results:  
Empty DVD drives should show (as they do with +gdu) and USB drives on insertion.

emerge --info
Portage 2.1.7.16 (default/linux/amd64/10.0/desktop, gcc-4.3.4, glibc-2.10.1-r1, 2.6.31-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.31-gentoo-r6-x86_64-Intel-R-_Core-TM-_i7_CPU_920_@_2.67GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 22 Feb 2010 05:15:01 +0000
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.10
dev-lang/python:     2.6.4
dev-python/pycrypto: 2.1.0_beta1
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r5
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc:       3.4.6-r2, 4.1.2, 4.3.4
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA dlj-1.1"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://mirrors.tera-byte.com/pub/gentoo http://www.gtlib.gatech.edu/pub/gentoo "
LANG="C"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j1"
PKGDIR="/usr/local/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sabayon /usr/local/portage/overlays/main /usr/local/portage/overlays/edma"
SYNC="rsync://192.168.10.140/gentoo-portage"
USE="X a52 aac alsa amd64 apache2 applet audacious automount avahi bash-completion berkdb blas branding bzip2 cairo caps cdparanoia cdr cli consolekit cracklib cups cxx daap dbus device-mapper disk-partition divx dri dts dvd dvdr dvi emboss encode evo fam fbcondecor ffmpeg fftw firefox flac font-server foomaticdb fortran gdbm gdu gif gimp glitz glut gmedia gnome gpm gsf gstreamer gtk hal hddtemp iconv icotools id3tag jpeg kdrive lapack ldap libburn libnotify lm_sensors mad matroska mikmod mmkeys mmx modules mono mp3 mp4 mpeg mudflap multilib mysql nautilus ncurses network networkmanager nfs nonfsv4 nptl nptlonly nsplugin nvidia ogg ole openal opengl openmp pam pcre pdf perl plotutils png policykit ppds pppd pulseaudio pygrub python qt4 quicktime readline realmedia reflection samba screen sdl sensord server session skins slang smp sourceview spell spl sse sse2 ssl startup-notification stream svg sysfs syslog tcpd theora threads thunar thunderbird tiff totem truetype unicode usb v4l v4l2 vnc vorbis wav winetools wma wmp wxwindows x264 xine xinerama xml xorg xscreensaver xulrunner xv xvid xvmc zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2010-02-22 21:05:13 UTC
It does show drives, but only the mounted ones. What is the bug exactly about ? Do you mean there should be a documentation about this ? I certainly intend for this to be added to the migration guide, but otherwise no changes will be done to the ebuild since gvfs is used outside of gnome alone.
Comment 2 Christophe 2010-02-22 21:14:21 UTC
Yes it show mounted drives but automount does not work, and you cannot manually mount drives if icons does not show in Nautilus.

So:
- DVD drives should always show even if empty
- USB drives should appear when inserted (even if not automounted)
Comment 3 Christophe 2010-02-22 21:30:18 UTC
Sorry, I posted too fast. Let me clarify, there is 2 issues:

automount settings set in Nautilus are not applied if gdu is not use when building gvfs. That part is probably a bug. But that is not the goal of this report per se.

The main thing is  that the need for +gdu flag might be fixed by a documentation thing to say that Gnome needs gdu flag to work correctly, but due to the loss of functionality, I am afraid it will cause unnecessary uproar to have such basic functions removed because users would not have set that brand new USE flag. Therefore gnome/nautilus ebuilds should have the dependency set to gvfs with +gdu flag mandatory by default.
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-02-22 21:47:56 UTC
It's not been a problem for the months gnome 2.28 has been in ~arch. I think migration documentation will be enough.
Comment 5 Christophe 2010-02-22 22:30:50 UTC
My point, it will cause loss of functionality for users who upgrade without tweaking their /etc/make.conf... and I think it's a bad idea. I used Gentoo for 8 years and spent enough times on forums to say that this is one of the thing that really upset casual users when their system break and they loose functionality during an upgrade. 

PS: Gentoo website lacks any description of USE flag. The only site which does is http://gentoo-portage.com/USE and it's not up-to-date . gdu is not there. A default Gnome install should not require users to dig in such arcane matters.

Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-02-28 07:52:55 UTC
We should probably add a rdepend on gvfs[gdu] to gnome-base/gnome
Comment 7 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-03-06 21:41:55 UTC
(In reply to comment #6)
> We should probably add a rdepend on gvfs[gdu] to gnome-base/gnome
> 

I did this. Keeping this bug open so it can be noted in the migration documentation as well.
Comment 8 Christian Ludwig 2010-03-08 19:49:44 UTC
Perhaps you should add IUSE="+gdu" for gnome-base/gvfs as well, otherwise I got the following minor problem on "emerge -puvDN world":

emerge: there are no ebuilds built with USE flags to satisfy ">=gnome-base/gvfs-1.4.3[gdu]".
!!! One of the following packages is required to complete your request:
- gnome-base/gvfs-1.4.3 (Change USE: +gdu)
(dependency required by "gnome-base/gnome-2.28.2" [installed])
(dependency required by "world" [argument])

Adding the above IUSE automagically fixes that for me, since I did not set that USE-flag anywhere before explicitly.
Comment 9 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-03-08 20:16:27 UTC
(In reply to comment #8)
> Perhaps you should add IUSE="+gdu" for gnome-base/gvfs as well, otherwise I got
> the following minor problem on "emerge -puvDN world":
> 

I'm sorry, but that's on purpose. We can't add +gdu on gvfs because gnome guys aren't the only consumers of it. You probably want to look into the portage enhancement to auto-enable USE-deps implicitly (like pkgcore does).
Comment 10 Nicholas J. Michalek 2010-03-14 04:57:05 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Perhaps you should add IUSE="+gdu" for gnome-base/gvfs as well, otherwise I got
> > the following minor problem on "emerge -puvDN world":
> > 
> 
> I'm sorry, but that's on purpose. We can't add +gdu on gvfs because gnome guys
> aren't the only consumers of it. You probably want to look into the portage
> enhancement to auto-enable USE-deps implicitly (like pkgcore does).
> 

After several times of being frustrated with these USE flag dependencies halting my world updates, the latest being this gnome/gvfs/gdu thing, it is clear to me that a standard package manager feature - automatic dependecy resolution - is crippled in portage. Thus, I am a strong proponent of this implicit USE-dep-auto-enabling enhancement you speak of. In fact, I woudn't consider it an "enhancement"; I would rather call it a missing part of the USE-deps feature that should have been there at its inception. But alas, I suppose hindsight makes things clearer now, eh? =)

Anyway, is there an open bug for it? A quick search didn't find it.
Comment 11 Nirbheek Chauhan (RETIRED) gentoo-dev 2010-03-14 12:00:00 UTC
(In reply to comment #10)
> After several times of being frustrated with these USE flag dependencies
> halting my world updates, the latest being this gnome/gvfs/gdu thing, it is
> clear to me that a standard package manager feature - automatic dependecy
> resolution - is crippled in portage. Thus, I am a strong proponent of this
> implicit USE-dep-auto-enabling enhancement you speak of. In fact, I woudn't
> consider it an "enhancement"; I would rather call it a missing part of the
> USE-deps feature that should have been there at its inception. But alas, I
> suppose hindsight makes things clearer now, eh? =)
> 
> Anyway, is there an open bug for it? A quick search didn't find it.
> 

You're looking for bug 256519
Comment 12 Pacho Ramos gentoo-dev 2010-04-14 16:11:27 UTC
Already in upgrade guide:
http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.28-upgrade.xml
Comment 13 walt 2010-11-08 00:18:56 UTC
Meanwhile gvfs is up to 1.6.3, and I find that the gdu USEFLAG with gvfs actually breaks automounting (gnome is now at 2.30.2).

If I compile gvfs with -gdu, then all of my long-missing disks re-appear on my desktop, including hotplugged usb drives and newly inserted cd/dvd media.

At this point (7 Nov 2010) the mandatory gdu USEFLAG is causing me great headaches when updating gnome packages.

This is now an old bug report, but I'm hoping that someone can give me a pointer to another (newer?) bug report dealing with this problem.

Thanks!