Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 305529

Summary: app-text/poppler-0.12.3-r5 causes pdflatex to segfault
Product: Gentoo Linux Reporter: Bernd Feige <Bernd.Feige>
Component: Current packagesAssignee: Desktop Misc. Team <desktop-misc>
Severity: normal CC: tex
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---
Attachments: emerge --info

Description Bernd Feige 2010-02-17 13:14:15 UTC
Downgrading to poppler-0.12.3-r3 fixes this.
gdb /usr/bin/pdflatex and running the tex file yields:
#0  0xb7b6d48b in strlen () from /lib/
#1  0xb7e72ba4 in GlobalParams::scanEncodingDirs() () from /usr/lib/
#2  0xb7e72b3e in GlobalParams::GlobalParams(char const*) () from /usr/lib/

Comment 1 Samuli Suominen (RETIRED) gentoo-dev 2010-02-17 23:39:25 UTC
I assume pdflatex is a symlink to pdftex from texlive-core? Have you tried rebuilding it? 

And for good measure, please post emerge --info
Comment 2 Bernd Feige 2010-02-18 08:26:57 UTC
Created attachment 220143 [details]
emerge --info
Comment 3 Bernd Feige 2010-02-18 08:50:14 UTC
(In reply to comment #1)

Thanks for the response!

> I assume pdflatex is a symlink to pdftex from texlive-core?

lrwxrwxrwx 1 root root 6 17. Feb 13:28 /usr/bin/pdflatex -> pdftex

> Have you tried rebuilding it? 

Oops, I did rebuild dev-texlive/texlive-latex-2009 since pdflatex belongs to that but not texlive-core... When rebuilding that, the crash is fixed.

Thanks again and best regards,