Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 3029

Summary: emerge postgresql does not work unless java is already setup
Product: Gentoo Linux Reporter: Scott Brooks <scottbrooks>
Component: [OLD] DevelopmentAssignee: Matthew Kennedy (RETIRED) <mkennedy>
Severity: normal CC: esigra, patrickn
Priority: Normal    
Version: 1.1a   
Hardware: x86   
OS: Linux   
Package list:
Runtime testing required: ---

Description Scott Brooks 2002-05-25 12:13:39 UTC
I did an emerge --pretend postgresql
and it listed that it needed to emerge blackdown, and ant, 
then postgresql
I ran emerge postgresql, and walked away for a bit.
When I came back, it was 
waiting at the checking to see if ant works stage.
I switched to a different console, and ran 
/usr/bin/ant  I reported an error about java not being setup right, but it didnt drop me back to my 
prompt, I needed to hit ctrl-c to get back.  This is the stage that was hanging in the ./configure for 

To Fix it I needed to properly set my java-config --set-system-vm to blackdown, then 
re emerge ant.
After I did that it worked fine.
It looks to me that the compile of ant may be 
returning a 0 instead of a error code if it's compile doesnt work because since my java was not set 
properly, it should have errored out at that stage.
Comment 1 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2002-05-28 14:05:15 UTC
This is a known issue. Fix will be implemented shortly. Hang in there.
Comment 2 Karl Trygve Kalleberg (RETIRED) gentoo-dev 2002-06-24 20:35:24 UTC
I have fixed this for blackdown-jdk-1.3.1-r7 and kaffe-1.0.7_rc1, by creating an
eclass that fixes most of the trivial details.

If you have the time to handle blackdown-jre, sun-{jdk,jre}, ibm-{jdk,jre},
that'd be grand!
Comment 3 Robert Blyler 2002-07-14 17:40:10 UTC
FYI - If you take java out of your use statement it should work.  You only need
to set up java first if you requested java support, or use "-java".
Comment 4 Matthew Kennedy (RETIRED) gentoo-dev 2002-10-21 02:32:08 UTC
i think this has already been fixed.