Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 300918

Summary: net-libs/xulrunner-1.9.1.7 fails to build on FreeBSD prefix
Product: Gentoo Linux Reporter: Christian Faulhammer (RETIRED) <fauli>
Component: New packagesAssignee: Mozilla Gentoo Team <mozilla>
Status: RESOLVED CANTFIX    
Severity: normal CC: prefix
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Christian Faulhammer (RETIRED) gentoo-dev 2010-01-13 22:29:26 UTC
It fails with "Dl_info not in this scope" in line 1554 of xpcom/base/nsStackWalk.cpp.  This can be fixed by including dlfcn.h unconditionally and adding the __BSD_VISIBLE define to Makefile.in.  It cannot be passed through CXXFLAGS as it is not respected in that directory.  Or can you provide a sane fix?
Comment 1 Jory A. Pratt gentoo-dev 2010-01-14 00:19:01 UTC
Please get with aballier he has patches already avaliable, there are more issues then just this, current state with aballier's patches still cause a bus error.
Comment 2 Jory A. Pratt gentoo-dev 2010-01-14 00:36:05 UTC
I should also note that this version is already known to be even more busted, the patches he has are for 1.9.2 version which does not use -xtype which breaks fbsd anyways.
Comment 3 Jory A. Pratt gentoo-dev 2010-01-14 00:39:35 UTC
Seems I have slip'd and forgotten about an already open bug.

*** This bug has been marked as a duplicate of bug 275807 ***
Comment 4 Alexis Ballier gentoo-dev 2010-01-14 08:05:52 UTC
fyi, the patch for this is: http://dev.gentoo.org/~aballier/libdl.patch
Comment 5 Fabian Groffen gentoo-dev 2010-01-14 09:56:41 UTC
Prefix does not have this -xtype problem (xulrunner builds fine on Solaris here).  This bug is about libdl, as the patch from aballier is supposed to fix.

Fauli, does that patch allow you to compile?  If so, let's add it.
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-14 12:29:13 UTC
(In reply to comment #5)
> Prefix does not have this -xtype problem (xulrunner builds fine on Solaris
> here).  This bug is about libdl, as the patch from aballier is supposed to fix.
> 
> Fauli, does that patch allow you to compile?  If so, let's add it.


 It does.  I knew that the underlying problem had to do with dl detection...great.
Comment 7 Fabian Groffen gentoo-dev 2010-01-14 12:33:52 UTC
can you commit this patch to the prefix repo then?
Comment 8 Christian Faulhammer (RETIRED) gentoo-dev 2010-01-14 12:51:37 UTC
(In reply to comment #7)
> can you commit this patch to the prefix repo then?

 In my eyes it should be safe for everyone...so what about XULRunner patchset for Gentoo?  On the other hand Mozilla won't start on FreeBSD anyway, the fbsd project has the same problems (says Alexis).  So I am reluctant to add keywords for all this.
Comment 9 Fabian Groffen gentoo-dev 2010-01-14 12:55:35 UTC
No sense in committing if it still doesn't work, obviously.
Comment 10 Jory A. Pratt gentoo-dev 2010-01-19 04:25:36 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > can you commit this patch to the prefix repo then?
> 
>  In my eyes it should be safe for everyone...so what about XULRunner patchset
> for Gentoo?  On the other hand Mozilla won't start on FreeBSD anyway, the fbsd
> project has the same problems (says Alexis).  So I am reluctant to add keywords
> for all this.
> 

Patch is included in 1.9.2/3.6 avaliable via mozilla overlay, all efforts should be concentrated there, I plan to move to tree in with rc3.
Comment 11 Christian Faulhammer (RETIRED) gentoo-dev 2010-02-24 10:35:16 UTC
It builds, but still does not work now...