Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 294618

Summary: kde-base/kmail-4.4.5 multiple item selection in message list sometimes wrong
Product: Gentoo Linux Reporter: Rick Jenkins <rick>
Component: [OLD] KDEAssignee: Gentoo KDE team <kde>
Status: RESOLVED FIXED    
Severity: normal Flags: tampakrap: Bugday+
Priority: High    
Version: unspecified   
Hardware: x86   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description Rick Jenkins 2009-11-25 17:21:59 UTC
When selecting multiple items in the kmail message list, as for instance to delete trash, I select the first item, then the last while holding <shift> down. This usually works when selecting a small numner of items, say two to five. When selecting a larger number of items, two forms of misbehaviour seem common:

  1. The selection is inverted, so that all items which I intended to be unselected are marked as selected.

  2. The first item, and two or three items following the last item, are marked as selected. 

I have never had any selection problems prior to the KDE4 "stable" upgrade. I never tried KDE4 until it was marked "stable"

Reproducible: Sometimes
Comment 1 Andreas K. Hüttel gentoo-dev 2010-04-03 16:42:00 UTC
Does this still happen with current stable 4.3.5?
Comment 2 Rick Jenkins 2010-04-03 17:07:38 UTC
Yes, behaviour in stable 4.3.5 is unchanged
Comment 3 Andreas K. Hüttel gentoo-dev 2010-04-04 17:34:18 UTC
Similar but not identical to the following upstream bug:
https://bugs.kde.org/show_bug.cgi?id=201770
Comment 4 Andreas K. Hüttel gentoo-dev 2010-05-17 21:56:01 UTC
Seems to work here with 4.4.3...
Comment 5 Andreas K. Hüttel gentoo-dev 2010-05-28 20:23:11 UTC
No duplicates with more recent kde versions for a long time, so I'm removing the kde-4.4.2 block.
Comment 6 Andreas K. Hüttel gentoo-dev 2010-08-19 19:07:58 UTC
Looks like this is fixed in kmail-4.4.x ...

Please reopen if the problem reoccurs.
Comment 7 Rick Jenkins 2010-08-19 19:18:47 UTC
My kmail gives its version as:
KMail Version 1.13.5 Using KDE Development Platform 4.4.5 (KDE 4.4.5)
and I updated my system two days ago. The bug is present, unchanged, in this version.
Comment 8 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-30 12:02:48 UTC
still reproducable with kde 4.5?
Comment 9 Rick Jenkins 2010-12-30 17:59:38 UTC
This bug seems no longer present, although the KDE version and kmail version numbers are unchanged from comment #7 above. My thanks to the unknown bug fixer.