Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 293374

Summary: mail-client/mail-notification-5.4 fails to compile with mail-client/evolution-2.28
Product: Gentoo Linux Reporter: Ahmed Ammar (RETIRED) <b33fc0d3>
Component: Current packagesAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: major CC: gnome, graaff, matrix47, nicolasbock, travisghansen
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
URL: https://bugzilla.gnome.org/show_bug.cgi?id=597552
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 288249    
Attachments: Add required compiler flags.
Actual fix.

Description Ahmed Ammar (RETIRED) gentoo-dev 2009-11-16 11:41:27 UTC
Patch to explicitly add the required clfags/ldflags when compiling the evolution plugin.
Comment 1 Ahmed Ammar (RETIRED) gentoo-dev 2009-11-16 11:42:55 UTC
Created attachment 210384 [details, diff]
Add required compiler flags.
Comment 2 Ahmed Ammar (RETIRED) gentoo-dev 2009-11-16 12:05:50 UTC
*** Bug 292018 has been marked as a duplicate of this bug. ***
Comment 3 Ahmed Ammar (RETIRED) gentoo-dev 2009-11-16 12:09:29 UTC
Hmm, this seems to actually be an evolution-plugins.pc issue, maybe I fixed it too soon.

https://bugs.launchpad.net/ubuntu/+source/evolution/+bug/443406
http://launchpadlibrarian.net/33125912/evo-dev-dependencies.diff

Fix it as you please.
Comment 4 Ahmed Ammar (RETIRED) gentoo-dev 2009-11-16 12:12:22 UTC
Created attachment 210386 [details, diff]
Actual fix.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-11-16 12:39:50 UTC
As said in the upstream bug report, those dependencies should not be in evolution-plugin.pc.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-11-16 12:42:33 UTC
fixing summary and adding graaff back.
Comment 7 Hans de Graaff gentoo-dev 2009-11-16 18:18:37 UTC
(In reply to comment #5)
> As said in the upstream bug report, those dependencies should not be in
> evolution-plugin.pc.

As far as I can tell from the upstream bug they should not be there for 2.29 and better (due to there being an evolution-mail.pc). But for 2.28 the case is less clear. I guess the alternatives are:

1. fix evolution-plugin.pc for 2.28
2. backport evolution-mail.pc from 2.29 and fix mail-notification to use it
Comment 8 Pacho Ramos gentoo-dev 2010-03-06 11:13:36 UTC
Fedora opted to fix it in mail-notification instead :-/ (Hans, I would also take a look on mail-notification fedora packages since they have also included some patches to make it work ok with evolution-2.30...):
http://cvs.fedoraproject.org/viewvc/devel/mail-notification/mail-notification-5.4-evolution-gtkhtml.patch?revision=1.2&content-type=text/plain&view=co
Comment 9 Pacho Ramos gentoo-dev 2010-03-12 11:23:22 UTC
(In reply to comment #8)
> Fedora opted to fix it in mail-notification instead :-/ (Hans, I would also
> take a look on mail-notification fedora packages since they have also included
> some patches to make it work ok with evolution-2.30...):
> http://cvs.fedoraproject.org/viewvc/devel/mail-notification/mail-notification-5.4-evolution-gtkhtml.patch?revision=1.2&content-type=text/plain&view=co
> 

I will apply this patch Sunday if nobody disagrees
Comment 10 Pacho Ramos gentoo-dev 2010-03-19 11:14:25 UTC
+*mail-notification-5.4-r2 (19 Mar 2010)
+
+  19 Mar 2010; Pacho Ramos <pacho@gentoo.org>
+  +mail-notification-5.4-r2.ebuild,
+  +files/mail-notification-5.4-e-d-s.patch,
+  +files/mail-notification-5.4-evolution-gtkhtml.patch,
+  +files/mail-notification-5.4-gmime.patch,
+  +files/mail-notification-5.4-sasl_encode64.patch:
+  Sync with Fedora to fix bug 293374, fix building against different and
+  upcoming eds versions in a better way, use new cyrus-sasl ABI and build
+  against latest gmime.