Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 293247

Summary: gnome-extra/polkit-gnome-0.95 parallel build failure
Product: Gentoo Linux Reporter: Steffen Hau <steffen>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: dabbott, ed, kanelxake
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 288249    
Attachments: parallel-build-docs.patch
MAKEOPTS.patch

Description Steffen Hau 2009-11-15 04:29:05 UTC
Merging of gnome-extra/polkit-gnome-0.95 fails with:

make[2]: Entering directory `/var/tmp/portage/gnome-extra/polkit-gnome-0.95/work/polkit-gnome-0.95/docs'
gtk-doc: Scanning header files
make[2]: *** No rule to make target `polkit-gtk-1-docs.xml', needed by `html-build.stamp'.  Stop.
make[2]: *** Waiting for unfinished jobs....

Unsetting MAKEOPTS (formerly -j4) did the trick.

Reproducible: Always
Comment 1 Patrick Lauer gentoo-dev 2009-11-15 09:37:34 UTC
emerge --info please
Comment 2 Steffen Hau 2009-11-15 16:16:08 UTC
Sorry,

I thought the info with the MAKEOPTS would be enough. Here it comes:

Portage 2.2_rc49 (default/linux/x86/10.0, gcc-4.4.2, glibc-2.11-r0, 2.6.32-rc6-HAUIHAU i686)
=================================================================
System uname: Linux-2.6.32-rc7-HAUIHAU-i686-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-gentoo-2.0.1
Timestamp of tree: Sun, 15 Nov 2009 04:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p35
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.4, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r2
sys-apps/sandbox:    2.2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -fomit-frame-pointer -mfpmath=sse -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fakeroot fixpackages metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo/ "
LANG="de_DE.utf8"
LC_ALL="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-znow -Wl,--sort-common -s"
LINGUAS="de"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sectools /usr/local/portage/layman/gnome /usr/local/portage/layman/x11 /usr/local/portage/layman/hauihau"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac aalib acl acpi alsa apache2 bash-completion berkdb bidi bluetooth branding bzip2 cairo cdb cdda cddb cdparanoia cdr cli cracklib crypt ctype cups curl dbus dedicated dga directfb doc dri dts dv dvd dvdr dvdread encode examples exif ffmpeg firefox flac fontconfig foomaticdb fortran ftp gdbm gif glitz glut gmp gnome gnome-keyring gnutls gphoto2 gstreamer gtk gtk2 hal htmlhandbook iconv ieee1394 imagemagick imap imlib innodb ipod ipv6 java java5 java6 javascript jpeg jpeg2k kde lame lcms ldap libcaca libnotify libsamplerate lua mad mikmod mmap mmx mng modules mono mp3 mpeg mplayer mudflap musepack musicbrainz mysql ncurses nls noseamonkey nptl nptlonly nsplugin offensive ogg openal opengl openmp oscar pam pcmcia pcre pdf perl php plasma png policykit posix ppds pppd python qt4 quicktime readline reflection rss rtc ruby samba sasl sdl session sndfile snmp sockets spell spl sqlite sse sse2 ssl startup-notification subversion svg sysfs tcl tcpd theora threads tiff tk truetype unicode usb userlocales v4l2 vcd vim-syntax visualization vorbis win32codecs x264 x86 xattr xcb xcomposite xine xinerama xml xorg xosd xpm xscreensaver xulrunner xv xvid yahoo zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_ftp proxy_http rewrite setenvif so speling status substitute unique_id userdir usertrack version vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon casio_qv fuji kodak konica minolta mustek panasonic samsung sonydscf1 sonydscf55 toshiba" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPT
Comment 3 Xake 2009-11-18 12:28:42 UTC
(In reply to comment #2)
> Sorry,
> 
> I thought the info with the MAKEOPTS would be enough. Here it comes:
> 

Always post emerge --info, as this bug is only replicable here with USE="doc" and verifying if you have this use-flag or any other suspicion of the cause is much easier in a emerge --info then have to ask for every detail.
Comment 4 Yu Yuwei 2009-11-19 02:03:07 UTC
same here with distcc and -j5:

emerge --info:
/distributions/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://ftp.swin.edu.au/gentoo"
LANG="zh_CN.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,--as-needed"
LINGUAS="zh_CN en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/openmoko/trunk/openmoko-target /usr/portage/local/layman/desktop-effects /usr/portage/local/layman/sunrise /usr/portage/local/layman/mpd /usr/portage/local/layman/acevery /usr/portage/local/layman/gentoo-china /usr/portage/local/layman/acevery-openmoko"
SYNC="rsync://59.77.33.199/gentoo-portage"
USE="16Bit X a52 aac acl acpi aiglx alsa asf avahi bash-completion beagle berkdb branding browserplugin bzip2 bzr cairo caps cdr chm cjk cleartype cli consolekit cracklib crypt cups custom-cflags custom-cpuopts custom-optimization dbus djvu dmx dri dts dvd dvdnav dvdr dvdread emboss evo exif faac faad fam fbcon fbcondecor fbsplash ffmpeg fifo flac fontconfig fontforge fortran fuse gdbm gif gimp git glib gmp gnome gnome-keyring gnutls gphoto2 gpm gstreamer gtk gtk2 gucharmap guile hal i8x0 iconv icu id3 ieee1394 imap iptc ipv6 jack jadetex java jpeg jpeg2k kerberos kpathsea lame latex lcms ldap libffi libmms libnotify libsamplerate lunar lzo mad midi mikmod mmap mmx modules mp3 mp4 mpeg msn mudflap nautilus ncurses nls nntp nptl nptlonly nsplugin ogg opengl openmp openssl pam pango pcmcia pcre pdf perl pic png policykit ppds pppd pulseaudio python qq qt3support quicktime raw readline reflection ruby samba scanner sdl session sound spell spl sqlite sqlite3 sse sse2 ssl startup-notification subversion svg sysfs taglib tcl tcltk tcpd tetex theora threads thunar tiff tk truetype unicode usb vcd vim vim-syntax vim-with-x vorbis wav wifi win32codecs winbind wma wmf wmp x264 x86 xattr xcb xcomposite xine xinerama xml xorg xprint xulrunner xv xvid zlib" ALSA_CARDS="intel8x0 intel8x0m emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" ELIBC="glibc" FOO2ZJS_DEVICES="hp1020 hpp1008" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean debug_commands envparser find fmon fstat history idleprobe initctl interactive iparser last limit lockfile logfile netdev netprobe ngc4 ngcs nge pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded usplash service_cache" INPUT_DEVICES="synaptics evdev keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="zh_CN en_US" QEMU_SOFTMMU_TARGETS="arm" QEMU_USER_TARGETS="arm" SANE_BACKENDS="snapscan" USERLAND="GNU" VIDEO_CARDS="intel" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 5 Yu Yuwei 2009-11-19 02:11:48 UTC
sorry, my problem is missing /usr/lib/libGL.la...
Comment 6 Juergen Rose 2009-11-19 14:26:38 UTC
same here with -j2
Comment 7 Ed Catmur 2009-11-22 17:50:34 UTC
Problem is that polkit-gtk-1-docs.xml ends up in EXTRA_DIST only if ENABLE_GTK_DOC is set.

Upstream have disted the package without --enable-gtk-doc, so polkit-gtk-1-docs.xml is omitted from the tarball.  This is primarily upstream's fault - it's their responsibility to make sure that the package builds - but it is rather sucky on gtk-doc's part as well, as there's no real reason for this behaviour.

Two possible workarounds: manually build polkit-gtk-1-docs.xml before the main build, or inject a dependency into the docs Makefile.
Comment 8 Ed Catmur 2009-11-22 17:51:12 UTC
1. Suggested stanza to prebuild polkit-gtk-1-docs.xml:

src_compile() {
	# docs/polkit-gtk-1-docs.xml has been left out of the package, so build it
	# http://bugs.gentoo.org/show_bug.cgi?id=293247
	if use doc; then
		emake -C polkitgtk || die "compile failure"
		emake -C docs sgml-build.stamp || die "compile failure"
	fi

	gnome2_src_compile
}
Comment 9 Ed Catmur 2009-11-22 17:53:21 UTC
Created attachment 210907 [details, diff]
parallel-build-docs.patch

Inject a dependency into docs Makefile to build polkit-gtk-1-docs.xml:

$(DOC_MAIN_SGML_FILE): sgml-build.stamp
Comment 10 Ed Catmur 2009-11-22 18:02:40 UTC
Found an upstream bug (for the general gtk-doc issue, not for polkit-gnome) at https://bugzilla.gnome.org/show_bug.cgi?id=592355
Comment 11 David Abbott gentoo-dev 2009-12-12 17:11:01 UTC
Created attachment 212800 [details, diff]
MAKEOPTS.patch

Same patch that is used in gnome-user-docs.
Comment 12 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-12-27 03:26:52 UTC
(In reply to comment #9)
> Created an attachment (id=210907) [details]
> parallel-build-docs.patch
> 
> Inject a dependency into docs Makefile to build polkit-gtk-1-docs.xml:
> 
> $(DOC_MAIN_SGML_FILE): sgml-build.stamp
> 

Thanks for the patch, added to 0.95