Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 292984

Summary: app-arch/file-roller 2.28.1 cannot open RPM files because of rpm2cpio-file-roller hack
Product: Gentoo Linux Reporter: Vaclav Slavik <vslavik>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal    
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 288249    
Attachments: patch to fix the ebuild

Description Vaclav Slavik 2009-11-13 07:50:46 UTC
Trying to open a RPM file in file-roller 2.28.1 results in this error:

    sh: /usr/libexec/file-roller/rpm2cpio-file-roller: No such file or directory

Gentoo ebuild has a hack to use rpm2cpio-file-roller script to avoid dependency on rpm2cpio. But file-roller 2.28 introduced its own custom rpm2cpio binary, installed in /usr/libexec/file-roller, so this hack is not needed anymore.

The error occurs (and wasn't caught), because the ebuild uses a sed command to change "rpm2cpio" occurences in the sources into "rpm2cpio-file-roller". If it were done with a proper patch, this would be caught sooner.

Patch to fix the ebuild attached. 

Reproducible: Always

Steps to Reproduce:
Comment 1 Vaclav Slavik 2009-11-13 07:51:04 UTC
Created attachment 210108 [details, diff]
patch to fix the ebuild
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-11-13 08:55:29 UTC
so instead of having rpm2cpio available for the whole system, they moved it out of sight. Does not sound like a real enhancement to me.
Comment 3 Vaclav Slavik 2009-11-13 09:19:12 UTC
They can, of course, not install rpm2cpio system-wide, because it would conflict with existing rpm2cpio. If you cared to look at the sources, you'd see it's a tiny file-roller-specific binary, /usr/libexec/ is an entirely appropriate location for it. All that is irrelevant anyway: upstream file-roller works, Gentoo changes break it and need fixing, period.

Frankly, I don't see what your problem is. By using a custom tiny program to (among other things) avoid dependency on rpm2cpio, THEY DO THE EXACT SAME THING THAT GENTOO EBUILD DID. So you could just as well target your derogatory comments back at Gentoo.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-11-13 09:44:21 UTC
I would advise you to tone down your comments. I never said I had a problem with the upstream change, just that it looked technically strange (ok might not be obvious at first sight but certainly doesn't need that kind of reply).
Comment 5 Romain Perier (RETIRED) gentoo-dev 2009-11-13 22:04:38 UTC
@Vaclav: heh, this is not a teenagers forum here. This is a bugzilla, in other words a place where you're able to share your experience with developers.
So please tone down your comments.

derogatory comment != what we think.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-12-13 23:06:40 UTC
+  13 Dec 2009; Gilles Dartiguelongue <eva@gentoo.org>
+  file-roller-2.28.1.ebuild:
+  Fix rpm support, many thanks to Vaclav, bug #292984.
+
Fixed without a bump, thanks for reporting.