Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 291329

Summary: media-video/totem-2.28.1 needs to depend on docbook-xml-dtd-4.5
Product: Gentoo Linux Reporter: Alexander E. Patrakov <patrakov>
Component: [OLD] GNOMEAssignee: Gentoo Linux Gnome Desktop Team <gnome>
Status: RESOLVED FIXED    
Severity: normal CC: public
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on:    
Bug Blocks: 288249    

Description Alexander E. Patrakov 2009-10-31 17:04:12 UTC
Without docbook-xml-dtd-4.5 installed, media-video/totem-2.28.1 fails to build. First it tries to access internet during the documentation build, and then fails with:

xsltproc -o totem-sv.omf --stringparam db2omf.basename totem --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "
-//OASIS//DTD DocBook XML V4.5//EN" --stringparam db2omf.lang sv --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam 
db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "/home/build/portage/media-video/totem-2.28.1/work/totem-
2.28.1/help/totem.omf.in"  `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` sv/totem.xml || { rm -f "totem-sv.omf"; ex
it 1; }
xsltproc -o totem-uk.omf --stringparam db2omf.basename totem --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "
-//OASIS//DTD DocBook XML V4.5//EN" --stringparam db2omf.lang uk --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam 
db2omf.help_dir "/usr/share/gnome/help" --stringparam db2omf.omf_in "/home/build/portage/media-video/totem-2.28.1/work/totem-
2.28.1/help/totem.omf.in"  `/usr/bin/pkg-config --variable db2omf gnome-doc-utils` uk/totem.xml || { rm -f "totem-uk.omf"; ex
it 1; }
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %list.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %admon.class; not found
                %local.divcomponent.mix;">
                                         ^
<snip more parser warnings of the same type>
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser warning : PEReference: %info.class; not found
<!ELEMENT setinfo %ho; ((%info.class;)+)
                                     ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : ContentDecl : Name or '(' expected
<!ELEMENT setinfo %ho; ((%info.class;)+)
                                     ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : expected '>'
<!ELEMENT setinfo %ho; ((%info.class;)+)
                                       ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : Content error in the external subset
<!ELEMENT setinfo %ho; ((%info.class;)+)
                                       ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser warning : PEReference: %beginpage.exclusion; not found
                %beginpage.exclusion;>
                                     ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : Content error in the external subset
                %beginpage.exclusion;>
                                     ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
 ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
    ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: validity error : All markup of the conditional section is not in the same entity
<!--end of setinfo.element-->]]>
    ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:238: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
        ^
unable to parse pl/totem.xml

http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %linespecific.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %synop.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %para.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %informal.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %formal.class; not found
                %local.divcomponent.mix;">
                                         ^
http://www.oasis-open.org/docbook/xml/4.5/dbhierx.mod:115: parser warning : PEReference: %compound.class; not found
                %local.divcomponent.mix;">
                                         ^
Installing docbook-xml-dtd 4.5 allowed the build to succeed.

Reproducible: Didn't try
Comment 1 Sebastian Luther (few) 2009-11-01 19:21:46 UTC
*** Bug 291379 has been marked as a duplicate of this bug. ***
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-11-01 20:44:21 UTC
+  01 Nov 2009; Gilles Dartiguelongue <eva@gentoo.org> totem-2.28.1.ebuild:
+  Add missing docbook-xml-dtd:4.5, bug #291329.
+
Fixed without a bump, thanks for reporting.