Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 290366

Summary: sys-fs/btrfs-progs-0.19: Missing symlink btrfsck -> fsck.btrfs
Product: Gentoo Linux Reporter: haarp <main.haarp>
Component: [OLD] Core systemAssignee: Joe Peterson (RETIRED) <lavajoe>
Status: RESOLVED CANTFIX    
Severity: normal CC: blshkv, bugs_gentoo_org.Tim_OKelly, timmy
Priority: High    
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---

Description haarp 2009-10-24 12:09:10 UTC
The ebuild doesn't add a symlink from btrfsck to fsck.btrfs. If a btrfs volume is set to be checked on boot in fstab, the system tries to execute fsck.btrfs but fails since it can't be found.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-24 12:35:35 UTC
Well, it seems like this symlink was omitted on purpose. If you look into the btrfs-progs ebuilds you will find the following comment in src_install():

  # fsck will segfault if invoked at boot, so do not make this link
  #dosym btrfsck /sbin/fsck.btrfs

Of course you can maybe check if this is still true for latest btrfsck by creating the symlink manually and make the system doing a fsck on the next reboot (shutdown -F -r now).

Reassigning to the btrfs-progs maintainer as he might shed some light on this.
Comment 2 haarp 2009-10-25 20:07:40 UTC
I just booted with the symlink and fsck.btrfs seemed to have worked just fine.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-27 06:11:03 UTC
I now had the time to do some testing with a btrfs-partition and there's still a (maybe small) problem. btrfsck doesn't accept any commandline options other than the partition to check which results in error messages when fsck.btrfs gets invoked at boot (Could not open -p).
Comment 4 haarp 2010-01-28 13:01:28 UTC
You're right. The problem is still there. I guess it's up to upstream to fix that
Comment 5 Joe Peterson (RETIRED) gentoo-dev 2010-01-31 01:56:48 UTC
Hey guys, yes, I had the symlink there originally, but because of the segfault, I removed it.  Better at this point to do manual fsck's if you need to.  But if upstream improves this, feel free to reopen this bug.

Btrfs is not *supposed* to need regular fsck's anyway, AFAIK.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2010-07-10 07:19:07 UTC
*** Bug 327663 has been marked as a duplicate of this bug. ***
Comment 7 Pavel Volkov 2013-03-26 06:49:30 UTC
I had created the symlink and fs check at boot went without errors (used systemd as init system).